LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-02-2007, 03:14 PM   #1
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,596
Blog Entries: 1

Rep: Reputation: 1046Reputation: 1046Reputation: 1046Reputation: 1046Reputation: 1046Reputation: 1046Reputation: 1046Reputation: 1046
jackd -R -d alsa -d hw:1 - second sound card


Hi

I use Studio 64 (Debian based distro). I have managed to get my external sound card
working (sort of) After some configuration of the programs like audacity, hydrogen, etc. I can hear sound coming out of it (Btw, it's a usb tascam us 122). However, there is no sound in programs like ardour and rosegarden (I have some soundfonts)

Question 1:

How can I change the card system-wide, so that I would connect the speakers to my tascam, not the on-board card.

Question 2:

Before running ardour, rosengarden one needs to start jack. When I start it normally everything is fine, I can run rosegarden, I can see my card recognised in settings, etc.
However, when I run jack and specify the second card I got the error:


Code:
sycamorex@64studio:~$ jackd -R -d alsa -d hw:1
jackd 0.102.20
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
creating alsa driver ... hw:1|hw:1|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:1
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
cannot load driver module alsa
Segmentation fault
Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card conflict with Vid-Capture card ALSA Optimistic Debian 5 11-06-2007 12:20 AM
jackd 0.99.0 + alsa 1.0.11 = xrun after every frame Yury Linux - Software 0 08-06-2006 09:18 AM
ALSA not working. (jackd) kaz2100 Linux - Software 7 04-07-2006 03:51 PM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 02:02 PM
No sound with a CM8738 sound card -- alsa installed istar80 Linux - Hardware 1 06-17-2005 03:02 PM


All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration