LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-01-2008, 01:13 AM   #1
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 408

Rep: Reputation: 30
jackd and alsa hwmon on an m-audio mobilepre


i see a setting in the jack demon for the direct audio monitoring, but it is not working when i set the -H flag. im using alsa hw0:0 for both capture and playback, my systems an old piece so im using 32000 -S for 16 instead of 32 and also 512 frames instead of 1024.

is it a kernel issue since i am using the 2.6.24.5-huge-smp? is it a driver issue since i just pluged it and played it? real time monitoring would be really really really cool. suggestions and comments welcome. =)
 
Old 10-07-2008, 02:36 AM   #2
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 408

Original Poster
Rep: Reputation: 30
this is the jack command i am building to use

Code:
jackd -d alsa -H --hwmon
this command does not work (yet with my device)

this next one works way better

Code:
jackd -d alsa -n 4
with this one i can software monitor with out xruns. -n 3 would x run on occastion. still hammering out the details.
 
Old 10-07-2008, 03:06 AM   #3
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 408

Original Poster
Rep: Reputation: 30
im working on

Code:
jackd -d alsa -n 4 -H -C hw:0,0 -P hw:0,0 -p2048
this one is somewhat laggy but absolutely NO xruns =D
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
jackd -R -d alsa -d hw:1 - second sound card sycamorex Linux - Hardware 0 05-02-2007 02:14 PM
jackd 0.99.0 + alsa 1.0.11 = xrun after every frame Yury Linux - Software 0 08-06-2006 08:18 AM
ALSA not working. (jackd) kaz2100 Linux - Software 7 04-07-2006 02:51 PM
m-audio mobilepre problems aevangelica Linux - Hardware 2 03-25-2006 08:59 PM
Multiple ICE1712 (M-Audio) cards and Jackd djdebian76 Linux - Hardware 0 04-30-2005 04:31 PM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration