LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   / is sata, can't find another IDE hd (http://www.linuxquestions.org/questions/linux-hardware-18/is-sata-cant-find-another-ide-hd-251837/)

momaley 11-06-2004 12:46 PM

/ is sata, can't find another IDE hd
 
I recently installed ubuntu, and I'm running it off of a SATA hd. I have a second hd that I put in using the standard IDE (i guess ATA?). I have important data on the 2nd drive, and ubuntu doesn't recognize it as a /dev (i've tried /dev/hda, /dev/hdb/, /dev/sdb). I don't know if it's a grub issue or some other hardware config. I booted into Suse and it found the drive just fine as /dev/hda. I'm not sure how to attack this. Any ideas?

oh yeah: here's my kernel: 2.6.8.1-2-386

Thanks in advance!
Mike

abisko00 11-06-2004 01:17 PM

Can you see the drive in the output of 'fdisk -l' (need to be root)?

momaley 11-06-2004 01:22 PM

nope. i just see the /dev/sda.

abisko00 11-06-2004 01:41 PM

And does it get recognized during boot (/var/log/boot.msg)? Maybe the driver need to be included in the ramdisk. Or there are some strange kernel paramters in grub? Sorry, but I have no experience with ubuntu (yet).

momaley 11-06-2004 02:01 PM

No. I don't think it is recognized during boot. I actually don't have /var/log/boot.msg (and can't seem to find any equivalent - i'm new to ubuntu as well). including the driver in ramdisk is probably the answer i'm looking for. I'm not sure how to do that. Can you point me to a reference for how to do that? i guess it could be a strange grub param, but suse doesn't seem to have any, so hopefully that's not it. thanks for the help abisko00. i really appreciate it.

abisko00 11-06-2004 02:21 PM

In suse, it's the command mkinitrd that does the job. With the option -m one can add modules to it. Don't know it in ubuntu...try 'man mkinitrd' or 'man initrd'. I think Ubuntu is a debian clone?! Maybe you'll find more info on debian related web pages.

With strange boot parameters I meant something like ide=noprobe which would prevent the drive from beeing recognized.


All times are GMT -5. The time now is 09:49 AM.