LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Internal mic just makes white noise (http://www.linuxquestions.org/questions/linux-hardware-18/internal-mic-just-makes-white-noise-4175436713/)

Rotten194 11-11-2012 08:12 PM

Internal mic just makes white noise
 
Just recently I began having a problem in Skype where I could hear other people fine, but I was just static. After upgrading some packages yesterday, the problem has spread to everything (mumble, google talk plugin, etc.). I've tried pavucontrol, alsamixer, etc. - everything's at it's normal settings.

Built-in analog stereo is, I'm assuming, my builtin mic.
http://i.imgur.com/IaUTg.png

This is normal too.
http://i.imgur.com/8qO7d.png

Either allowing skype to adjust my mixer levels or no, still deafening static.
http://i.imgur.com/OYgYF.png

I wasn't even talking during this, that was the static.
http://i.imgur.com/9eiZK.png

I don't understand what went wrong, this used to work perfectly! With Windows this works fine with no hassle, so it drives me nuts that a random update can break it in Linux.

floppy_stuttgart 11-14-2012 02:41 PM

Distro? modules newly missing in your installed distro? (after an update)
Hardware PC modell?
error in dmesg?
please put here more information about hour hardware/distro/soundchip..
look for debugging at http://www.alsa-project.org/main/index.php/Main_Page

Rotten194 11-14-2012 04:05 PM

Quote:

Originally Posted by floppy_stuttgart (Post 4829500)
Distro? modules newly missing in your installed distro? (after an update)
Hardware PC modell?
error in dmesg?
please put here more information about hour hardware/distro/soundchip..
look for debugging at http://www.alsa-project.org/main/index.php/Main_Page

Huh... while trying it to get more info, I can hear my voice now! There's still a lot of static though...

Distro: Xubuntu 12.04
Missing modules: I don't think so, how would I check?
Errors in dmesg: None

Quote:

jon@ubuntu: arecord -l (0)
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
Also a sample created with `arecord -d 10` is at https://dl.dropbox.com/u/9540090/test.wav

floppy_stuttgart 11-15-2012 06:38 AM

missing modules? like linux-backports-modules-alsa- ...41-generic of following thread http://forum.ubuntuusers.de/topic/la...niert-nicht/2/

Rotten194 11-16-2012 07:06 AM

Quote:

Originally Posted by floppy_stuttgart (Post 4829959)
missing modules? like linux-backports-modules-alsa- ...41-generic of following thread http://forum.ubuntuusers.de/topic/la...niert-nicht/2/

I don't have linux-backports-modules-alsa, but it's also not in the Ubuntu repositories. Should I install it from somewhere else?

EDIT: Also

Quote:

jon@ubuntu: dpkg-query -W | egrep 'pulse|paman|pavu|asound|alsa|esd|esound|jack|skype'
alsa-base 1.0.25+dfsg-0ubuntu1
alsa-utils 1.0.25-1ubuntu5
bluez-alsa 4.98-2ubuntu7
bluez-alsa:i386 4.98-2ubuntu7
esound-common 0.2.41-10build3
gstreamer0.10-alsa 0.10.36-1ubuntu0.1
gstreamer0.10-pulseaudio 0.10.31-1ubuntu1
lib32asound2 1.0.25-1ubuntu10.1
lib32asound2-dev 1.0.25-1ubuntu10.1
libasound2 1.0.25-1ubuntu10.1
libasound2:i386 1.0.25-1ubuntu10.1
libasound2-dev 1.0.25-1ubuntu10.1
libasound2-plugins 1.0.25-1ubuntu1
libasound2-plugins:i386 1.0.25-1ubuntu1
libcanberra-pulse 0.28-3ubuntu3
libesd0 0.2.41-10build3
libesd0:i386 0.2.41-10build3
libesd0-dev 0.2.41-10build3
libjack-jackd2-0 1.9.8~dfsg.1-1ubuntu1
libjack-jackd2-0:i386 1.9.8~dfsg.1-1ubuntu1
libjack0 1:0.121.0+svn4538-3ubuntu1
libpulse-browse0 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1
libpulse-dev 1:1.1-0ubuntu15.1
libpulse-mainloop-glib0 1:1.1-0ubuntu15.1
libpulse-mainloop-glib0:i386 1:1.1-0ubuntu15.1
libpulse0 1:1.1-0ubuntu15.1
libpulse0:i386 1:1.1-0ubuntu15.1
libpulsedsp 1:1.1-0ubuntu15.1
libpulsedsp:i386 1:1.1-0ubuntu15.1
libsdl1.2debian-alsa 1.2.14-6.1ubuntu4
libsox-fmt-alsa 14.3.2-3
pavucontrol 0.99.2-1build1
pulseaudio 1:1.1-0ubuntu15.1
pulseaudio-esound-compat 1:1.1-0ubuntu15.1
pulseaudio-module-x11 1:1.1-0ubuntu15.1
pulseaudio-utils 1:1.1-0ubuntu15.1
skype 4.0.0.8-0oneiric1
skype-bin:i386 4.0.0.8-0oneiric1
vlc-plugin-pulse 2.0.3-0ubuntu0.12.04.1

gradinaruvasile 11-16-2012 11:21 AM

Launch alsamixer in a terminal. There you will see/can change the low-level settings of the card (such as which mike to listen to, enable/disable mixing in stuff etc). Unfortunately every card has its own controls and settings so i cant say what you should exactly do if the issue is from there (it happened to me).
After the launch you'll probably see only 1 control (that of PulseAudio's) - press f6 then select the real card, press enter.
F3 is the playback tab, f4 is the capture tab, dont try f5 cause there is every conceivable control from capture+playback.

Basically you have to make sure:
- the mic is muted in the playback tab (pressing m mutes/unmutes)
- the capture volume is up
- there is no loopback mixing or the like enabled

business_kid 11-16-2012 11:52 AM

On the alsa site there's a set of python scripts for tuning hda_intel cards. I have had mixed succedd with them. The problem is probably that you(or the updates) buggered the sound one day, you rebooted (which preserved the buggered settings) and then restore them every time

Have a look in /etc/asound.state - it's fairly self explanatory. It seems like you have a digital (rubbish noise) feed coming in and you have the real capture turned down.

If you play with the scripts, it's "Kill or cure". It's very easy to turn stuff up too much which causes distortion. Try the asound.state first - and make a backup before you fart about with it.

Rotten194 11-17-2012 08:24 PM

Quote:

Originally Posted by gradinaruvasile (Post 4830895)
Launch alsamixer in a terminal. There you will see/can change the low-level settings of the card (such as which mike to listen to, enable/disable mixing in stuff etc). Unfortunately every card has its own controls and settings so i cant say what you should exactly do if the issue is from there (it happened to me).
After the launch you'll probably see only 1 control (that of PulseAudio's) - press f6 then select the real card, press enter.
F3 is the playback tab, f4 is the capture tab, dont try f5 cause there is every conceivable control from capture+playback.

Basically you have to make sure:
- the mic is muted in the playback tab (pressing m mutes/unmutes)
- the capture volume is up
- there is no loopback mixing or the like enabled

Ahah! Thank you! I had tried alsamixer before but I guess the update changed it, since I could only get to a bare-bones interface. Using f6 I got to my real sound card and was able to set Internal Mic Boost from 100(!) to 20, the setting I normally keep it at. Can't believe I didn't figure that out myself. It's perfect now!

gradinaruvasile 11-18-2012 05:22 AM

Quote:

Originally Posted by Rotten194 (Post 4831713)
Ahah! Thank you! I had tried alsamixer before but I guess the update changed it, since I could only get to a bare-bones interface. Using f6 I got to my real sound card and was able to set Internal Mic Boost from 100(!) to 20, the setting I normally keep it at. Can't believe I didn't figure that out myself. It's perfect now!

If you use Skype, make sure the "Allow Skype to automatically adjust mixer levels" setting is disabled (Options->Sound devices).


All times are GMT -5. The time now is 04:30 AM.