LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Intel / nvidia driver problem (http://www.linuxquestions.org/questions/linux-hardware-18/intel-nvidia-driver-problem-4175416601/)

sunwukong 07-13-2012 08:04 PM

Intel / nvidia driver problem
 
Hi,

I'm running Fedora 17 on an ASUS K53S laptop, that has an "optimus" setup, and cannot get it to work. For the time being, I would be happy even with just the intel chip, but I keep getting "no screens found" errors at boot time (but no meaningful WW warnings in the /var/log/Xorg.0.log), leaving me in (hi-res) console mode.

The output of lspci:
- VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
- VGA compatible controller: nVidia Corporation Device 1058 (rev ff) (prog-if ff)

I have disabled the nouveau driver (lsmod | grep nouveau is blank), and installed bumblee & bbswitch, so:
Code:

$ lsmod | grep bbswitch
bbswitch              13396  0

and
Code:

$ systemctl status bumblebeed.service =>
bumblebeed.service - Bumblebee C Daemon
  Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
  Active: active (running) since Sat, 14 Jul 2012 01:28:59 +0200; 14min ago

I have downloaded the akmod-nvidia driver, and modified the bumblebee configuration files according to this guide.

I also experimented a lot with different xorg.conf files (using intel or nvidia drivers, defining modelines), with no success.

I am using Kernel 3.4.4-5, and also tried the same with 3.3.4-5, as well, because some threads said that bumblebee/bbswitch work better on the that one.

Any ideas?
Thanks!

peter

tonyfreeman 07-14-2012 10:17 PM

Those dkm setups usually require you to reboot your machine ... do that if you have not already.

Have you tried manually installing the nvidia driver? http://www.nvidia.com/object/unix.html

Down load it, chmod 775 it, telinit 3, log in as root, execute the NVIDIA script you just downloaded, reboot:

Code:

su -
wget http://us.download.nvidia.com/XFree86/Linux-x86_64/295.59/NVIDIA-Linux-x86_64-295.59.run
chmod 775 NVIDIA-Linux-x86_64-295.59.run
telinit 3
./NVIDIA-Linux-x86_64-295.59.run
(NOTE: answer yes to the question about fixing your xorg.conf file)
shutdown -r now

I suspect you'll probably have to ignore that other intel video card on your system.

sunwukong 07-16-2012 05:12 AM

tonyfreeman, thank you for your reply.

I have tried three kinds of nvidia drivers:
- the one from the nvidia site, just like you said
- the precompiled kmod-nvidia package
- and the akmod-nvidia (source) package

None of it worked so far (with or without bumblebee), I didn't even get to the GDM.

Since then I have reinstalled Fedora, and now I have a working system with the i915/nouveau combo, but of course I can't use the nvidia GPU this way. I guess I'll just use it this way for the time being, and maybe give the nvidia driver another shot when I have the time...

peter


All times are GMT -5. The time now is 12:44 PM.