LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   intel i810 problem (http://www.linuxquestions.org/questions/linux-hardware-18/intel-i810-problem-89614/)

greg108 09-05-2003 11:57 AM

intel i810 problem
 
I have integrated i810 Intel video card with 1MB memory.
Display setup (RH9) claims that my video memory is 16MB.
When I try to switch to 1Mb manually X windows won't start.

Also my XFree86 Log says:
(WW) I810(0): xf86AllocateGARTMemory: allocation of 1024 pages failed
(Cannot allocate memory)

So it seems like there is some problem

There is no problem though in WinME. The card seems to work fine and I never had problem with any games. In Linux I can't run Tuxracer. It moves 1 screenshot every 2 secs.

Any ideas on how to fix my problem. Thanks.

Mad Merlin 09-05-2003 01:47 PM

Are you sure that your video card only has 1 meg of video memory? If it does, I suspect that it'll "share" the system memory to bring it up to something more reasonable, like 16 megs. You won't have 3D acceleration without DRI from http://dri.sourceforge.net/

Just grab the proper binaries and install them, then boot back into X, run glxinfo and you should see a line resembling:

Direct Rendering: Yes

This is what you want, if it still says no (as I assume it does now) then you'll have to do more twiddling before you can get 3D acceleration.

Joey.Dale 09-05-2003 05:56 PM

Just let it think it has 16MBs


All times are GMT -5. The time now is 12:51 PM.