LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 10-06-2008, 11:46 AM   #1
Omnipresence
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Rep: Reputation: 0
Question Intel GMA 900 1440x900 Resolution Problem


I'm running Slackware 12.1 using Fluxbox window manager on a Gateway 3250S which uses an Intel Graphics Media Accelerator (GMA) 900 graphics processor. I use a ViewSonic 19" Widescreen monitor with an optimum resolution of 1440x900. I'm somewhat of a newbie, and I can't get 1440x900 resolution. I'm not sure what driver to use, or what to add/remove in /etc/X11/xorg.conf. I've played with the file a little, but I still haven't figured it out.

Here is the output of lspci:
Code:
00:00.0 Host bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Express Memory Controller Hub (rev 04)
00:01.0 PCI bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Express PCI Express Root Port (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Express Chipset Family Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
06:00.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)
06:05.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)
06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller (rev 03)
And here is my /etc/X11/xorg.conf (edited out comments and irrelevant lines for bandwidth sake):
Code:
Section "Monitor"
	Identifier	"Monitor0"
	Option	"DPMS"	"true"
	VendorName	"VSC"
	ModelName	"VSC171f"
	HorizSync 30 - 82 # DDC-probed
	VertRefresh 50 - 75 # DDC-probed
	Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 +HSync +VSync
        EndSection

Section "Device"
	Identifier  "Card0"
	Driver      "i810"
	VendorName  "All"
	BoardName   "All"
#	BusID       "PCI:1:0:0"
	Option "XAANoOffscreenPixmaps"
	Option "AllowGLXWithComposite" "true"
	Option "EnablePageFlip" "true"
        Option  "XaaNoScanlineImageWriteRect" "true"
        Option  "XaaNoScanlineCPUToScreenColorExpandFill" "true"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultColorDepth 24
	Option "AddARGBGLXVisuals" "true"
	Option "DisableGLXRootClipping" "true"
	SubSection "Display"
		Depth     24
		Modes "1440x900"
	EndSubSection
EndSection
However, this results in 1600x1200 resolution, and I have to move my mouse to the edge of the screen to view more of the desktop.

Ubuntu automatically configures my monitor for 1440x900 resolution. Is there a way to see the drivers being used by Ubuntu so I can find them for Slackware?

I've tried to solve this for about a week now, to no success. Any suggestions or ideas would be much appreciated.
 
Old 10-06-2008, 05:13 PM   #2
rabbit2345
Member
 
Registered: Apr 2007
Location: 中国上海
Distribution: openSUSE 11.3
Posts: 369

Rep: Reputation: 40
well if you just want to see the modules it loads, then go back to your /etc/X11/xorg.conf and under Section "Device", you will see the driver it uses.

like in yours:

Code:
Section "Monitor"
	Identifier	"Monitor0"
	Option	"DPMS"	"true"
	VendorName	"VSC"
	ModelName	"VSC171f"
	HorizSync 30 - 82 # DDC-probed
	VertRefresh 50 - 75 # DDC-probed
	Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 +HSync +VSync
        EndSection

Section "Device"
	Identifier  "Card0"
	Driver      "i810"
	VendorName  "All"
	BoardName   "All"
#	BusID       "PCI:1:0:0"
	Option "XAANoOffscreenPixmaps"
	Option "AllowGLXWithComposite" "true"
	Option "EnablePageFlip" "true"
        Option  "XaaNoScanlineImageWriteRect" "true"
        Option  "XaaNoScanlineCPUToScreenColorExpandFill" "true"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultColorDepth 24
	Option "AddARGBGLXVisuals" "true"
	Option "DisableGLXRootClipping" "true"
	SubSection "Display"
		Depth     24
		Modes "1440x900"
	EndSubSection
EndSection
you use the i810 driver. you can find this modules in /usr/lib/xorg/modules/drivers.

so yours would be /usr/lib/xorg/modules/drivers/i810_drv.so
or something similar to that. this is just whats on my system, but they should work about the same

i'm not sure that the copy module would work, but you can give it a shot, i'm curious on how this works

btw, you also need to copy to *.la file.

so the command would be:
Code:
cp /usr/lib/xorg/modules/drivers/i810* <destination>
just remember to replace <destination> with your slackware /usr/lib.... yeah
that should take care of things.


good luck,
rabbit2345 ^_^
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 900 GMA onboard graphics problem hsimah Linux - Hardware 2 06-17-2009 10:48 AM
INTEL GMA 900 Issues Please HELP!!!! acdc Linux - Hardware 1 07-18-2006 03:57 AM
Intel GMA 900 goes blank kem96hrn Linux - Laptop and Netbook 1 01-31-2006 09:42 AM
Intel GMA 900 Linux driver doesn't support XFree86 4.2 chiangyulin Linux - Software 1 01-10-2006 09:43 AM
Stuck on Intel GMA 900 Graphic thom Linux - Hardware 2 02-06-2005 07:41 PM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration