LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-28-2007, 05:57 AM   #1
paritosh73
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Intel 845G Resolution Problem


Hi,
I have installed Fedora Core 6 in a IBM Thinkcentre (PIV) machine with Intel 845G/GL Integrated Graphics Device. It is supporting only low resolution with 16 bit but not supporting 1024x768 with 24 bit. Can anybody help me ?
 
Old 09-28-2007, 07:32 AM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
What do you mean by 'low resolution with 16bit' ?? What mode is it currently displaying (like is it 800x600 or what?), and what mode do you WANT do be displayed?
I would think that 1024x768x24 would be able to display fairly easily. What video driver are you using? I think it's the i810 driver you would use for that device (don't quote me-- I think it is though).

You should check the file /etc/X11/xorg.conf and make sure that:

A) the correct driver is being used
B) the resolution(s) you would like to use are included in the 'Screen' section
C) The 'Monitor' section is properly configured for the display in your laptop, specifically horizScan, and vertRefresh rates..
 
Old 06-03-2008, 03:19 PM   #3
Vermilion Sparrow
LQ Newbie
 
Registered: Jun 2008
Distribution: Slackware 12.1, Zenwalk 5
Posts: 11

Rep: Reputation: 0
I am having the same problem on my IBM NetVista desktop with integrated Intel 845G graphics.

By default, the driver is "vesa", I tried changing this to "intel" and "i810" and neither of those worked, I got just a black screen. Even under "vesa" the only resolution it would display is 640x480x16. Changing the DefaultDepth to anything else, I got just a black screen.

This is with Slackware 12.1.
 
  


Reply

Tags
fedora, graphics, intel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X won't start - Intel 845G chip - new testing install grdnpdrsn Debian 2 09-12-2007 10:53 AM
Intel 845G X Server Hang phowlett Linux - Hardware 0 09-19-2005 02:54 PM
Installing on-board sound card of Intel 845G sbalasuriya Linux - Hardware 0 05-20-2004 06:41 AM
XFree86 problem with Intel 845G Chipset on RHEL 3 cpeppler Linux - Hardware 0 12-01-2003 08:12 PM
Problem with Solaris 9 x86 and Intel 845G/GL graphic card control tcanvn Solaris / OpenSolaris 1 10-02-2003 11:36 AM


All times are GMT -5. The time now is 02:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration