LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Intel 82815, HP A4033A working (http://www.linuxquestions.org/questions/linux-hardware-18/intel-82815-hp-a4033a-working-790076/)

merlin1012 02-18-2010 08:26 PM

Intel 82815, HP A4033A working
 
Hello all;

Extreme newbie to Linux. Installed Debian on a Dell Optiplex a couple of weeks ago. Installation went very smooth. Kudos to the developers of the installation package!

Had problems getting my monitor at the correct resolution, the system was using the default 800x600. After researching many sites, including here, I found the answer at 2 locations: Intel & (dang, I didn't write down the site but I did a search on "HP A4033A" monitors). Anyway, Intel gave me the proper text for the Driver & Screen sections of the XORG.CONF file, the other site gave me the text for the Monitor section.

Following is the corresponding code from my XORG.CONF with just those sections (sorry I don't know how to insert into one of those "boxes"):

Code:

Section "Device"
        Identifier        "i810"
EndSection

Section "Monitor"
        Identifier        "HP A4033A"
        Option "VendorName"  "HP"
        Option "ModelName"    "A4033A"
        HorizSync      30.0-80.0
        VertRefresh      50.0-120.0
        Modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
        Option "DPMS" "true"
#      DisplaySize    270    203    # 1024x768 96dpi
#      DisplaySize    338    254    # 1280x960 96dpi
#      DisplaySize    338    270    # 1280x1024 96dpi
#      DisplaySize    370    277    # 1400x1050 96dpi
#      DisplaySize    423    370    # 1600x1400 96dpi
EndSection

Section "Screen"
        Driver "svga"
        Device "i810"
        Monitor "HP A4033A"
        Subsection "Display"
          Depth 8
          Modes "640x480" "800x600" "1024x768" "1280x1024"
          ViewPort 0 0
        EndSubsection
        Subsection "Display"
          Depth 16
          Modes "640x480" "800x600" "1024x768" "1280x1024"
          ViewPort 0 0
        EndSubsection
        Subsection "Display"
          Depth 24
          Modes "640x480" "800x600" "1024x768" "1280x1024"
          ViewPort 0 0
        EndSubsection
EndSection

Hope this helps someone else!!!

Merl

cgtueno 02-22-2010 02:08 AM

Hi merlin1012

Thank you for taking the effort to post the results of your work.

Regards

Chris

merlin1012 04-02-2012 08:22 PM

Follow-up
 
I just updated from Lenny to Squeeze but now those changes don't seem to be helping. The screen seems to be about half the size what the software thinks it is. I have to slide the mouse around to see all parts of the Desktop. Kind of like looking at your current screen but can only see one quarter of it.
If anyone can help I would appreciate it.


All times are GMT -5. The time now is 11:24 AM.