LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   installation of debian squeeze and sid resulting in grfic error (http://www.linuxquestions.org/questions/linux-hardware-18/installation-of-debian-squeeze-and-sid-resulting-in-grfic-error-899428/)

gbo 08-25-2011 01:07 PM

installation of debian squeeze and sid resulting in grfic error
 
Hello everyone!

I tried to get Debian testing working on my Asus F8Sa laptop with Core2Duo and Ati Radeon Mobility HD2600. Unforutantly i failed whatever I tried.

Installing Squeeze works fine with both Gnome and KDE. The modification of sources.list and apt-get update && apt-get dist-upgrade failed.
So I tried install from netinstaller. I chose testing and tried gnome and kde. Both with same result:
The installation works fine, but after rebooting the system cant access DE. All I see is "snow" instead of the splashscreen. The same applies when I install Debian without DE --- it's snow again and no terminal...
Oh, and I tried different 3.0 kernels and 32 / 64 bit versions. Also tried to set a kernel option "nomodeset". Nothing helped.

While booting I get the same error:
Code:

[0.215148] pci_root PNP0A08 :00: adress space collision: host bridge window
[mem {some numbers here}] conflicts with adapter ROM [mem {some more numbers}]

If it's of any concern, Mint LMDE (based on debian testing) fails to install too, but different *ubuntus work just fine.

Did anyone experience the same issue? I'm little desparate right now, don't know what to do...
Thanks in advance for any suggestions

Regards,
gbo

business_kid 08-25-2011 01:24 PM

There's a kernel iommu setting that may affect it. I started with 4 gigs on a 64bit machine and the kernel would report something like:

Hmmph! this thinks the video port is over 4 gigs! That's clearly ridicolous. Disabling itg
Making a new one at 2 gigs

and later

Hey dweeb - get your iommu out of ram as it's costing you 64MB >:-(

It was all to do with bios stuff and kernel stuff. If you stop video rom shadowing(copying to ram) in the bios maybe you can get going and sort yourself out. It means a slow video ram, but it's probably the way to get off the ground.

gbo 08-26-2011 01:45 AM

Quote:

Originally Posted by business_kid (Post 4453345)
There's a kernel iommu setting that may affect it. I started with 4 gigs on a 64bit machine and the kernel would report something like:

Hmmph! this thinks the video port is over 4 gigs! That's clearly ridicolous. Disabling itg
Making a new one at 2 gigs

and later

Hey dweeb - get your iommu out of ram as it's costing you 64MB >:-(

It was all to do with bios stuff and kernel stuff. If you stop video rom shadowing(copying to ram) in the bios maybe you can get going and sort yourself out. It means a slow video ram, but it's probably the way to get off the ground.

Hello!

Thanks for the fast reply. Well, if you could tell me, how I do this. I don't have a slightest clue about this... I googled and found nothing. There is no such option in my BIOS menu..

business_kid 08-26-2011 03:37 AM

grep -n IOMMU /usr/src/linux-2.6.37.6/.config
311:# CONFIG_IOMMU_HELPER is not set
312:# CONFIG_IOMMU_API is not set
2476:# CONFIG_IOMMU_STRESS is not set

This box has agp, not pcie. It may be some option as a video aperature or window. 32 bit boxes couldn't address over 3 gigs, but 64 bit can, and this jolted the software for a bit.

Can you shift the address the video rom is shadowed to? Can you shrink the pcie window?

gbo 08-27-2011 11:01 AM

I finally managed to get Debian testing working!!

The problem is, that the newer 3.0.x kernel has troubles with free ATI drivers.

So, I downloaded a businesscardcd from Debian stable and installed the system with 2.x kernel (everything is default plus non-free repositories). After that I installed propriety ATI drivers, as explained in DebianWiki, and removed the free ones. After that, I left DE and switched to the command line. There I modified sources.list (squeeze --> testing) and ran apt-get update && apt-get dist-upgrade.
The upgrade successfully finished, and I could see the screen! The command line in this case. And there were no errors while booting with kernel 3.0.1-amd64. The only thing, that was broken was gdm3. Tried to reinstall it, but with no luck. The solution was to re-configure the ATI driver settings, which was pretty easy.

And that's actually it. Everything's working as it supposed to be. :D :D :D

business_kid 08-28-2011 03:30 AM

Sounds like I was barking up the wrong tree, and you are sorted. Mark this solved, then.


All times are GMT -5. The time now is 06:09 AM.