LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-30-2011, 09:20 PM   #1
renzed
LQ Newbie
 
Registered: Dec 2011
Posts: 3

Rep: Reputation: Disabled
Install USB HDD as "standard" partition instead of automounting to /media/...


I hope the subject is clear enough. I have a 1.5TB external USB HDD. Currently, when I plug it into my box, it appears on the current user's desktop just like any other USB drive (i.e., a thumb drive).

What I would like to do is do incremental backups to this drive. I'd like to be able to mount it and use it just like any other partition (i.e., if I installed a second internal drive) without interfering with the automount behavior for any other USB drives (i.e., thumb drives or any other external USB HDD's I might use for one reason or another).

Can anybody give me any pointers?
 
Old 12-30-2011, 09:25 PM   #2
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 189Reputation: 189
Create an fstab entry for it.
Using the UUID rather than /dev/sdxx
That way its not likely to get confused with device names on boot and such...
 
Old 12-31-2011, 01:08 AM   #3
renzed
LQ Newbie
 
Registered: Dec 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by fukawi1 View Post
Create an fstab entry for it.
Using the UUID rather than /dev/sdxx
That way its not likely to get confused with device names on boot and such...
Thanks. I'll give it a shot and see if I can make it work. I'll scream if I can't figure it out.
 
Old 01-02-2012, 10:54 AM   #4
renzed
LQ Newbie
 
Registered: Dec 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Worked perfectly - thanks!
 
Old 01-03-2012, 12:32 AM   #5
htdIO
LQ Newbie
 
Registered: Jan 2012
Posts: 1

Rep: Reputation: Disabled
Great, I've also been having troubles with it auto-mounting. Thanks guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysterious "usb" directories in /media dir - USB devices Don't Mount Like Before gentisle Linux Mint 3 04-10-2011 10:37 AM
[SOLVED] Using Clonezilla to clone HDD that has an "EISA Configuration" Partition austinium Linux - Newbie 19 03-01-2011 03:28 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
Bios config: "ahci" or "standard ide" for a sata drive ? Danodare Slackware 1 11-05-2006 12:31 AM
rh9 usb officejet g85 "media tray empty" message skippy1969 Linux - Hardware 0 03-03-2004 06:47 PM


All times are GMT -5. The time now is 12:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration