LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-26-2008, 07:13 AM   #16
resetreset
Senior Member
 
Registered: Mar 2008
Location: India
Distribution: Dynebolic, Ubuntu 10.10
Posts: 1,320

Rep: Reputation: 51

if your lsusb is showing it, you already HAVE the driver. now you have to activate TCP/IP on the USB interface, and i'm hoping some experts here will say how.
 
Old 07-27-2008, 02:40 AM   #17
chaminga
LQ Newbie
 
Registered: Jul 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by resetreset View Post
if your lsusb is showing it, you already HAVE the driver. now you have to activate TCP/IP on the USB interface, and i'm hoping some experts here will say how.
plz help me bro.. tel me hw 2 do...?? thanks
 
Old 07-27-2008, 05:06 AM   #18
resetreset
Senior Member
 
Registered: Mar 2008
Location: India
Distribution: Dynebolic, Ubuntu 10.10
Posts: 1,320

Rep: Reputation: 51
i donno - maybe by using ifconfig on your modem /dev/ file? do you know what the file is that it's made from the modem?
 
Old 07-27-2008, 05:25 AM   #19
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
This is a howto on installing Conexant chip based USB ADSL Modem.

1. What we need.
Firmware for modem. You can download it here http://depositfiles.com/files/6748275 (tar archive) (also you'll find there a so called bridge for creating nas0 interface plus script for autostart connection.)

2. Put the files on there place.
First of all, put cxacru-cf.bin and cxacru-fw.bin in /lib/firmware.
Then, put br2684ctl (the "bridge") in /usr/sbin.

3. Trying to connect.
Start the bridge:

# modprobe br2684

Check it:

# lsmod
br2684 9348 1

# ls /proc/net/atm/
br2684 cxacru:0 devices pvc svc vc

Then, we create nas0 interface:

# br2684ctl -b -c 0 -a 0.0.33
Last two digits in above line are VPI and VCI. So change them according to your ISP.

Check:

# cat /proc/net/atm/br2684 | grep dev
dev nas0: num=1, mac=00:30:CD:00:05:16 (auto)

# ifconfig nas0
nas0 Link encap:Ethernet HWaddr 00:30:CD:00:05:16
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

If all is OK, let's setup inet connection:

# pppoe-setup (It will ask for username, password, etc...)

It will also ask for Ethernet interface, which is - nas0, in our case.

Options are stored in /etc/ppp/pppoe.conf

Check and edit if needed:
/etc/ppp/pppoe.conf

ETH='nas0'
USER='guest@mtu' # your username
DEMAND=no
DNSTYPE=NOCHANGE
PEERDNS=yes
CONNECT_TIMEOUT=30
CONNECT_POLL=2
PING="."
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-adsl.pid"
SYNCHRONOUS=no
CLAMPMSS=1412
LCP_INTERVAL=20
LCP_FAILURE=3
PPPOE_TIMEOUT=80
FIREWALL=NONE # may try STANDALONE

Two files, pap-secrets and chap-secrets located in /etc/ppp/ must be equal (there is your username and password).

File Options in /etc/ppp/ must be blank.

Try to connect:
pppoe-start
#############################################

Script for autostart creating nas0 interface:
(put it in /etc/rc.d/rc.local (this is for slackware, in my
case; and you should put it in the same place for automatic startup in your distro).

Code:
#!/bin/sh
#-----------------------------------------------------------------------------
/sbin/modprobe br2684

#
sleep 1

#
#
if ! cat /proc/net/atm/cxacru\:0 | grep up ; then
     
    for second in 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 \
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 60 ;
    do
      if cat /proc/net/atm/cxacru\:0 | grep up ; then
        break;
      fi
      sleep 3
      tty -s && echo -n "."
    done
      if [ "$second" = "60" ]; then
         echo -e "\n"
         echo -e " \33[37;1;41m  WARNING: Line failed !!! Try again ...  \33[0m"
         echo -e "\n"
         exit 1
      fi
fi

#
#
#
if ! cat /proc/net/atm/br2684 | grep dev ; then
      br2684ctl -b -c 0 -a 0.0.33  # your VPI and VCI
fi

#
sleep 3
Tip: After reboot you'll get created nas0 interface and you will only need to open console to bring actual connection:
pppoe-start

#############################################
That's all my friends.

This is a howto version 0.01=) So, I will edit it if needed to make it more clear.

P.S. Also there is a gui app for that. rp-pppoe. You can download it here http://depositfiles.com/en/files/6809878
Unpack archive, open console and type ./go-gui. Very easy to setup. Options are stored closely to pppoe.conf in /etc/ppp/

Last edited by STARHARVEST; 07-27-2008 at 06:31 AM.
 
Old 07-27-2008, 10:31 AM   #20
chaminga
LQ Newbie
 
Registered: Jul 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by STARHARVEST View Post
This is a howto on installing Conexant chip based USB ADSL Modem.

1. What we need.
Firmware for modem. You can download it here http://depositfiles.com/files/6748275 (tar archive) (also you'll find there a so called bridge for creating nas0 interface plus script for autostart connection.)

2. Put the files on there place.
First of all, put cxacru-cf.bin and cxacru-fw.bin in /lib/firmware.
Then, put br2684ctl (the "bridge") in /usr/sbin.

3. Trying to connect.
Start the bridge:

# modprobe br2684

Check it:

# lsmod
br2684 9348 1

# ls /proc/net/atm/
br2684 cxacru:0 devices pvc svc vc

Then, we create nas0 interface:

# br2684ctl -b -c 0 -a 0.0.33
Last two digits in above line are VPI and VCI. So change them according to your ISP.

Check:

# cat /proc/net/atm/br2684 | grep dev
dev nas0: num=1, mac=00:30:CD:00:05:16 (auto)

# ifconfig nas0
nas0 Link encap:Ethernet HWaddr 00:30:CD:00:05:16
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

If all is OK, let's setup inet connection:

# pppoe-setup (It will ask for username, password, etc...)

It will also ask for Ethernet interface, which is - nas0, in our case.

Options are stored in /etc/ppp/pppoe.conf

Check and edit if needed:
/etc/ppp/pppoe.conf

ETH='nas0'
USER='guest@mtu' # your username
DEMAND=no
DNSTYPE=NOCHANGE
PEERDNS=yes
CONNECT_TIMEOUT=30
CONNECT_POLL=2
PING="."
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-adsl.pid"
SYNCHRONOUS=no
CLAMPMSS=1412
LCP_INTERVAL=20
LCP_FAILURE=3
PPPOE_TIMEOUT=80
FIREWALL=NONE # may try STANDALONE

Two files, pap-secrets and chap-secrets located in /etc/ppp/ must be equal (there is your username and password).

File Options in /etc/ppp/ must be blank.

Try to connect:
pppoe-start
#############################################

Script for autostart creating nas0 interface:
(put it in /etc/rc.d/rc.local (this is for slackware, in my
case; and you should put it in the same place for automatic startup in your distro).

Code:
#!/bin/sh
#-----------------------------------------------------------------------------
/sbin/modprobe br2684

#
sleep 1

#
#
if ! cat /proc/net/atm/cxacru\:0 | grep up ; then
     
    for second in 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 \
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 60 ;
    do
      if cat /proc/net/atm/cxacru\:0 | grep up ; then
        break;
      fi
      sleep 3
      tty -s && echo -n "."
    done
      if [ "$second" = "60" ]; then
         echo -e "\n"
         echo -e " \33[37;1;41m  WARNING: Line failed !!! Try again ...  \33[0m"
         echo -e "\n"
         exit 1
      fi
fi

#
#
#
if ! cat /proc/net/atm/br2684 | grep dev ; then
      br2684ctl -b -c 0 -a 0.0.33  # your VPI and VCI
fi

#
sleep 3
Tip: After reboot you'll get created nas0 interface and you will only need to open console to bring actual connection:
pppoe-start

#############################################
That's all my friends.

This is a howto version 0.01=) So, I will edit it if needed to make it more clear.

P.S. Also there is a gui app for that. rp-pppoe. You can download it here http://depositfiles.com/en/files/6809878
Unpack archive, open console and type ./go-gui. Very easy to setup. Options are stored closely to pppoe.conf in /etc/ppp/
thanks bro.. u ar cool.. i'll try this now...
i hav posted this question on several linux forums but no any site gave me help this much... cool site, thanks all...
 
Old 07-27-2008, 11:59 AM   #21
chaminga
LQ Newbie
 
Registered: Jul 2008
Posts: 14

Original Poster
Rep: Reputation: 0
thanks all who helped me... specially STARHARVEST.. i hav done all the things as he said.. now adsl working in ubuntu.. thanks again...
 
Old 07-27-2008, 03:33 PM   #22
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
Quote:
Originally Posted by chaminga View Post
thanks all who helped me... specially STARHARVEST.. i hav done all the things as he said.. now adsl working in ubuntu.. thanks again...
Glad you're online=) Write back if smth goes wrong=)
 
Old 07-27-2008, 11:08 PM   #23
chaminga
LQ Newbie
 
Registered: Jul 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by STARHARVEST View Post
Glad you're online=) Write back if smth goes wrong=)
hmm... ya there is small prob.... i hav to create nas0 interface each time i start ubuntu..
 
Old 07-27-2008, 11:34 PM   #24
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
Quote:
Originally Posted by chaminga View Post
hmm... ya there is small prob.... i hav to create nas0 interface each time i start ubuntu..
You should put the autostart script posted above to /etc/rc.d/rc.local (this is for slackware, in my case; and you should put it in the same place for automatic startup in ubuntu, AFAIK /etc/bla-bla/boot.local). Well, look for similar file in /etc/ folder. Do not remember now how it called in ubuntu. Oops=)
 
Old 07-29-2008, 01:34 AM   #25
chaminga
LQ Newbie
 
Registered: Jul 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by STARHARVEST View Post
You should put the autostart script posted above to /etc/rc.d/rc.local (this is for slackware, in my case; and you should put it in the same place for automatic startup in ubuntu, AFAIK /etc/bla-bla/boot.local). Well, look for similar file in /etc/ folder. Do not remember now how it called in ubuntu. Oops=)
bro this is a screen shot...
http://uploadx.co.cc/data/oca.jpg
 
Old 07-29-2008, 11:14 PM   #26
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
wow=) now go to rc0.d
show me what's there.
 
Old 08-30-2008, 12:23 PM   #27
yuchankit
Member
 
Registered: Apr 2008
Distribution: Slackware 13.1 ,slackware-current
Posts: 143

Rep: Reputation: 22
I have the same modem TS,but when after setting up the connection,I get a timeout for pppoe-start.When I put pppoe-status;the output is

bash-3.1# pppoe-status
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)


Any clue about this?
 
Old 08-31-2008, 01:01 PM   #28
chaminga
LQ Newbie
 
Registered: Jul 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by yuchankit View Post
I have the same modem TS,but when after setting up the connection,I get a timeout for pppoe-start.When I put pppoe-status;the output is

bash-3.1# pppoe-status
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)


Any clue about this?
Try UbuDSL. Its is Easiest and Best way...
http://www.ubudsl.com
 
Old 08-31-2008, 11:08 PM   #29
yuchankit
Member
 
Registered: Apr 2008
Distribution: Slackware 13.1 ,slackware-current
Posts: 143

Rep: Reputation: 22
Quote:
Originally Posted by chaminga View Post
Try UbuDSL. Its is Easiest and Best way...
http://www.ubudsl.com
I'm using Slackware 12.0 so I can't use UbuDSL
 
Old 08-31-2008, 11:31 PM   #30
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
Quote:
Originally Posted by yuchankit View Post
I'm using Slackware 12.0 so I can't use UbuDSL
Did you follow my instructions posted above?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Conexant USB ADSL Modem Paul7 Linux - Software 5 11-11-2005 12:22 PM
usb adsl modem conexant yusufozk Linux - Hardware 2 03-23-2005 03:20 PM
USB Adsl Conexant Modem on SuSE 9.2 MarkzZz Linux - Hardware 0 02-02-2005 09:04 AM
adsl with linuadsl usb modem..conexant unionjak Mandriva 2 10-28-2004 05:56 AM
Conexant USB ADSL MODEM athen Linux - Newbie 6 12-22-2003 11:22 AM


All times are GMT -5. The time now is 07:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration