LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-10-2005, 04:35 PM   #1
cadkins
Member
 
Registered: Mar 2004
Location: <----- there
Distribution: Mandrake 9.0 - 9.2, Slackware 9.1 - 10
Posts: 98

Rep: Reputation: 15
Input/Output error on second hard drive


I have a fileserver that has 2 160g hard drives. All files are saved on hdb1 and then at the end of the night, via cron job and bash script, hdb1 is backed up to hdd1.

I am now getting an Input/Output error when trying to access the hdd1.

The hard drive is mounted and I have checked fstab to make sure. I can cd into the hard drive but I can not do anything. Just errors.

Here is what the error says in /var/log/syslog.1



Jan 8 04:43:25 fileserver kernel: hdd: status timeout: status=0x80 { Busy }
Jan 8 04:43:25 fileserver kernel:
Jan 8 04:43:25 fileserver kernel: hdd: drive not ready for command
Jan 8 04:44:00 fileserver kernel: ide1: reset timed-out, status=0x80
Jan 8 04:44:00 fileserver kernel: hdd: status timeout: status=0x80 { Busy }
Jan 8 04:44:00 fileserver kernel:
Jan 8 04:44:00 fileserver kernel: hdd: drive not ready for command
Jan 8 04:44:30 fileserver kernel: ide1: reset timed-out, status=0x80
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 4200
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 4200
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 104
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 0
Jan 8 04:44:30 fileserver kernel: EXT2-fs error (device ide1(22,65)): ext2_write_inode: unable to rea
d inode block - inode=2, block=13
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 1052688
Jan 8 05:01:01 fileserver last message repeated 2 times
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 1048592
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 0
Jan 8 05:01:01 fileserver kernel: EXT2-fs error (device ide1(22,65)): ext2_write_inode: unable to rea
d inode block - inode=65551, block=131074
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 528400



from looking at the log, it looks like the drive is going bad. It's brand new and everything has been working fine for the past 2 months (when I set it up) but it just started doing this.

Any and all help would be GREATLY appreciated!

thanks in advance!!!


[edit]

Guess I should say that I am running Slackware 10

anything else you need just ask

[/edit]

Last edited by cadkins; 01-10-2005 at 04:45 PM.
 
Old 01-10-2005, 05:18 PM   #2
linuxgeekery
Member
 
Registered: Jul 2004
Location: Austin, Texas!
Distribution: Gentoo
Posts: 121

Rep: Reputation: 15
try running fsck -yv /dev/hdd.
 
Old 01-10-2005, 06:11 PM   #3
cadkins
Member
 
Registered: Mar 2004
Location: <----- there
Distribution: Mandrake 9.0 - 9.2, Slackware 9.1 - 10
Posts: 98

Original Poster
Rep: Reputation: 15
It say's that it can't access it.

Here is another detail. It has a 20g drive with the OS on it, one 160g drive that is a slave drive. The other 160g drive (hdd1) that I'm having problems with, is linked up as a slave drive to the CDRom. I just tried to open the cdrom drive, not on the computer, just open the drawer, and i can't even do that.

I think it is either the IDE cable or it could be that the CDRom drive went out and that makes the hdd1 that is a slave drive to it, not accessable.

I need to head home, so I will try these things tomorrow.

thanks for the help!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
aplay: pcm_write:1029: write error: Input/output error mimithebrain Linux - Software 2 12-04-2007 11:51 AM
cp - error reading /mnt/cdrom/mpegav/avseq01.dat input/output error manishsingh4u Linux - General 2 10-17-2005 05:02 AM
Input/output error when reading from CD-RW drive vrooje Linux - Newbie 2 02-17-2004 11:17 PM
Input/Output error arctuniol Linux - Software 2 10-06-2003 05:35 PM
input/output error copying from cdrom to hard drive aredshaw Linux - Hardware 4 07-16-2002 02:35 PM


All times are GMT -5. The time now is 07:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration