LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Input/Output error on second hard drive (http://www.linuxquestions.org/questions/linux-hardware-18/input-output-error-on-second-hard-drive-276245/)

cadkins 01-10-2005 04:35 PM

Input/Output error on second hard drive
 
I have a fileserver that has 2 160g hard drives. All files are saved on hdb1 and then at the end of the night, via cron job and bash script, hdb1 is backed up to hdd1.

I am now getting an Input/Output error when trying to access the hdd1.

The hard drive is mounted and I have checked fstab to make sure. I can cd into the hard drive but I can not do anything. Just errors.

Here is what the error says in /var/log/syslog.1



Jan 8 04:43:25 fileserver kernel: hdd: status timeout: status=0x80 { Busy }
Jan 8 04:43:25 fileserver kernel:
Jan 8 04:43:25 fileserver kernel: hdd: drive not ready for command
Jan 8 04:44:00 fileserver kernel: ide1: reset timed-out, status=0x80
Jan 8 04:44:00 fileserver kernel: hdd: status timeout: status=0x80 { Busy }
Jan 8 04:44:00 fileserver kernel:
Jan 8 04:44:00 fileserver kernel: hdd: drive not ready for command
Jan 8 04:44:30 fileserver kernel: ide1: reset timed-out, status=0x80
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 4200
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 4200
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 104
Jan 8 04:44:30 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 0
Jan 8 04:44:30 fileserver kernel: EXT2-fs error (device ide1(22,65)): ext2_write_inode: unable to rea
d inode block - inode=2, block=13
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 1052688
Jan 8 05:01:01 fileserver last message repeated 2 times
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 1048592
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 0
Jan 8 05:01:01 fileserver kernel: EXT2-fs error (device ide1(22,65)): ext2_write_inode: unable to rea
d inode block - inode=65551, block=131074
Jan 8 05:01:01 fileserver kernel: end_request: I/O error, dev 16:41 (hdd), sector 528400



from looking at the log, it looks like the drive is going bad. It's brand new and everything has been working fine for the past 2 months (when I set it up) but it just started doing this.

Any and all help would be GREATLY appreciated!

thanks in advance!!!


[edit]

Guess I should say that I am running Slackware 10

anything else you need just ask

[/edit]

linuxgeekery 01-10-2005 05:18 PM

try running fsck -yv /dev/hdd.

cadkins 01-10-2005 06:11 PM

It say's that it can't access it.

Here is another detail. It has a 20g drive with the OS on it, one 160g drive that is a slave drive. The other 160g drive (hdd1) that I'm having problems with, is linked up as a slave drive to the CDRom. I just tried to open the cdrom drive, not on the computer, just open the drawer, and i can't even do that.

I think it is either the IDE cable or it could be that the CDRom drive went out and that makes the hdd1 that is a slave drive to it, not accessable.

I need to head home, so I will try these things tomorrow.

thanks for the help!!


All times are GMT -5. The time now is 10:06 PM.