LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-25-2005, 12:00 AM   #1
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Rep: Reputation: 30
iMac Resolution Issue


I've got a tray loading iMac that I've loaded the PPC verion of Ubuntu on. My display settings are very low, under 640x480 but the exact number escapes me at the moment.

I've seen others have run into this issue before but I've not found the solution for it. Anyone have any suggestions?

Here is my hardware info:
Display:
Code:
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC 215IIC [Mach64 GT IIC] (rev 3a)
Dmesg Junk:
Code:
[    0.000000] Total memory = 288MB; using 1024kB for hash table (at c0400000)
[    0.000000] Linux version 2.6.12-9-powerpc (buildd@adare) (gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8)) #1 Mon Oct 10 15:26:45 BST 2005
[    0.000000] Found a Paddington mac-io controller, rev: 0, mapped at 0xfdec0000
[    0.000000] PowerMac motherboard: iMac (first generation)
xorg.conf file:



Code:
mknisely@IMcBuntu:~$ cat /etc/X11/xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. 3D Rage IIC 215IIC (Mach64 GT IIC)"
        Driver          "ati"
        BusID           "PCI:0:18:0"
        Option          "UseFBDev"              "true"
EndSection

Section "Monitor"
        Identifier      "iMac"
        Option          "DPMS"
        HorizSync       60-60
        VertRefresh     75-117
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. 3D Rage IIC 215IIC (Mach64 GT IIC)"
        Monitor         "iMac"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "800x600"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection
Is there another configuration file that I just don't see?

I hope this is helpful, and I look forward to any suggestions.

Thanks!

MrKnisely

Last edited by charon79m; 10-25-2005 at 10:29 AM.
 
Old 10-25-2005, 05:40 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
Code:
Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. 3D Rage IIC 215IIC (Mach64 GT IIC)"
        Monitor         "iMac"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "800x600"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "800x600"
        EndSubSection
EndSection
Here's your problem. Change the "800x600" to read
Code:
 Modes           "1240x768" "800x600"
If you need greater resolution, add them to the front of the line as I did.

Restart X (ctrl+alt+backspace) and see if it worked.
 
Old 10-25-2005, 08:44 PM   #3
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Original Poster
Rep: Reputation: 30
As noted in the first line of my post... my resolution is lower than 640x480.... It's not even the 800x600 that is in my xorg.conf.

Making changes to those settings has no impact at all.

I agree, that should work. It is not, and that is the reason for the post.

Also, this is on an iMac, the Ctrl+Alt+Backspace is not a valid key sequense on a Mac.

MrKnisely
 
Old 10-26-2005, 01:31 AM   #4
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
You could check in the log file for any clues: /var/log/Xorg.0.log
It should tell you what the resolution is, at any rate.
 
Old 10-26-2005, 08:12 AM   #5
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Original Poster
Rep: Reputation: 30
That's a good idea. I'll give that a look.

I can see the resolution in Gnome's screen size manager. I'm just not around the system right now. It's 5xx by 3xx... I just can't remember the x values.

MrKnisely
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot OS9 iMac (tray) to a Linxu iMac and install rudyard Linux - Networking 3 08-13-2006 11:03 PM
resolution issue darklordzim Slackware 3 07-03-2004 10:38 AM
Resolution issue with Quake 3 Thaidog Linux - Software 3 02-28-2004 11:06 AM
possibly not the same resolution issue rogueelement Linux - General 2 05-04-2002 06:06 PM
iMac Open Firmware won't boot on Blue iMac.... opn Linux - Software 0 12-31-2001 10:02 AM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration