LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 09-29-2007, 01:19 PM   #1
jukebox55
Member
 
Registered: Aug 2007
Distribution: slackware 11
Posts: 101

Rep: Reputation: 15
ide cable


hi,

ive bought a new ide cable (the one with the blue connector, think its the 80 pin), but when i connect up my 2 ide HD's the computer wont recognise them and gives me this error on reboot 'searching for boot record from scsi...not found'. im wondering why the new cable wont work? i was told that it should be backwards compatible?

however an original ide cable that came with the machine works fine and when i connect the drives to that, the computer picks them up.

btw, my computer is a fairly old p3 800mhz. ive also flashed the bios to the latest version.

any help would be appreciated.

Last edited by jukebox55; 09-29-2007 at 01:21 PM.
 
Old 09-29-2007, 02:01 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
First, check that the jumpers on the back of the drives are appropriately set for a master and a slave device.

I would also think that an 80 wire cable would be backwards compatible, as long as that's exactly what it is. If it's specifically a 'Cable Select' IDE cable, that could be the source of the problem, though I don't know if they even sell those anymore.

Also, connect the master device to the END of the cable. The Slave device goes on the middle connector.

Comparing the two cables side by side, it should be obvious if they are both 40-wire, or if one or both are 80-wire. How do they compare?

Also, since you flashed the BIOS, you ought to go into the BIOS menu where the disk drives are located, and make sure that they are still identified the same as they were before. Check the settings in that IDE setup area and look for anything that appears to be different than it was with your old BIOS.

What's the motherboard? How many IDE connectors has it got? If more than one, be sure you have the drives on the primary IDE connector, and not the secondary one.
 
Old 09-30-2007, 12:42 PM   #3
jukebox55
Member
 
Registered: Aug 2007
Distribution: slackware 11
Posts: 101

Original Poster
Rep: Reputation: 15
GrapefruiTgirl,

i set the drives for master/slave, cable select, and no jumpers at all with the new cable, (putting the master on the end connector, and the slave on the middle), but whatever i try the bios wont recognise the HD's.

the cables do look the same, except on the new cable, the connector that attaches to the motherboard is blue coloured, the old cables connector is black.

there are 2 ide connectors on the motherboard, and both old and new ide cables have 2 connectors on them to attach devices, so 4 in total can be attached.

my computer is a toshiba equium 3300D

(from everest diagnostic tool)
motherboard manufacturer is 'GVC', product 'MR824', v1.0

Motherboard ID 62-0108-000000-00101111-071595-V694V686$1AAIR137_1.08.03

Front Side Bus Properties
Bus Type Intel GTL+
Bus Width 64-bit
Real Clock 133 MHz
Effective Clock 133 MHz
Bandwidth 1067 MB/s

Motherboard Chipset VIA VT8604/5/6 ProSavage PL133/PM133/PN133

bios is american megatrends amibios released 07/10/2001 v.1.08.03 (flashed to the latest version).


the 2 HD's btw are capable of udma4, but i get the feeling the motherboard (or the bios) isnt, because when i go into the bios and change the '40 pin' connector setting to '80 pin' and restart my windows os, everything loads really slowly, and i get errors when trying to open a .chm from a disk in my dvd drive, if i then change back to '40 pin' in the bios, everything speeds up and works ok.

(btw this dma problem is preventing me from booting/using slackware properly)

Last edited by jukebox55; 09-30-2007 at 12:56 PM.
 
Old 09-30-2007, 02:38 PM   #4
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
Wow, it'd be great if all new LQ'ers provided such detailed information with their problems

Looks like you are totally on the right track. Let's try booting Slackware with no DMA.

I presume you have gotten Slack loaded as far as the boot prompt, correct? But it is not yet installed on your machine? Even if it is installed, let's try this:

Set your BIOS up for the '40 wire' setting, as it really sounds like the board or the BIOS do not like the 80-wire cable/setting.

Now, either insert your Slackware disc, or boot up to your LILO or GRUB menu. Hopefully you have the menu set so that you can alter the boot commandline. With GRUB, just hit the 'e' key, and adjust the boot line as follows. If using LILO, then to simplify things, boot using your Slack CD.

What we want to try is putting ide=nodma onto the kernel boot line. If you were booting from the Slack CD, then the boot line would look something like:

boot: sata.i root=/dev/hda2 noinitrd init=3 ro ide=nodma

Change the /dev/hda2 to whatever partition your Slackware is on, if it's on anything. If you haven't installed it yet, then you'll simply be picking a kernel to install WITH, and adding the ide=nodma option to that. Follow the instructions on the screen.
Also, I put init=3 because I am taking a guess that you may have trouble running X once it's booted. you can leave this out too, if you like.
And finally, change sata.i to whatever your kernel name is, or the kernel of choice that you are installing with.
 
Old 10-01-2007, 03:34 PM   #5
jukebox55
Member
 
Registered: Aug 2007
Distribution: slackware 11
Posts: 101

Original Poster
Rep: Reputation: 15
my apologies for lack of response GrapefruiTgirl, i have to start another new job this week and i have very little time at the moment, but i hope to return to the problem at the weekend

Last edited by jukebox55; 10-01-2007 at 03:35 PM.
 
Old 10-01-2007, 05:51 PM   #6
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
Hey no worries, I or someone will be around when you get back to it.

Speaking of, I also start a job next week, on Tuesday. Certainly far from what I'd like to be doing, but then, I don't really know what I'd like to do, let alone what I'd like enough to be able to say "Wow, am I ever happy to be starting this job!" LOL.. Maybe one day..
Well I hope yours works out well for you

Here's to us, and our jobs. Cheers :/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Easy IDE (usb cable connecting external device) monkster Linux - Hardware 5 09-09-2006 01:49 PM
safe to unplug IDE/power cable from HD wuya Linux - Hardware 5 04-27-2005 02:06 PM
laptop use a cdrom with ide-usb cable norstar Linux - Hardware 1 10-12-2004 12:19 AM
playing CD's through IDE cable edh7 Linux - General 5 07-21-2003 02:20 AM
can't mount harddisks in separated IDE cable gsbarry Linux - Hardware 5 01-29-2003 03:44 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration