View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 02-21-2005, 04:21 PM   #1
Registered: Dec 2004
Distribution: SimplyMepis 3.3.1
Posts: 30

Rep: Reputation: 15
IBM 300PL needs sound/vid drivers

Hey All,
Newbie running FC3 (kernel: 2.9-1.667) on a pentium II 400mhz IBM 300PL workstation. Ethernet, Sound, and Video are all onboard (mobo), and I need drivers like nobody's business.
Ethernet seems to be a Pulse pe-68515 (never heard of the make)
Video is an S3 Trio 64 3D 366
and Sound is Crystal Audio CSC0100

All fairly abstruse hardware, and I need some help finding Lin drivers for them. Any help would be GREATLY appreciated. Thanks, Guys.

Here's lspci output for my machine:

00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX PCI bridge (rev 03)
00:02.0 ISA bridge: Intel Corp. 8237/AB/EB/MB PIIX4 ISA (rev 02)
00:02.1 IDE interface: Intel Corp. 8237/AB/EB/MB PIIX4 IDE (rev 01)
00:02.2 USB Controller: Intel Corp. 8237/AB/EB/MB PIIX4 USB (rev 01)
00:02.3 Bridge: Intel Corp. 8237/AB/EB/MB PIIX4 ACPI (rev 02)
01:01.0 VGA Compatible Controller: S3 Inc. Trio 64 3D (rev 01)
Old 02-21-2005, 06:42 PM   #2
LQ Guru
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,294

Rep: Reputation: 168Reputation: 168
It appears your nic and audio chips are isa. You can have a look at pnpdump.

You could try modprobing the sound modules. Try these.




I think one of those should work for that chip. As far as the video card is concerned I've got an old ibm box with that card and it works fine. Have a look at this.

You may need to run the configuration manually so have a look at this.

Hope this solves some of your problems.
good luck.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are the integrated IBM 300PL NICs Linux compatible? justin_p Linux - Networking 2 10-28-2004 09:02 PM
IBM 300PL computer, Slack 9.1 hitest Slackware 3 03-21-2004 05:55 PM
IBM 300PL sound&graphics card wrong tsitras Debian 3 03-04-2004 05:42 AM
vid drivers not working how do i go back? V_LESTAT Linux - Hardware 9 01-22-2004 08:59 PM
No Sound - IBM 300PL and Red Hat 9 avs925 Red Hat 3 09-09-2003 11:33 PM

All times are GMT -5. The time now is 06:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration