LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-04-2006, 03:31 PM   #1
rrr-jr
Member
 
Registered: Jul 2003
Location: Romania
Distribution: Gentoo GNU/Linux
Posts: 65

Rep: Reputation: 15
i915 module problems


i have a gentoo box with xorg 7 and mesa 6.5 installed on it and i can't seem to get direct rendering to work ... when i run the x server i get the following in my xorg log ...
Code:
drmOpenDevice: node name is /dev/dri/card0
(II) I810(0): [drm] created "i915" driver at busid "pci:0000:00:02.0"
(EE) I810(0): [dri] I830DRIScreenInit failed because of a version mismatch.
[dri] i915 kernel module version is 1.2.0 but version 1.4 or greater is needed.
[dri] Disabling DRI.
what should i do ?
how do i upgrade my kernel modules?
btw ... i have a gentoo-sources-2.6.16-r2 kernel
 
Old 05-04-2006, 05:24 PM   #2
sn9ke_eyes
Member
 
Registered: Feb 2003
Location: Texas
Distribution: slackware 11
Posts: 90

Rep: Reputation: 15
Not sure on the gentoo specifics, but you can find the newer i915 modules at http://dri.freedesktop.org/wiki/, look under snapshots. You will want to grab a common and a i915 that have the same release date. Both packages will have install scripts in them.
 
Old 05-05-2006, 12:31 AM   #3
rrr-jr
Member
 
Registered: Jul 2003
Location: Romania
Distribution: Gentoo GNU/Linux
Posts: 65

Original Poster
Rep: Reputation: 15
Well if i do that ... what i have already did ... the common package installs just fine but the i915 module gives me a error when the script tries to modprobe it something about an unknown symbol drm_cleanup_pci ...
any help on this as well?

/later on ...
I have managed to get it working somehow by installing the dri module into the kernel ... but i keep gettin some errors when i type glxgears or glxinfo ...
Code:
libGL warning: 3D driver claims to not support visual 0x23
libGL warning: 3D driver claims to not support visual 0x25
libGL warning: 3D driver claims to not support visual 0x27
libGL warning: 3D driver claims to not support visual 0x29
libGL warning: 3D driver claims to not support visual 0x2b
libGL warning: 3D driver claims to not support visual 0x2d
libGL warning: 3D driver claims to not support visual 0x2f
libGL warning: 3D driver claims to not support visual 0x31

Last edited by rrr-jr; 05-05-2006 at 12:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No DRI with an i865G graphics adaptor and the i915 kernel module HicEtNunc Linux - Software 2 05-02-2006 12:32 PM
how can i install i915 on omnibook xe3 spillo3000 Linux - Laptop and Netbook 0 12-28-2005 06:32 AM
xorg for i915 chipset viniosity Linux - Laptop and Netbook 42 11-29-2005 02:37 PM
i915 module matrixon Linux - Software 1 06-24-2005 10:40 PM
"Failed to load module "i915"" Kane635 Linux - Software 0 11-22-2004 08:17 PM


All times are GMT -5. The time now is 11:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration