LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   I have Suse 8.2 and a Sound blaster live 5.1 cant get open source drivers installed (http://www.linuxquestions.org/questions/linux-hardware-18/i-have-suse-8-2-and-a-sound-blaster-live-5-1-cant-get-open-source-drivers-installed-76889/)

Linuxusernoob 07-29-2003 06:50 AM

I have Suse 8.2 and a Sound blaster live 5.1 cant get open source drivers installed
 
I can not for the life of me get the open source drivers from creatives web site to install properly i did what the readme says and it has multiple errors i will copy what is output in the konsole
this is what it outputs when i try to make
make
make -Cscripts
make[1]: Entering directory `/home/ScottCummings/Unzip/Sound/scripts'

/lib/modules/2.4.20-4GB-athlon/build directory does not exist. Please edit the f ile 'config'
in this directory and set KERNEL_SOURCE to the correct location of your
kernel source.

You are currently running kernel version 2.4.20-4GB-athlon, the source code shou ld
be for this version.

make[1]: *** [get_version] Error 1
make[1]: Leaving directory `/home/ScottCummings/Unzip/Sound/scripts'
make: *** [opts] Error 2

does anybody get this?
any help would be really nice

carlywarly 07-29-2003 08:52 AM

Is there a reason why you can't use the drivers SuSE installs by default?

Linuxusernoob 07-29-2003 09:06 AM

I have 4 speakers
 
The drivers that install i cant figure out how to set them up to use four speakers and i know since i read the thing for their drivers and it said that it could and does support mirroring rear speakers and i would really like to be able to use that

Linuxusernoob 07-29-2003 09:10 AM

well i can deal with it
 
i figure i can deal with having 2 speakers lol because i still have windows xp so anyway thanks anyway

Linuxusernoob 07-29-2003 09:23 AM

no i wont i dont want windows i want LINUX anyway i change my mind alot huh?

Linuxusernoob 08-02-2003 01:57 PM

ok i fixed that problem and now this is the error that im getting please some one post a reply that will help

linux:/home/cost2/sound # make
make -Cscripts
make[1]: Entering directory `/home/cost2/sound/scripts'
cc -I/lib/modules/`uname -r`/build/include get_version.c -o get_version
make -f /home/cost2/sound/scripts/Makefile.get_options -C /lib/modules/`uname -r`/build get_version_target
make[2]: Entering directory `/usr/src/linux-2.4.20.SuSE'
**
** /lib/modules/2.4.20-4GB-athlon/build/.config is missing
** if this is a custom kernel then you need to run make config in /lib/modules/2.4.20-4GB-athlon/build.
** if this is a distribution kernel then you need to copy the correct .config file to /lib/modules/2.4.20-4GB-athlon/build.
** for RedHat kernels the .config file is one of the /lib/modules/2.4.20-4GB-athlon/build/configs/*.config
**
make[2]: *** [get_version_target] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.20.SuSE'
make[1]: *** [get_options] Error 2
make[1]: Leaving directory `/home/cost2/sound/scripts'
make: *** [opts] Error 2

Linuxusernoob 08-02-2003 01:58 PM

what is the correct config file i cant find it


All times are GMT -5. The time now is 09:22 AM.