LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   I get this annoying kernel error several times a minute (http://www.linuxquestions.org/questions/linux-hardware-18/i-get-this-annoying-kernel-error-several-times-a-minute-470749/)

mandrakethepenguin 08-04-2006 10:38 AM

I get this annoying kernel error several times a minute
 
Hi all!


This is an annoyance that pops up in /var/log/kern.log several times a minute (and not just the Linux kernel either, I've had the same problem on the FreeBSD kernel, but not OpenBSD). The error is as shows
Code:

Aug  3 12:39:22 ubuntu-server kernel: [4295741.768000]    ACPI-0351: *** Error: Looking up [\_TZ_.THRM] in namespace, AE_NOT_FOUND
Aug  3 12:39:22 ubuntu-server kernel: [4295741.768000]    ACPI-0517: *** Error: Method parse/execution failed [\_GPE._L1C] (Node df7aadc0), AE_NOT_FOUND
Aug  3 12:39:22 ubuntu-server kernel: [4295741.768000]    ACPI-0549: *** Error: AE_NOT_FOUND while evaluating method [_L1C] for GPE[ 0]

and so on...

I'm running the 2.6.15-23-386 Kernel on ubuntu.
I can install a new kernel (I'm thinking 2.4?) if it will fix this problem.
Any help is apreciated.

Thanks

Simon Bridge 08-05-2006 03:19 AM

This is an ACPI error (well OK) - something like this usually means there is a fault in your DSDT (supplied by the manufacturer). You can attempt to fix this with the iASL compiler/decompiler. Or you can look for a mended version of the DSDT and install that.

You could disable ACPI.

meetscott 08-05-2006 03:20 AM

Things are definitely better in the 2.6 series for ACPI. So I wouldn't revert to 2.4. I like 2.4 too because it seems to perform better for some things. I'm running 2.6.17.7 right now. There was some work, recent done, on hotpluging that makes it work flawlessly now. So it was worth the upgrade for me.

It looks like you are running a special Ubuntu kernel? I don't use Ubuntu but I would highly recommend downloading sources from kernel.org and rolling you own. You can find a good config file from Slackware or use your config from Ubuntu. Copy it into the source tree and then issue "makeoldconfig".

One other thing is to consider turning ACPI off altogether.

Obviously something is missing or not being referenced properly. A fresh recompile and install of a new kernel should fix that.


All times are GMT -5. The time now is 12:43 AM.