LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom! (http://www.linuxquestions.org/questions/linux-hardware-18/i-cannot-access-either-cd-drive-and-theres-no-dev-hdc-or-dev-hdd-or-dev-cdrom-382061/)

Dmalic 11-11-2005 05:22 AM

I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom!
 
A bit ago, my cd drives stopped working, the system (Suse Linux 10) stopped recognizing them, and when I clicked on the icon for them it'd say only root can mount.. blah blah blah.

So, I manually mounted them as root with "mount -t iso9660 /dev/dvd /media/dvd -r" or somesuch and it worked, though badly, for some time.

Now not even that works, because there's no /dev/hdc or /dev/hdd or /dev/cdrom or /dev/cdrecorder or any of the things that used to be in /dev relating to my CD drives.

And I'm absolutely and totally lost with no idea what to do, I know I'm going to have to reinstall soon unless I can fix this, because I need to access my CD drives.

Can anyone help?

nonzero 11-11-2005 10:04 PM

Quote:

"mount -t iso9660 /dev/dvd /media/dvd -r" or somesuch
Did you mean - mount -t iso9660 /dev/hdc (or /dev/hdd)??? What does /etc/fstab contain for your removable media i.e. /media/cdrom or /mnt/cdrom or /mnt/cdwriter or /media/blah blah blah. If issuing the correct mount command still gives no joy, shutdown and check your cables. You could swap the motherboard IDE cables to your removable media and harddrives, but depending on the situation you could blow the other IDE channel, so be forewarned.
If you've got no removable media how are you going to reinstall?

nz

Dmalic 11-11-2005 11:33 PM

Quote:

Originally posted by nonzero
Did you mean - mount -t iso9660 /dev/hdc (or /dev/hdd)??? What does /etc/fstab contain for your removable media i.e. /media/cdrom or /mnt/cdrom or /mnt/cdwriter or /media/blah blah blah. If issuing the correct mount command still gives no joy, shutdown and check your cables. You could swap the motherboard IDE cables to your removable media and harddrives, but depending on the situation you could blow the other IDE channel, so be forewarned.
If you've got no removable media how are you going to reinstall?

nz

I tried both! Etc/fstab contains this: /dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0
/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0


It's not a hardware problem. I can reinstall just fine by booting off the cds. Software problems don't affect the bios bootup sequence..

nonzero 11-12-2005 10:12 PM

Quote:

I can reinstall just fine by booting off the cds. Software problems don't affect the bios bootup sequence..
Uh yeah, I think I knew that. But you said
Quote:

A bit ago, my cd drives stopped working,
.

Here is what a normal /etc/fstab look like;

proc /proc proc defaults 0 0
/dev/hda2 / ext2 defaults,errors=remount-ro 0 1
/dev/hda1 /boot ext2 defaults 0 2
/dev/hdf1 /home xfs defaults 0 2
/dev/hdb2 /opt xfs defaults 0 2
/dev/hda5 /usr xfs defaults 0 2
/dev/hde2 /archive xfs defaults 0 2
/dev/hdb1 /usr/share xfs defaults 0 2
/dev/hde1 /var xfs defaults 0 2
/dev/hdg1 /vicepa xfs defaults 0 2
/dev/hdg2 /nfsv4 xfs defaults 0 2
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda1 /media/usb0 auto rw,user,noauto 0 0

I would test to see what the master drive on your removable drive cable is then change /etc/fstab
to something like the following;

/dev/hdc /media/cdrecorder iso9660 defaults 0 0
/dev/hdd /media/dvd auto defaults 0 0
#/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0
#/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

/dev/hdc is the first drive on the second ide interface
/dev/hdd is the slave on the second ide interface

If /etc//fstab is not correct the kernel will refuse to mount the drive no matter what you type on the command line. Givning you errors exactly or similar to what you are experiencing.

I do not know why the likes of RedHat and Suse decided to jack with /etc/fstab dynamically during boot but they do and sometines things go awry. autofs and automount suck IMHO. But, I guess we've got to give Windows users whaterver they are familiar with.

nz

Dmalic 11-15-2005 06:30 AM

I managed to get SuSE to recreate the /dev entries, and now I can run the cd drives if I mount them manually!

Now, the question is, how do I configure them so they'll mount so I can view them when I insert a CD, and automatically unmount when I press the button on the cd drive (default SuSE behavior)? While it might not be for everyone, I'd rather not type the exact same command in on the command line 10-20 or more times a day. I'd just like the default behavior for CD's. Relevant portions of my current etc/fstab is as follows:

/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0 /dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0 /dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Do I need to change the /etc/fstab, or is something else the problem/

nonzero 11-15-2005 11:09 PM

Quote:

dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0 /dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0 /dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
Something is getting lost in translation here. The above should actually read as;

Quote:

/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
If it does than mybad. If it doesn't your /etc/fstab formatting is off, first of all. Second you have two entries for /dev/hdd /media//dvd and two different entries pointing to the same mountpoint (/media/cdrecorder). If what I have said is confusing have a look at;

http://www.tuxfiles.org/linuxhelp/fstab.html

To get an idea of what I am talking about. Again, find out what the master removable drive is, I am assuming it will be /dev/hdc /media/cdrecorder and the slave will be /dev/hdd /media/dvd. Then edit /etc/fstab as follows;

Quote:

#/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
#/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
#/dev/dvd /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
#/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdc /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
Also, make sure you actually have mountpoints (directories) under /media as /media/cdrecorder and /media/dvd.
Another thing I have had problems with is using a cable select cable on the drives. I'm still a jumper sort of guy and straight up IDE cables have never failed me. Oh well, just trying to help.

nz

Dmalic 11-15-2005 11:34 PM

It was just formatting when I posted it, the etc/fstab's correct.

The error message I'm getting when I clck on the dvd drive (only root can mount /dev/hdc on /media/cdrecorder) makes me think it might be a permissions problem. ls -la shows the following:

linux:/media # ls -la dvd
total 0
drwxrwxrwx 2 root root 6 2005-10-22 17:25 .
drwxr-xr-x 5 root root 51 2005-11-07 13:22 ..

linux:/media # ls -la /dev/hdd
brw------- 1 illidan disk 22, 64 2005-11-15 02:34 /dev/hdd

linux:/media # ls -la /media/dvd
total 0
drwxrwxrwx 2 root root 6 2005-10-22 17:25 .
drwxr-xr-x 5 root root 51 2005-11-07 13:22 ..


Do I need to change some of these?

nonzero 11-15-2005 11:49 PM

As I said make the changes mentioned above to /etc/fstab and try again, you do not have to reboot. Then we will see about permissions. You can save a copy of your original /etc/fstab as /etc/fstab.orig.

nz

Dmalic 11-16-2005 12:24 AM

This is how it looked when I did the last post:


/dev/hdc /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

I'm assuming that's correct?

nonzero 11-16-2005 11:40 PM

Yes that is what I was hoping to get you to try. Adding those two lines below the four above it after commenting (remarking) out the four old lines with the '#' sign. As an additional precaution, before editing I would have you copy /etc/fstab to /etc/fstab.orig. You will need to be root to do this. Without rebooting you should then be able to issue 'mount /dev/hdc' and see your files on a mounted data CD under /media/cdrecorder and conversely 'mount /dev/hdd' would let you see files on a DVD under /media/dvd.

Your /etc/fstab instruction lines are rather busy for my comfort, I subscribe to the KISS principle. So my entries are more like;

Quote:

/dev/hdc /media/cdrecorder iso9660 ro,user,noauto 0 0
But, let's not confuse the issue any more than we have to at this point. Maybe those two changes will at least allow you to mount the drives manually and possibly automount will come back. If not, you drill down a little deeper. To your benefit you are not trying to do something really hard like trying to configure a Lexmark printer under Linux!

nz

Dmalic 11-17-2005 12:10 AM

I'm still getting the "only root can mount" errors. Could it be my permissions, again?

nonzero 11-17-2005 06:02 PM

Quote:

/dev/hdc /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
Try changing the above lines to;

/dev/hdc /media/cdrecorder subfs noauto,fs=cdfss,rw,user,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,user,exec,iocharset=utf8 0 0

and tell us what happened when you try and mount from the command line. The 'user' option in the above lines should allow all users to mount those two drives. I also changed 'ro' to 'rw' for /dev/hdc since it is a writable device.

nz

Dmalic 11-18-2005 03:45 AM

I still get the "only root can do that" message if I try to mount / umount as user from the command line, but it now automounts and unmounts so everything's fine!

nonzero 11-18-2005 08:11 PM

Cool beans!

nz


All times are GMT -5. The time now is 05:03 PM.