LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-29-2005, 06:47 AM   #1
RAHUKUMAR
LQ Newbie
 
Registered: Feb 2004
Posts: 14

Rep: Reputation: 0
Post I am getting "MODE NOT SUPPORTED" message when i login to suse 9.3


Hi All;

I have Advent T9302 at home; my hardware configuration is Intel 3.6 Ghz, 1GB RAM, 19” TFT Proview monitor and ATI Radeon x600 Graphic card. I have installed Suse Linux 9.3 successfully after installing it asked me to reboot the pc to take effects the configuration, when I reboot the pc I am getting blank screen and “MODE NOT SUPPORTED” error message. How can I resolve this problem? I am new to linux.

Please help me!

Regards
Rajan
 
Old 10-29-2005, 08:03 AM   #2
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
Is there only linux installed ? You are using grub or lilo?
 
Old 10-29-2005, 08:09 AM   #3
RAHUKUMAR
LQ Newbie
 
Registered: Feb 2004
Posts: 14

Original Poster
Rep: Reputation: 0
i have dual OS (i.e windows xp as well as suse 9.3)

I am using grub.

thanks
 
Old 10-29-2005, 08:19 AM   #4
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
Dit you get any grub messages during startup?
 
Old 10-29-2005, 08:25 AM   #5
RAHUKUMAR
LQ Newbie
 
Registered: Feb 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Mr. Paul7, thanks for your reply.

I am at office now, i will give you my xconf.org file, i think my monitor resolution is not supporting.

I logged in through text mode and checked my xconf.org, as i am new to linux i don't to what to change.

It is booting up to some time aftwards getting "Mode Not Supported" message in the middle of the screen and screen is black.
 
Old 10-29-2005, 08:27 AM   #6
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Go to rescue mode using install disk and edit xorg.conf which is in /etc/X11. Use either pico or mc.
Remove all resolutions above 1024x768
 
Old 10-29-2005, 08:29 AM   #7
RAHUKUMAR
LQ Newbie
 
Registered: Feb 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Sorry, lots of mistake in my above post. Please don't mind it.

What i am intend to tell, i am at office so i will get back to you my xconf.org file later

You can have look on it.

Thanks
 
Old 10-29-2005, 01:35 PM   #8
RAHUKUMAR
LQ Newbie
 
Registered: Feb 2004
Posts: 14

Original Poster
Rep: Reputation: 0
could anyone help to see my suse linux desktop?

Here is my xorg.conf file. I am getting "MODE NOT SUPPORTED" message in the blank screen.

# /.../
# SaX generated X11 config file
# Created on: 2005-10-29T19:07:27+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "type1"
Load "dbe"
Load "freetype"
Load "glx"
Load "v4l"
Load "extmod"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "Chic Browser Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 380 300
HorizSync 30-80
Identifier "Monitor[0]"
ModelName "PROVIEW MONITOR"
Option "DPMS"
VendorName "PTS"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "768x576" 43.52 768 800 880 992 576 577 580 601
Modeline "768x576" 37.37 768 800 880 992 576 577 580 598
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "Radeon X600 (RV370) 5B62 (PCIE)"
BusID "1:0:0"
Driver "radeon"
Identifier "Device[0]"
VendorName "ATI"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

thanks
 
Old 10-31-2005, 10:16 AM   #9
enrico123
LQ Newbie
 
Registered: May 2005
Posts: 9

Rep: Reputation: 0
I have got the same problem a I solved it this way:

1) Almost at the end of the SuSE 9.3 installation there is the "Hardware Configuration" page (graphic, sound, TV etc.). There I choosed to skip the hardware configuration and I terminated the installation. When I boot, the system seems to use the same configuration used during the installation.

2) Then I logged in as root and switched to runlevel 3 with "init 3". At the prompt I have used the command suggested in the README.SuSE file:

# sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profiles/firegl -i

After this I executed the "fglrxconfig" command, anwering a lot of questions (the most have to be anwerded as default).

At the end I rebooted the PC and everything seems to work well (except a problem with kdetv tha I have still to solve). When you execute as root "glxinfo | head" you get a few info: when you see "direct rendering: Yes" then it means that 3D rendering is enabled!
 
Old 11-01-2005, 05:32 AM   #10
RAHUKUMAR
LQ Newbie
 
Registered: Feb 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Hi enrico123;


sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profiles/firegl -i

i couldn't find the path /usr/X11R6/lib/sax/profiles/firegl

i can see upto sax/profiles not "firegl".

can you tell me more clearly. How to get it work.

Cheers!
 
Old 11-01-2005, 07:12 AM   #11
enrico123
LQ Newbie
 
Registered: May 2005
Posts: 9

Rep: Reputation: 0
You can find the info in the file /usr/share/doc/packages/fglrx/README.SuSE :

sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl -i

I'm using fglrx-8.10.19-6 (from the version inside the SuSE 9.3 distribution).

Enrico
 
Old 01-05-2006, 10:22 PM   #12
43r05p4c3
Member
 
Registered: Mar 2005
Location: Ontario, Canada
Distribution: Mandrake 10.0/XP Dual Boot Desktop & Gentoo 2005.1 Laptop
Posts: 79

Rep: Reputation: 15
First and foremost, in order to take full advantage of your ATI card, you'll need the ATI drivers found on the ati website. This can be much easier said than done, and I suggest you look at this website before trying.

Having said that, your xorg.conf looks wrong here:

Code:
Section "Monitor"
DisplaySize 380 300
HorizSync 30-80
Identifier "Monitor[0]"
ModelName "PROVIEW MONITOR"
Option "DPMS"
VendorName "PTS"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection
I expect the display size line could be removed, but failing that, I would suggest a more ideal:
DisplaySize 1024 768
or if that doesn't work, a more traditional:
DisplaySize 640 480

I could be wrong though, and you should be sure to back up your xorg.conf (in case you didn't already know). All you need to do is rename is xorg.conf.old or something.

Another possibility is the horizontal and vertical refresh rates. Have you checked them against your monitor's documentation?

The only other possible problem in that section is the UseModes "Modes[0]" line. I have no idea what it is or does, so you may want to search around.

Let us know if this helps

Steve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is "sticky bit mode" , "SUID" , "SGID" augustus123 Linux - General 10 08-03-2012 04:40 AM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 12:49 PM
"Mode not Supported" upon boot up. WrldPce Linux - Newbie 2 05-20-2005 09:49 AM
During installation--"video mode not supported" DavidPorterHolt Fedora 3 03-08-2005 06:26 PM
"Video mode not supported" on a samsung syncmaster 151v with linux mandrake 9.2 UndieingHacker Linux - General 6 06-24-2004 08:52 AM


All times are GMT -5. The time now is 03:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration