LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 09-14-2006, 05:43 PM   #1
phreakshew
Member
 
Registered: Aug 2005
Distribution: Ubuntu, Kubuntu, Linux Mint
Posts: 97

Rep: Reputation: 16
Thumbs down hp scanjet 4400c -xsane failed to open device


hello all! I am trying to get my scanner working with Ubuntu- I used synaptic package manager to install libsane-extras which includes the backend I need (hp_rts88xx)

However, upon starting xsane, it always says: failed to open device 'hp_rts88xx:libusb:002:002': error during device I/O

Do I need to install the libsane-extras-dev as well?

What else should I do?

Thank you very much.
 
Old 09-15-2006, 04:27 PM   #2
svarmido
Member
 
Registered: Apr 2006
Posts: 78

Rep: Reputation: 15
The obvious...

Have you turned your scanner on? Was your scanner on and plugged into the computer when you booted into Linux? Or, did you connect and turn the scanner on afterwards? Did you check "dmesg" for evidence the scanner has been recognized and for any hints therein that may help you to resolve your problem?

svarmido
 
Old 09-15-2006, 09:33 PM   #3
phreakshew
Member
 
Registered: Aug 2005
Distribution: Ubuntu, Kubuntu, Linux Mint
Posts: 97

Original Poster
Rep: Reputation: 16
yes it was on

yes it was on

When I load up xsane I can choose to click on my scanner, but then I get that error message.

I will check dmesg (after I learn how) and post it

thanx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to open audio device (/dev/dsp): No such device stevesk Slackware 6 01-01-2009 07:29 AM
mp3blaster: Failed to open sound device. Dralnu Linux - Software 2 05-22-2006 02:39 PM
Failed to open device gt68xxLlibusb 004:002 invalid arguments error message radatan71 Linux - Hardware 1 10-24-2005 09:07 PM
Failed to open device /dev/usb/ttyUSB0: No such device efm Linux - Newbie 2 04-04-2005 09:46 PM
mplayer: failed to open /dev/rtc no such device darkleaf Linux - Software 2 02-18-2005 06:07 PM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration