LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-23-2009, 04:54 AM   #1
mike11
Member
 
Registered: Apr 2009
Posts: 222

Rep: Reputation: 17
HP Scanjet 4400c not working, Debian Lenny


Hi All,

The scanner is detected, as scanimage -L gives:
device `hp_rts88xx:libusb:002:005' is a Hewlett-Packard ScanJet 4400C flatbed scanner

but scanimage > /home/mike/o gives:
scanimage: open of device hp_rts88xx:libusb:002:005 failed: Device busy

hp-setup (from the HPLIP package) does not recognize the scanner as a USB device.

Would appreciate help in solving this.

Thanks,
Mike.
 
Old 06-23-2009, 01:12 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
I have fallen afoul of this! You need to add yourself to the 'lp' group (if it doesn't already exist, you need to add it).
 
Old 06-24-2009, 04:55 AM   #3
mike11
Member
 
Registered: Apr 2009
Posts: 222

Original Poster
Rep: Reputation: 17
Thanks, Xavier, but it didn't solve my problem .

Cheers,
Mike.
 
Old 06-24-2009, 03:46 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Open up a terminal and run "hp-toolbox" minus the quotes. Do you get errors? I will say that it has a great missing package detection option (hp-setup -t from memory) and you may be missing a few things - I know I was!

If you run "groups" are you definitely in the lp group? Try adding yourself to the lpadmin group as well.
 
Old 06-24-2009, 07:43 PM   #5
mike11
Member
 
Registered: Apr 2009
Posts: 222

Original Poster
Rep: Reputation: 17
Thanks again for replying, Xavier. It's still not working (after adding myself to the lpadmin group).

hp-toolbox --help gives:
HP Linux Imaging and Printing System (ver. 3.9.6)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


The HP Device Manager (aka "Toolbox") for HPLIP supported devices. Provides access to status, tools, and supplies levels.

Usage: hp-toolbox [OPTIONS]


[OPTIONS]
Use Qt4: --qt4 (Default)
Set the logging level: -l<level> or --logging=<level>
<level>: none, info*, error, warn, debug (*default)
Run in debug mode: -g (same as option: -ldebug)
This help information: -h or --help

Disable dbus (Qt3 only): -x or --disable-dbus

See Also:
hp-align
hp-clean
hp-colorcal
hp-devicesettings
hp-hp-faxsetup
hp-firmware
hp-info
hp-levels
hp-linefeedcal
hp-makecopies
hp-plugin
hp-pqdiag
hp-print
hp-printsettings
hp-scan
hp-sendfax
hp-testpage
hp-timedate
hp-unload

Which options do you suggest using?.

Cheers,
Mike.
 
Old 08-02-2009, 10:51 PM   #6
mike11
Member
 
Registered: Apr 2009
Posts: 222

Original Poster
Rep: Reputation: 17
Solved this by installing a recent Sane (1.0.20-5) with sane-rts8891 support.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Debian Lenny (and fully working X in Linux) I'm back LXer Syndicated Linux News 0 05-29-2009 07:12 PM
PCI wireless card with ralink chipset not working (on Debian Lenny) kernelsource Linux - Hardware 0 05-01-2009 06:22 PM
Bluetooth now working after Debian Etch to Lenny upgrade Ponder Linux - Hardware 3 04-09-2009 03:01 PM
Problem getting a Philips webcam working on Debian Lenny Count Zero Linux - Hardware 6 01-11-2009 01:54 PM
hp scanjet 4400c -xsane failed to open device phreakshew Linux - Hardware 2 09-15-2006 08:33 PM


All times are GMT -5. The time now is 09:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration