LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-14-2005, 12:05 PM   #1
tdking19
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware
Posts: 16

Rep: Reputation: 0
howto turn on DMA for /dev/hda ?


Greetings,

I'm trying to turn on DMA for my hard drive, tried the following as root and got an error:


hdparm -d 1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)



Can anyone help? Using Slackware 10.1. I need to turn DMA on because I get a message on boot up saying fschk will be slow without it and it certainly is.

Thanks,
-- Jason

Last edited by tdking19; 05-14-2005 at 12:06 PM.
 
Old 05-14-2005, 06:23 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
You need to compile your kernel with support for your IDE chipset built in, or load the chipset-specific IDE module if that is how it was compiled. You can usually find the name of your IDE chipset by using /sbin/lspci | grep -i ide.


Håkan
 
Old 05-14-2005, 08:53 PM   #3
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
I like where hw-tph is going with this, but is this a stock Slack kernel? If so, then it has support for just about every chipset you could scrounge. Heck, what's this machine? And the drive? And did you use a ghetto old 40-wire IDE cable on an ATA100 drive, they don't like that.

A good chunk of "dmesg" and all of "/sbin/lspci" should be enough to go on.

Also, there's the no-brainer, check to see if DMA is disabled from the board level in BIOS. The machine might have switched to "failsafe defaults" from being turned off ugly once, who knows... and the moron mode that some of these bios's hop to is no fun at all, rockin like its 1988.

Cheers,

Finegan
 
Old 05-15-2005, 07:31 AM   #4
FinalFlash
LQ Newbie
 
Registered: May 2005
Posts: 7

Rep: Reputation: 0
Quote:
Originally posted by hw-tph
You need to compile your kernel with support for your IDE chipset built in, or load the chipset-specific IDE module if that is how it was compiled. You can usually find the name of your IDE chipset by using /sbin/lspci | grep -i ide.


Håkan
thx, that worked well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling DMA on my /dev/hda Riddick Slackware 11 12-13-2005 07:28 PM
/dev/hda under lilo.conf even thoug my HD is under /dev/hdb Basel Slackware 8 10-27-2005 06:00 PM
dd if=/dev/hda of=dev/hdb taking forever to complete fechin Linux - Hardware 7 06-19-2005 12:04 AM
How can I boot either one of my hard drives /dev/hda or /dev/hdb, I have RH9 and FC2 omogunkristi Linux - General 1 06-21-2004 05:11 AM
DMA on /dev/hda but not on /dev/dvd jslade Linux - Hardware 4 04-07-2003 11:26 PM


All times are GMT -5. The time now is 05:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration