LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   howto turn on DMA for /dev/hda ? (http://www.linuxquestions.org/questions/linux-hardware-18/howto-turn-on-dma-for-dev-hda-323449/)

tdking19 05-14-2005 12:05 PM

howto turn on DMA for /dev/hda ?
 
Greetings,

I'm trying to turn on DMA for my hard drive, tried the following as root and got an error:


hdparm -d 1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)



Can anyone help? Using Slackware 10.1. I need to turn DMA on because I get a message on boot up saying fschk will be slow without it and it certainly is.

Thanks,
-- Jason

hw-tph 05-14-2005 06:23 PM

You need to compile your kernel with support for your IDE chipset built in, or load the chipset-specific IDE module if that is how it was compiled. You can usually find the name of your IDE chipset by using /sbin/lspci | grep -i ide.


Håkan

finegan 05-14-2005 08:53 PM

I like where hw-tph is going with this, but is this a stock Slack kernel? If so, then it has support for just about every chipset you could scrounge. Heck, what's this machine? And the drive? And did you use a ghetto old 40-wire IDE cable on an ATA100 drive, they don't like that.

A good chunk of "dmesg" and all of "/sbin/lspci" should be enough to go on.

Also, there's the no-brainer, check to see if DMA is disabled from the board level in BIOS. The machine might have switched to "failsafe defaults" from being turned off ugly once, who knows... and the moron mode that some of these bios's hop to is no fun at all, rockin like its 1988.

Cheers,

Finegan

FinalFlash 05-15-2005 07:31 AM

Quote:

Originally posted by hw-tph
You need to compile your kernel with support for your IDE chipset built in, or load the chipset-specific IDE module if that is how it was compiled. You can usually find the name of your IDE chipset by using /sbin/lspci | grep -i ide.


Håkan

thx, that worked well


All times are GMT -5. The time now is 09:28 PM.