LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How to set "restart after power loss" ? (http://www.linuxquestions.org/questions/linux-hardware-18/how-to-set-restart-after-power-loss-41806/)

ifm 01-17-2003 09:24 AM

How to set "restart after power loss" ?
 
System:
Yellowdog LinuxPPC 2.1
Blue & White G3 Macintosh

Simple enough question... how, or where do I set the bit to automatically boot the machine in the event of a power loss?

I know this is possible on this particular machine, as when it ran with MacOS8.6, it had a control panel where you set it (and it worked too).

However since the MacOS is LONG GONE on this machine, formatted to be a server now with YDL2.1 ... the machine does not reboot after power loss.

Any ideas gurus o' de machinas?

acid_kewpie 01-17-2003 09:28 AM

well surely that could only ever be in the BIOS somewhere....

Electro 01-18-2003 10:40 PM

Quote:

Originally posted by acid_kewpie
well surely that could only ever be in the BIOS somewhere....
Just about every INTEL user knows that. In the MAC world, it is slightly different. The setting could be well hiddent in the OS. If there is a way to enter into the BIOS of the MAC then you can try it that way.

Its not good to instantly turn on a system after it had shutdown. The read and write heads can scratch the platters.

moses 01-19-2003 12:51 AM

Macs have no BIOS (per se), it's a different world, the PRAM needs
to be modified. . .
After a few minutes of googling, this is the best I could do:
http://lists.linuxppc.org/linuxppc-u.../msg01454.html
It may be G4 specific, but it may not be, and there's bound to be
something similar for the G3. You might check out the source code,
look for something in /usr/src/linux/include/asm (which should be a
symlink to your /usr/src/linux/include/asm-arch).

ifm 01-23-2003 08:39 AM

Thanks, but on that post you linked too, I cannot figure out what to do with this command:

"3. I set the Open Firmware variable boot-command to:
begin ['] boot catch 1000 ms cr again"


"begin" is not a known linux command.

So I am lost there. In LinuxPPC YDL2.1 there are no asm files that are referred too in that post as well, so I am not sure if this will work, and I am not about to go trying to set every other bit in the CUDA chip to find out what works and what doesnt =) Hehehe.

Thanks anyhow.

Malfredious 01-30-2004 12:39 PM

Bind 9 lame server resolving
 
ifm,

You mention you found the problem to your post:

A typical log entry:
Jul 2 00:00:06 xxxxxxxx named[21481]: lame server resolving 'xxxxxxxxxxxxx.com' (in 'xxxxxxxxxxxxxx.COM'?): xxx.xxx.xxx.xxx#53


After searching I've been unsuccessful. Could you share your solution?

We are having certain zones corrupt because the entries are filling our logs and crashing the server.

Thanks,
Malfredious

DaFrEQ 01-30-2004 03:10 PM

Better idea:
UPS!

moses 01-31-2004 01:30 AM

Quote:

Originally posted by ifm
Thanks, but on that post you linked too, I cannot figure out what to do with this command:

"3. I set the Open Firmware variable boot-command to:
begin ['] boot catch 1000 ms cr again"


"begin" is not a known linux command.
No, begin is a command for the Open Firmware. You can get to the OF by doing something
like:
cmd-option-o-f
You would then enter the above command and continue one. . . I recommend you read the FAQs here:

http://lppcfom.sourceforge.net/fom-serve/cache/1.html


Quote:

So I am lost there. In LinuxPPC YDL2.1 there are no asm files that are referred too in that post as well, so I am not sure if this will work, and I am not about to go trying to set every other bit in the CUDA chip to find out what works and what doesnt =) Hehehe.

Thanks anyhow.
The asm.h file is included with kernel source code, so if that's not installed, you wouldn't have it.

However, you don't really need it, since, assuming you have the same architecture as the guy in the post, you SHOULD be able just to set that bit in the /dev/adb device (using the commands shown on the website) and reboot. You may not even need to mess with the Open Firmware.


All times are GMT -5. The time now is 03:37 PM.