LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-14-2009, 09:50 PM   #1
Photon Blizzard
LQ Newbie
 
Registered: Sep 2009
Location: Oklahoma City
Distribution: Unbuntu 11.04 and FreeBSD Sometimes
Posts: 19

Rep: Reputation: 1
How to read vfat flash drive with Slackware 13 and Dolphin?


Greetings,

I have just installed Slackware Linux 13. When I insert a 2GB or a 4GB Sandisk Cruzer flash drive, it appears in a little KDE "Devices recently plugged in:" window show "Volume vfat". When I click on it, Dolphin file manager opens and clicking on it from that window returns the error:

An error occured while accessing 'volume (vfat)', the system responded org.freedesktop.DBus.Error.Access
Rejected send message, 1
mathced rulues;
type = "method call"
sender="1:40" (uid=1000)
pid=5148 comm="/usr/bin/dolphin
-icon system-file-manager - captio")
interface="org.freedesktop.Hal.Dev
member="mount" error error name-"(unset)"
requested reply=0
destination="org.freedesktop.hal"
(uid=0 pid=3140 comm="/usr/bin/hald --daemon=yes "))

Neato.


Trying to take care of all the tidbit since I've had it installed again for a day.

Thanks in adavance.

PB

(And if anyone want to shoots me the answer of how to get rid of that stupid bouncing mouse cursor. (I've looked for and found the answer but they seem to talking about older versions of KDE or something). That would be swell too. :-)
 
Old 09-14-2009, 11:05 PM   #2
rabbit2345
Member
 
Registered: Apr 2007
Location: 中国上海
Distribution: openSUSE 11.3
Posts: 369

Rep: Reputation: 40
Try manually mounting in a terminal with:

Code:
mount -t vfat /dev/[device] /mount/point
as root

please replace [device] with the actual device name and /mount/point with your actual desired mount point.

Post the results up here.



As for the bouncing cursor, it's called "Launch Feedback" in KDE. You can disable/change it by going to KDE Control Center > Appearance & Themes > Launch Feedback.


good luck,
rabbit2345

Last edited by rabbit2345; 09-14-2009 at 11:08 PM.
 
Old 09-15-2009, 04:39 PM   #3
Photon Blizzard
LQ Newbie
 
Registered: Sep 2009
Location: Oklahoma City
Distribution: Unbuntu 11.04 and FreeBSD Sometimes
Posts: 19

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by rabbit2345 View Post
Try manually mounting in a terminal with:

Code:
mount -t vfat /dev/[device] /mount/point
as root

please replace [device] with the actual device name and /mount/point with your actual desired mount point.

Post the results up here.


As for the bouncing cursor, it's called "Launch Feedback" in KDE. You can disable/change it by going to KDE Control Center > Appearance & Themes > Launch Feedback.


good luck,
rabbit2345

Thanks rabbit2345,

Regarding the flash drive, your suggestion led me to start looking at /dev/ and searching the block devices, etc. I didn't see anything that made sense to play with, so I consulted the google again and it took me to a 2007 thread from this forum discussing /etc/fstab entries, udev,etc. None of this seemed very clear, so I searched more.

I searched and found one more article located at: "http://informatix.or.id/willy/auto-mounting-in-slackware.php". After grazing over all the articles and HOWTO's, considering the tid-bits from here and there, which were all useful, the simplicity of it occurred to me. (It appears that HAL has a lot to do with this, however no interaction is required of the user. HAL didn't say jack to me).

Mine is a brand new Slackware 13 install from the DVD-ISO. Slackware has and does support automounting. And the device *was* being loaded and seen, just wasn't usable yet.

The directions for getting a flash drive to be usefull with Slackware 13 and the kde userland file managers are as follows. (Worked for me anyway).

--------------------------------SNIP--------------------------------
As root or su,

1:Edit the /etc/group file and insert your username after root in the plugdev entry so it looks like:

plugdev:x:84:root,UserName

Write and save the file.

2.Run the command: /etc/rc.d/rc.messagebus reload

Reloads and uses the changes you made to /etc/groupfile.

Done.

-------------------------------SNIP----------------------------------

Now stick a flash drive in, the little USB icon at the bottom of the tray pops up a window showing a vfat device with a little USB icon. If you click on it, by Default the Dolphin file manager loads and you can select it from there and you're good to go.

I actually put 2 flash drives in the front slots on my system and they both auto mounted and behaved as you'd expect. Can drag and drop, yada, yada, yada.


Thank you for your suggestion rabbit2345, and I must say that the bouncing cursor is Dead! Dead! Dead! Hahaha! Thank you!

It was found by "K" start button-> system settings-> Under Look and Feel, Desktop-> Last item on left at bottom is launch feedback-> no busy cursor. It's dead!

Hope someone else finds this useful, please don't ask me to explain why it works. :-)

Photon

Last edited by Photon Blizzard; 09-15-2009 at 09:55 PM. Reason: Step 3, 4 and 5 are not needed. The 'device' name cruzer in /media isn't only arbritrary, it's useless.
 
Old 10-08-2009, 01:34 PM   #4
fiz65
LQ Newbie
 
Registered: May 2008
Posts: 7

Rep: Reputation: 0
Hi, Photon Blizzard, your suggestions were very useful to me.

The fact is, the solution proposed by rabbit2345 are useful, but not 'clean', i.e., this is the way to do things without hal.

The problem with slackware is that users are by default not allowed to
use several system components. For example, I was not allowed to burn
dvds as user using k3b. In order to get the appropriate permissions, instead of doing what you did, you can do the following:

su root

usermod -G plugdev USERNAME

and then reload rc.messagebus

This command will do what you did by hand. You should be careful if
you want to get permissions for other groups, because if you write

usermod -G plugdev USERNAME
usermod -G video USERNAME

you get access to video, but you loose your permissions in plugdev!
You must write

usermod -G plugdev,video USERNAME

Regards,

fiz65
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I don't want my flash drive as read-only! johnnyxxxcakes Linux - Newbie 1 06-02-2009 10:10 PM
USB flash drive (Pen drive) mounts read only prabhatsoni Linux - Hardware 24 07-02-2007 02:28 PM
Slackware having problems checking my VFAT drive crabber338 Slackware 5 04-06-2006 02:47 AM
usb flash drive always read-only flihp Linux - Hardware 2 11-12-2005 06:14 PM
Can't mount flash drive with vfat? maq Linux - Hardware 2 04-10-2005 05:57 PM


All times are GMT -5. The time now is 03:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration