LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-11-2007, 09:24 PM   #1
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Rep: Reputation: 15
Question How to mount internal drive just formatted to ext3


I took a drive that belonged to Windows and formatted it to ext3. The question now is: how do I mount it, so it will be "seen" by suse.

This is my initial try:

macho@linux-wwtz:~> su
Password:
linux-wwtz:/home/macho # mount /dev/hdd1
mount: can't find /dev/hdd1 in /etc/fstab or /etc/mtab
linux-wwtz:/home/macho # /dev/hdd1
bash: /dev/hdd1: Permission denied
linux-wwtz:/home/macho #

This is the output of my fstab:

/dev/hdb2 / ext3 acl,user_xattr 1 1
/dev/hdb3 /home ext3 acl,user_xattr 1 2
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0

How should I change it?
This is my mtab:

/dev/hdb2 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/hdb3 /home ext3 rw,acl,user_xattr 0 0
/dev/hda1 /windows/C ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
securityfs /sys/kernel/security securityfs rw 0 0
/dev/fd0 /media/floppy vfat rw,noexec,nosuid,nodev,sync,user=macho 0 0

Should I change this too?
Your help will be much appreciated. Sorry, I'm a newbie.
 
Old 04-11-2007, 09:36 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,770

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
You need to do three things:
a) create a mount point for /dev/hdd1 (mkdir /mnt/hdd1);
b) tell the systen it's there by adding it to /etc/fstab (/dev/hdd1 /mnt/hdd ext3 acl,user_xattr 1 2 (so that it looks like your hdb3 partition entry).
c) then use the mount command: mount /dev/hdd1.
 
Old 04-12-2007, 05:17 AM   #3
kmokrzcyki
LQ Newbie
 
Registered: Jan 2004
Posts: 15

Rep: Reputation: 0
Easiest way:

mount -t ext3 /dev/hdd1 /mnt/mountPoint/
where /mnt/mountPoint must exist
 
Old 04-12-2007, 08:09 AM   #4
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Smile

Quote:
Originally Posted by kmokrzcyki
Easiest way:

mount -t ext3 /dev/hdd1 /mnt/mountPoint/
where /mnt/mountPoint must exist
Thanks a lot both of you guys! I'll try one, and if I have difficulties, I'll try the other method. I'll keep you posted.
 
Old 04-12-2007, 08:14 AM   #5
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You could have found this post if you had searched before posting.
http://www.linuxquestions.org/questi...82#post2707382
 
Old 04-12-2007, 08:16 AM   #6
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kmokrzcyki
Easiest way:

mount -t ext3 /dev/hdd1 /mnt/mountPoint/
where /mnt/mountPoint must exist

It looks like it happened, but I still don't see the drive. Should I reboot?

linux-wwtz:~ # mount -t ext3 /dev/hdd1 /mnt/xwindowsd
linux-wwtz:~ #
 
Old 04-12-2007, 08:22 AM   #7
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by Pumalite
It looks like it happened, but I still don't see the drive. Should I reboot?

linux-wwtz:~ # mount -t ext3 /dev/hdd1 /mnt/xwindowsd
linux-wwtz:~ #

I went to /dev and found hdd1 with a big red X on top and when I try to open it: a message: "Couldn't display /dev/hdd1"???
What can I do now???
 
Old 04-12-2007, 09:05 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
What can I do now???
If you haven't worked it out by now, /dev/hdd1 is the device.
Your diskspace (and any files) will be at /mnt/xwindowsd. Try looking there.
 
Old 04-12-2007, 09:07 AM   #9
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Red face

Quote:
Originally Posted by bigrigdriver
You need to do three things:
a) create a mount point for /dev/hdd1 (mkdir /mnt/hdd1);
b) tell the systen it's there by adding it to /etc/fstab (/dev/hdd1 /mnt/hdd ext3 acl,user_xattr 1 2 (so that it looks like your hdb3 partition entry).
c) then use the mount command: mount /dev/hdd1.
Thanks for the reply. I was afraid to edit fstab. I tried to use vi the other day in another file, and couldn't get out; finally found out it was :wq.
 
Old 04-12-2007, 09:43 AM   #10
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by stress_junkie
You could have found this post if you had searched before posting.
http://www.linuxquestions.org/questi...82#post2707382
Let me tell you! I tried every different way of putting it, but the search gave me an error every time. Probably I don't know how to do it, I read your link. It's very interesting; especially the permissions, because I think that's what happened to me; I did everything as root, but now I'm the user. Any ideas on how to get out of this hole?

My fdisk -l:

linux-wwtz:~ # fdisk -l

Disk /dev/hda: 120.0 GB, 120060444672 bytes
255 heads, 63 sectors/track, 14596 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 14595 117234306 7 HPFS/NTFS

Disk /dev/hdb: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 262 2104483+ 82 Linux swap / Solaris
/dev/hdb2 263 2179 15398302+ 83 Linux
/dev/hdb3 2180 4998 22643617+ 83 Linux

Disk /dev/hdd: 40.0 GB, 40060403712 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdd1 1 4870 39118243+ 83 Linux
linux-wwtz:~ #

Last edited by Pumalite; 04-12-2007 at 09:46 AM.
 
Old 04-12-2007, 09:49 AM   #11
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by stress_junkie
You could have found this post if you had searched before posting.
http://www.linuxquestions.org/questi...82#post2707382
Let me tell you! I tried every different way of putting it, but the search gave me an error every time. Probably I don't know how to do it, I read your link. It's very interesting; especially the permissions, because I think that's what happened to me; I did everything as root, but now I'm the user. Any ideas on how to get out of this hole?
 
Old 04-12-2007, 09:57 AM   #12
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by tredegar
If you haven't worked it out by now, /dev/hdd1 is the device.
Your diskspace (and any files) will be at /mnt/xwindowsd. Try looking there.
Thank you for your answer. I did find out it was hdd1. I created a dir /dev/mnt/xwindowsd. fdisk -l shows the drive but I can't access it. I think I did it as root and now I'm a user. I'm totally lost.Any ideas?

linux-wwtz:~ # fdisk -l

Disk /dev/hda: 120.0 GB, 120060444672 bytes
255 heads, 63 sectors/track, 14596 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 14595 117234306 7 HPFS/NTFS

Disk /dev/hdb: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 262 2104483+ 82 Linux swap / Solaris
/dev/hdb2 263 2179 15398302+ 83 Linux
/dev/hdb3 2180 4998 22643617+ 83 Linux

Disk /dev/hdd: 40.0 GB, 40060403712 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdd1 1 4870 39118243+ 83 Linux
linux-wwtz:~ #
 
Old 04-12-2007, 09:57 AM   #13
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 114Reputation: 114
As root, from the command line, enter the following commands EXACTLY AS WRITTEN:

mkdir /mnt/hdd1
chmod 777 /mnt/hdd1
mount -t ext3 /dev/hdd1 /mnt/hdd1

Then, to access the drive, forget all about /dev/hdd1. Go to /mnt/hdd1 and you'll be able to use it.
 
Old 04-12-2007, 10:20 AM   #14
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Smile

Quote:
Originally Posted by jiml8
As root, from the command line, enter the following commands EXACTLY AS WRITTEN:

mkdir /mnt/hdd1
chmod 777 /mnt/hdd1
mount -t ext3 /dev/hdd1 /mnt/hdd1

Then, to access the drive, forget all about /dev/hdd1. Go to /mnt/hdd1 and you'll be able to use it.
Thanks for the reply. I'll try it an let you know ASAP.

linux-wwtz:~ # mkdir /mnt/hdd1
linux-wwtz:~ # chmod 777 /mnt/hdd1
linux-wwtz:~ # mount -t ext3 /dev/mnt/hdd1
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
linux-wwtz:~ #

Im ok or I'm in trouble? Whats the next command if I need to issue one? Thanks for your help.

Last edited by Pumalite; 04-12-2007 at 10:26 AM.
 
Old 04-12-2007, 11:08 AM   #15
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Jiml8 asked you to write mount -t ext3 /dev/hdd1 /mnt/hdd1
You wrote mount -t ext3 /dev/mnt/hdd1

Can you spot the difference?
 
  


Reply

Tags
suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount partially formatted drive true_atlantis Linux - Hardware 4 04-03-2006 10:23 PM
cannot mount already formatted secondary hard drive on newly installed debian angmar Debian 8 08-05-2005 01:12 PM
mount external firewire drive udf formatted tgreen Linux - Hardware 3 02-03-2005 10:02 AM
ext3 formatted drive capacity smaller than ntfs gsupp Linux - General 12 07-25-2004 02:47 PM
Is it possible to mount an external mac formatted firewire drive? BrianK Linux - General 1 06-03-2004 07:08 PM


All times are GMT -5. The time now is 09:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration