LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-27-2004, 09:05 PM   #1
mannyjazz
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Rep: Reputation: 0
Question How to mount an external NTFS USB drive on Mandrake 10.0??


Ok, I admit, I'm without question a newbie, and YES, i have searched for answers BEFORE asking this question probably for the 400th time. However, as I'm sure you're all aware, every situation is unique, and I find myself in just such a snare.

So here's my problem. I have Mandrake 10.0 and i haven't been able to get it to recognize my external USB hard drive. Here's what I've been able to do so far:

1) I can mount it as root, but that's about it. No other users can log on, nor have any access to read or write.

For example, as root in terminal, I can type:
mount -t ntfs /dev/sda1 /mnt/usb
--this will give ROOT access, but nobody else. So, I tried this:
mount -t ntfs / dev/sda1 /mnt/usb -o rw,user,noauto,exec 0 0
--no difference, still can't access drive outside of root.

2) I have tried to edit fstab to the Nth degree, and it continues to fail miserably.

For example, I edited fstab to the following:
/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdb6 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /mnt/win_c2 supermount dev=/dev/sda1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0
none /mnt/removable supermount dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
/dev/sda1 /mnt/usb ntfs rw,noauto,user,exec 0 0

but then it just adds this crap to the end of it after rebooting:
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

and it still doesn't work....

3) Strangest thing is, I have another windows drive on my system, and Mandrake already recognizes it and I can browse / read anything there with any user without a problem.

I can't seem to figure out why this external is being such a pain. If it can read my C: drive, why can't it pick up on the external without a problem? When I installed linux, it gave me several different icons for hd, win_c2, and removable -- all of which are empty and have no files in them whatsoever. The only thing I can find anything in is win_c, as I mentioned before.

I should let you all know that I am slowly but surely making the transition to Linux because I am certain that Windows is trash -- Garbage in, garbage out, hehehe -- but I need to know that I'll be able to actually complete the migration!! You've got a new advocate, just help me get running and I'll migrate all my friends too!!! :-)

Thank you all for your help, I hope I don't sound like too much of an idiot, please be patient as I am new to Linux.
 
Old 08-27-2004, 09:12 PM   #2
p-static
Member
 
Registered: Jul 2004
Distribution: Gentoo
Posts: 101

Rep: Reputation: 15
Try setting umask=0 on the USB drive, like it's set on the windows drive.

ed.: Also, keep in mind that Linux's access ti NTFS is somewhat limited right now; i know that read support works, but i'm not totally sure about write support.

Last edited by p-static; 08-27-2004 at 09:13 PM.
 
Old 08-28-2004, 11:03 AM   #3
mannyjazz
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Original Poster
Rep: Reputation: 0
I tried that, but it didn't work so good... I appreciate the input though!!

I think I may be getting hung up on the whole supermount thing. Here's how Mandrake originally set up my fstab file:

/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdb6 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /mnt/win_c2 supermount dev=/dev/sda1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0
none /mnt/removable supermount dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

this, however, does not work. Do I have to mount the external drive as a user or what do I do?
 
Old 09-22-2004, 12:39 PM   #4
nextekcarl
Member
 
Registered: Oct 2003
Location: Portland
Distribution: Gentoo
Posts: 73

Rep: Reputation: 15
I have a very similar problem in Mandrake 10.0 But my drive is formatted Fat32, not NTFS It works just fine if I am logged in as root, but if I try to use it from my user account (when I turn the drive on a mnt/removable icon shows up on my desktop as a user) it says something about that "file or folder does not exist". But it works just fine under root.

This is what my fstab looks like when I turn the drive on:


/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,sync,codepage=850,noauto,exec 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
none /mnt/removable supermount dev=/dev/scsi/host3/bus0/target0/lun0/part1,fs=ext2:vfat,--,iocharset=iso8859-1,kudzu,codepage=850 0 0

The last 2 lines only show up when I have the drive on, and disappear when I shut it off.

Is this a supermount problem? When I checked it said the /mnt/removable folder was "owner root" Group nogroup and I couldn't change that, even as root (it said I didn't have enough permissions). It seems like it's the 'thing' that hotplugs the usb device that might be adding something badly? But I don't know what that is.
 
Old 09-22-2004, 08:59 PM   #5
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
USB storage should not be in fstab. The fstab file should only be use for static (peranment) drives like IDE hard drives, SCSI hard drives, CDROM, DVD, floppy, ZIP, JAZ, Super Disk (LS-120). You can keep on disconnecting and reconnecting the same USB storage device over and over again. Linux will keep on making new devices but it will point to the same device from the dozen times you disconnect it and reconnect it. I suggest you go into fstab and remove all lines for your USB storage after you unmount (umount) your USB drive. Use # in front of each USB line if you are little worry removing lines from fstab.

For NTFS:
mount -t ntfs -o ro,umask=022,users /dev/sdX /mnt/usbdrive

For FAT:
mount -t ntfs -o rw,umask=000,users /dev/sdX /mnt/usbdrive

The X designates the device and partition number. You can use dmesg to find out the device. The right codepage should be 437 instead of 850. I suggest using FAT32 for USB drives because Windows, Mac, and Linux are able to read and write.
 
Old 09-23-2004, 10:33 AM   #6
nextekcarl
Member
 
Registered: Oct 2003
Location: Portland
Distribution: Gentoo
Posts: 73

Rep: Reputation: 15
Does it perhaps add the lines because it treats USB drives as SCSI devices? As I said, it auto deletes those lines when you unplug the device, also, under one of the files that talks about USB usb.agent I think) it has some code that looks like it is what is adding and removing the lines involved.
 
Old 05-29-2006, 07:13 PM   #7
fulanolinux
LQ Newbie
 
Registered: May 2006
Posts: 5

Rep: Reputation: 0
Hello all,

In my case I had to recompile the kernel in order to add scsi device support (scsi cdrom support), which adds module sr_mod (check with modprobe -l or lsmod if you already have it), since usb devices are accessed via scsi devices.
After that (make xconfig, make modeles_install) , reboot and mounted /dev/scd0 on /mdeia/dvdrecorder (or any other mount point).
mount -t iso9660 /dev/scd0 <mountpoint>
In some cases, depending on the number of usb devices attached, the device id may differ from scd0, being another number. In such case, use lsusb (figure out bus and device ids), /proc/scsi files, /var/log/messages.
regards,
F.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount an external ntfs usb hard disk dmpop Mandriva 5 03-03-2013 10:45 AM
Mount external USB 2.0 hard disk with NTFS? Musikolo Linux - Hardware 8 09-15-2006 09:11 AM
How to Mount External USB CD Drive? ArchiMark Linux - Laptop and Netbook 12 05-29-2006 07:10 PM
How to mount external USB hard drive? zyzyis Linux - Newbie 6 02-01-2006 09:37 PM
can't mount external usb ntfs harddrive etienne.navarro Mandriva 1 10-27-2005 12:54 PM


All times are GMT -5. The time now is 11:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration