LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How to Force Ubuntu to load and use a .ppd driver instead of the default one? (http://www.linuxquestions.org/questions/linux-hardware-18/how-to-force-ubuntu-to-load-and-use-a-ppd-driver-instead-of-the-default-one-4175421554/)

Bjorg 08-11-2012 07:07 AM

How to Force Ubuntu to load and use a .ppd driver instead of the default one?
 
Hi,

I have a Dell 1815dn printer and a laptop with Ubuntu 12.04.

Ubuntu recognizes the printer automatically and installs a default driver. But this driver lacks the option to bypass the toner-saver function which is very important for me since some times I want no toner-saver function as I need more contrast.

I have a propietary .ppd file from Dell that I have been using in past Ubuntu releases, and even currently in another computer with Ubuntu 12.04. But now I don't now how to force Ubuntu to skip the default driver and load the one I have (for some reason I got Ubuntu to ask me for the .ppd in the other computer, now I don't now how).

Any help on how to do this?

My prefered solution would be that the GUI asks me for the .ppd I have and load it, as I always have done. Another solution would be to know the folder in which I need to put the propietary .ppd file and force Ubuntu to use it.

Thanks,

Alex

aus9 08-11-2012 11:51 PM

hi

as a local user open your web browser and start CUPS

go to admin and delete your current printer then add a new one

it should ask you for a username and password.....you use root and its passwd

in adding a printer....there will be an option to use a ppd file.

open your ppd file and ensure it has no dependency issue....if not sure just try it.

cups is accessed by

http://localhost:631/

good luck

---------- Post added 12-08-12 at 12:51 ----------

hi

as a local user open your web browser and start CUPS

go to admin and delete your current printer then add a new one

it should ask you for a username and password.....you use root and its passwd

in adding a printer....there will be an option to use a ppd file.

open your ppd file and ensure it has no dependency issue....if not sure just try it.

cups is accessed by

http://localhost:631/

good luck

Bjorg 08-12-2012 05:57 AM

Thanks for your reply, but I finally solved this in a much easier way:

To bring the dialog box that was present in past releases, in a terminal put:

$ system-config-printer



















Quote:

Originally Posted by aus9 (Post 4752105)
hi

as a local user open your web browser and start CUPS

go to admin and delete your current printer then add a new one

it should ask you for a username and password.....you use root and its passwd

in adding a printer....there will be an option to use a ppd file.

open your ppd file and ensure it has no dependency issue....if not sure just try it.

cups is accessed by

http://localhost:631/

good luck

---------- Post added 12-08-12 at 12:51 ----------

hi

as a local user open your web browser and start CUPS

go to admin and delete your current printer then add a new one

it should ask you for a username and password.....you use root and its passwd

in adding a printer....there will be an option to use a ppd file.

open your ppd file and ensure it has no dependency issue....if not sure just try it.

cups is accessed by

http://localhost:631/

good luck


TobiSGD 08-12-2012 07:50 AM

Nice that you got your issue solved and that you posted back your solution. If your issue is solved please mark this thread as solved using the thread tools at the top of the thread. This makes it easier for users with a similar problem to find a solution.

Bjorg 08-12-2012 07:53 AM

Done ;D



Quote:

Originally Posted by TobiSGD (Post 4752298)
Nice that you got your issue solved and that you posted back your solution. If your issue is solved please mark this thread as solved using the thread tools at the top of the thread. This makes it easier for users with a similar problem to find a solution.



All times are GMT -5. The time now is 06:13 AM.