LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 06-17-2007, 10:47 AM   #1
substring
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
How to force aic7xxx using synchronous neg. mode


Hi,

i attached a SCSI RAID system to my debian box. The HBA is a Adaptec 29160.

dmesg shows that the RAID is attached with asynchronous negotiation:

Code:
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 7.0
        <Adaptec 29160 Ultra160 SCSI adapter>
        aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

  Vendor: SB-2800T  Model:                   Rev: 0001
  Type:   Direct-Access                      ANSI SCSI revision: 03
scsi0:A:0:0: Tagged Queuing enabled.  Depth 8
 target0:0:0: Beginning Domain Validation
 target0:0:0: wide asynchronous
 target0:0:0: FAST-80 WIDE SCSI 160.0 MB/s DT (12.5 ns, offset 31)
 target0:0:0: Domain Validation skipping write tests
 target0:0:0: Ending Domain Validation
The RAID should support synchronous negotiation. Cables and termination are set up correctly.

Is there a way to force the HBA to use synchronous neg.?

bg
substring
 
Old 06-17-2007, 03:47 PM   #2
rtspitz
Member
 
Registered: Jan 2005
Location: germany
Distribution: suse, opensuse, debian, others for testing
Posts: 307

Rep: Reputation: 32
go into the adaptec's bios and turn off domain validation and set sync transfer manually.
 
Old 06-17-2007, 06:22 PM   #3
substring
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rtspitz
go into the adaptec's bios and turn off domain validation and set sync transfer manually.
I tried this already, but the kernel driver ignores it, too. I.e. it still does the domain validation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to force write cache mode on aacraid? pofcorn Linux - Hardware 1 03-21-2007 09:19 AM
synchronous encryption algorithm vs. non-synchronous whysyn Linux - Security 2 02-22-2007 11:42 AM
Need to force Proftp in passive mode by default mago Slackware 7 05-11-2006 09:27 PM
Need to force usb1.1 mode for printer. chaumurky Linux - Hardware 4 03-17-2006 05:38 PM
Force linux to boot in single processor mode dlnlinux Linux - Newbie 2 08-05-2005 03:53 PM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration