LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How To-enable IDE-SCSI for my CD-ROM (http://www.linuxquestions.org/questions/linux-hardware-18/how-to-enable-ide-scsi-for-my-cd-rom-115557/)

cbjhawks 11-13-2003 10:10 AM

How To-enable IDE-SCSI for my CD-ROM
 
Installed a CD burning program called K3b and everything is fine except one problem...I cannot select my CD-ROM as a source read device until I enable what the program calls 'IDE-SCSI (SCSI Emulation)...see below please.

"No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.

Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems."

New to linux so I was hoping/wondering if someone could tell me how this is accomplished...thanks so much for your reply.

slakmagik 11-13-2003 10:14 AM

A search of LQ would turn this up in a flash:
editor /etc/lilo.conf
append="hd?=ide-scsi"

Also, I think newer versions of cdrtools/k3b don't have this limitation. Not sure, though - i just enable it for both my drives as a matter of course.

cbjhawks 11-13-2003 12:49 PM

below is part of my lilo.conf....append is already set...except that I dont have a hdc....I have an hda and hdb...should I change?

image=/boot/vmlinuz-2.4.20-6
label=RH9
initrd=/boot/initrd-2.4.20-6.img
read-only
append="hdc=ide-scsi root=LABEL=/"

nrunge 11-13-2003 01:52 PM

Depends on where your drive is hooked up.
hda=primary master
hdb=primary slave
hdc=secondary master
hdd=secondary slave

also get rid of roo=LABEL=/ I dont know what you are trying to accomplish there. Just simply append="hdc=ide-scsi". Also people forgot to mention that you have to enable scsi emulation in your kernel. In 2.4.22 you have to first enable scsi devices, then under your ide stuff you can enable scsi emulation. The help file for scsi-emulation reccomends that in scsi you enable both scsi cdrom and scsi generic. If you dont re-compile your kernel for this support then the "hdx=ide-scsi" option will do you know good because it is a kernel paramter that is there to tell the cdrom that it is to be using scsi emulation.


All times are GMT -5. The time now is 11:51 AM.