LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How to choose default sound card? (http://www.linuxquestions.org/questions/linux-hardware-18/how-to-choose-default-sound-card-325694/)

TVH 05-21-2005 11:13 AM

How to choose default sound card?
 
Hello

I have 3 sound cards, how do I select which one is the default one?

Distro is mandrake 10.1

Half_Elf 05-22-2005 01:11 PM

I dont know about Mandrake ( you are somewhat in the wrong part of the forum, but PLEASE don't double post), but usually the default card is the one "linked" to /dev/dsp and the default mixer is the one linked to /dev/mixer. So, on my system (I have 2 sound card).
this is my output of ls -l /dev/dsp* :
lrwxrwxrwx 1 root root 9 May 22 12:57 /dev/dsp -> /dev/sound/dsp1
( /dev/mixer is about the same ) :
lrwxrwxrwx 1 root root 17 May 22 14:12 mixer -> /dev/sound/mixer1


It depends on your distro, but usually just relinking the /dev/dsp link and /dev/mixer to other devices will tell your system to use another soundcard. Like, in my case, if I would like to use my second (it is first in fact, "1" mean the second) soundcard :
ln -sf /dev/sound/dsp /dev/dsp
ln -sf /dev/sound/mixer /dev/mixer

This will tell "ALSA" to use the first sound card as default one. Then you might want to ajust Artsd (Kde sound server) or whatever you are using (most modern distro don't use Alsa directly), there is always a cute wizy-wizard thingy to do that (in kde, it is located in Control Center/Sound System. Dont know about Gnome but it shouldn't be hard to find).

Cyborg16 05-24-2005 06:08 AM

Well, on my system /dev/dsp and /dev/mixer aren't links (debian testing). I've got around the problem by blacklisting the driver I don't want to use (because otherwise that -- the onboard sound (snd_intel8x0) -- is the default). I just removed the blacklisting and restarted, and my sound card (snd_emu10k1) wasn't loaded; I got a probing error in dmesg. The module was loaded but no extra device was created (rmmod then modprobe didn't help, but rmmod both drivers then modprobe with emu10k1 first did create both). I guess the error on startup could be due to driver bugs, but any idea how to make dsp and mixer links rather than devices, or load the drivers in the other order? I'm using a self-built 2.6.8 kernel btw, which I will upgrade at some point.

Electro 05-24-2005 07:32 PM

Add the index value for each sound card in /etc/modules.conf or /etc/modprobe.conf. An index value of 0 will be the first card and index value of 1 will be the second card.

Lets say we have an intel on-board sound, Audiotrak Prodigy 7.1, and Turtlebeach Santa Cruz. We want the Turtlebeach Santa Cruz to be first card istead of second, the Audiotrak Prodigy 7.1 to be the second card instead third, and intel on-board sound to be the third sound card instead first. The code below is an example with out opening up the computer and moving the cards or changing symbolic links.

# ALSA and OSS
alias char-major-116 snd
alias char-major-14 soundcore

# Turtlebeach Santa Cruz
alias snd-card-0 snd-cs46xx
options snd-cs46xx index=0

# Audiotrak Prodigy 7.1
alias snd-card-1 snd-ice1724
options snd-ice1724 index=1

# intel on-board sound
alias snd-card-2 snd-intel8x0
options snd-intel8x0 index=2

# OSS emulation naming
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
alias sound-slot-2 snd-card-2

# Card 1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# Card 2
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss

# Card 3
alias sound-service-2-0 snd-mixer-oss
alias sound-service-2-1 snd-seq-oss
alias sound-service-2-3 snd-pcm-oss
alias sound-service-2-8 snd-seq-oss
alias sound-service-2-12 snd-pcm-oss

Phew! All you need to do is to restart the alsa script. To do that, login as su or root and type service alsa restart. The default sound device can be change in program's preferences.


All times are GMT -5. The time now is 09:34 PM.