LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How to check network speed conection (http://www.linuxquestions.org/questions/linux-hardware-18/how-to-check-network-speed-conection-930925/)

miros84 02-23-2012 02:44 PM

How to check network speed conection
 
Hello,

In windows you can check network speed conection when you go to network and see speed if it is 54Mps, 100Mps or 1000Mps, but in Linux, where can I check that?

I have Debian squeeze.

ukiuki 02-23-2012 03:23 PM

Here just as follow:
Code:

dmesg | grep eth0
Regards

repo 02-23-2012 03:36 PM

Try
Code:

ethtool eth0
iwconfig

Kind regards

John VV 02-23-2012 03:39 PM

that IS NOT your connection speed even on windows
54,100,1000 has no meanning
that is a generic setting and is 100% meaningless ( even on windows)
there are on line sites like
http://www.speedtest.net/

http://netalyzr.icsi.berkeley.edu/

d072330 02-23-2012 03:45 PM

If you only have command line access this will work.

wget http://speedtest.sea01.softlayer.com...m1000x1000.jpg

Will return something like this:

100%[==================================================================================================== =========>] 1,986,284 2.32M/s in 0.8s

2012-02-23 14:49:47 (2.32 MB/s) - `random1000x1000.jpg' saved [1986284/1986284]

miros84 02-23-2012 03:56 PM

i dont mean speed test to internet. I mean speed test to local network.
It is 100Mps, and I am not very happy, because, my motherboard lan is 10/100/1000, and I connected the PC to switch which is gigabit 10/100/1000
I use cables Cat5e, and in Windows and in Debian speed is 100Mps. Must be 1Gbps.

Some advice where could be the problems?

teckk 02-23-2012 04:36 PM

http://en.wikipedia.org/wiki/Gigabit_Ethernet
http://linux.die.net/man/8/ip
http://linux.about.com/od/commands/l...l8_ethtool.htm

There are several things to check.
Are you sure that all of your hardware is up to it?
How is your cable running, you sure that you don't need CAT6?
Can you you turn off auto negotiate on your network device and force gigabit? Are your machines configured for gigabit speed?
What does ip addr or ifconfig tell you about your device?
How did you determine what transfer speeds that you are getting?

Quote:

Windows and in Debian speed is 100Mps
How did you determine that?
Give some more info. There are lots of network admins that use this forum.

miros84 02-24-2012 02:42 AM

Code:

root@Miros-Debian:/home/miros# dmesg | grep eth0
[    0.901390] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x732 @ 3, addr 00:19:66:bf:9f:e8
[  22.568661] bridge-eth0: up
[  22.568664] bridge-eth0: attached
[  24.612347] eth0: no IPv6 routers present


Code:

eth0      Link encap:Ethernet  HWaddr 00:19:66:bf:9f:e8 
          inet addr:192.168.0.19  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::219:66ff:febf:9fe8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4451 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3851 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4447987 (4.2 MiB)  TX bytes:727163 (710.1 KiB)
          Interrupt:29 Base address:0x2000

I dont find the information I need. Where can I see speed in local area? In windows it shows 100Mps
In Linux I dont find that. But when I copy Movies between my computer and Nas 1Gigabit server, maximum speed is 10Mb. So I understand it is Lan 100Mps limitation.

EDDY1 02-24-2012 03:50 AM

right -click on network icon select connection information.

H_TeXMeX_H 02-24-2012 06:29 AM

Code:

bash-4.1# ethtool eth1
Settings for eth1:
        Supported ports: [ TP MII ]
        Supported link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                            100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 32
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000007 (7)
                              drv probe link
        Link detected: yes


ukiuki 02-24-2012 08:52 AM

Here one more:
Code:

# mii-tool -v eth0
Regards

miros84 02-26-2012 03:37 AM

Well, if My computer Lan is 10/100/1000, my NAS is 1Gigabit and I connected them to switch 10/100/1000 by Cord Cat5e, why I can copy big files only up to 10MB?
Is there other things I have to do, so I can jump this 100Mps limitation?

EDDY1 02-26-2012 04:47 AM

I have to ask, isn't the limitation governed by the type of account you have thru your isp?
In other words residential service as opposed to commercial service.

teckk 02-26-2012 08:48 AM

Quote:

why I can copy big files only up to 10MB?
You aren't giving much info.

Code:

#ethtool eth0
Will tell you what your computers network device is doing.
Is it running at 1000mbps?

Code:

ifconfig eth0
Should tell you too.

What speed is you NAS set to run at? Sometimes forcing 1000mbs works better than auto.

Is your 10/100/1000 switch or router set to auto negotiate? They should do that but some older hubs would run at the lowest speed device hooked to it.

CAT5e is 100mbps cable. CAT6 is Gigabit. Did you make your cables or did you buy factory made cables? You can't get 1000mbps with home made cables. You probably won't get 1000mbps performance with CAT5e, but should get better that 100mbps. You won't get 1000mbps performance with CAT6 at home between 2 machines if the hard drives won't deliver that fast.

Either your network device needs a better driver, you have them set wrong, your cables are sub standard, your switch is cheep and doesn't perform, etc. And even then, you can't transfer data faster than the machines will deliver it.

If you are only getting 10mbit performance, (that's 10 / 8 = 1.25mbyte) then you have a device set to 10mb, or bad cables.
If you are getting 100mbit performance (that's 100 / 8 = 12.5mbyte) then your hardware is 100mb, set to 100mb, or your cables will only do 100mb.

You'll have to trouble shoot your network to see where the bottleneck is.

http://www.linuxhomenetworking.com/w...roubleshooting

miros84 02-28-2012 07:54 AM

Code:

eth0      Link encap:Ethernet  HWaddr 00:19:66:bf:9f:e8 
          inet addr:192.168.0.19  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::219:66ff:febf:9fe8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2771 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2706 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2441962 (2.3 MiB)  TX bytes:562001 (548.8 KiB)
          Interrupt:29 Base address:0xe000

Also in information to network it shows speed 100Mb/s. That is 12MB. I can copy almost to 10MB
I changed the cable and I connect the PC to the 1Gigabit Switch with factory cord Cat6. Nothing change. It shows 100Mps again.
When I put ethtool eth0 in terminal, nothing appears.
I dissconect all other cables from the switch and I try only to connect my PC connected to the Switch and the connection appears 100Mps again. Something that I can try?


All times are GMT -5. The time now is 05:43 AM.