LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How do I go about installing webcam drivers? -Are there drivers for my camera? (http://www.linuxquestions.org/questions/linux-hardware-18/how-do-i-go-about-installing-webcam-drivers-are-there-drivers-for-my-camera-764393/)

mitchell7man 10-25-2009 04:37 PM

How do I go about installing webcam drivers? -Are there drivers for my camera?
 
Here is my lsusb

Quote:

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 002: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000.
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 03f0:7404 Hewlett-Packard Printing Support
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 413c:2105 Dell Computer Corp.
Bus 003 Device 002: ID 046d:c049 Logitech, Inc. G5 Laser Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
The camera is the Microsoft Corp. LifeCam VX-1000

I've never had a webcam on linux before and would like to get it to work with skype and what not.

Thanks for your help,
MJ

smeezekitty 10-25-2009 04:56 PM

since the camera is made by microsawft the camera working with linux is nearly 0.
infact the chances of it working with anything is nearly 0.

spurious 10-25-2009 06:46 PM

According to the Ubuntu Skype Webcam Wiki, the Microsoft Lifecam VX-1000 should work with the 2.6.30 Linux kernel and gspca module. No additional driver installation is necessary, but you may have to do a hack to get Skype to work.

mitchell7man 10-31-2009 03:42 AM

Okay, so I tried using that command:

Quote:

mitchj@mitchj-desktop:~$ sudo apt-get install lib32v4l-0
[sudo] password for mitchj:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package lib32v4l-0
mitchj@mitchj-desktop:~$ sudo apt-get install libv4l-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
libv4l-0 is already the newest version.
The following packages were automatically installed and are no longer required:
libqt4-opengl libqt4-assistant libqt4-test libqt4-core binutils-static
libqt4-gui libqt4-svg libqt4-designer libqt4-script
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
mitchj@mitchj-desktop:~$ env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
the error i'm getting is that it just shows static and fuz instead of an image, it would continue giving the decompress errors until I close the program.

Does anyone know of a solution for this?


All times are GMT -5. The time now is 03:14 PM.