LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 01-18-2006, 08:03 PM   #1
cookevillain
LQ Newbie
 
Registered: Dec 2005
Posts: 7

Rep: Reputation: 0
How do I enable 4.1 sound on an Intel HDA card? SOLVED


Hi everybody!

I have an Intel D945PSNLK motherboard. I am using Ubuntu 5.10 and am trying to get the sound to work. I can play 2 channel no problem but how do I enable all 4 channels (well, I only need 4)? When I run

speaker-test -Dplug:surround40 -c4

I can only hear the sound when I plug the speakers into the `line out' jack. No other jack produces sound even though the motherboard is supposed to be able to switch the mic and line-in jack to output . Playing with the mixer did not get me anywhere. Does anyone have any advice for me?

If it helps, here is the output of

aplay -L 2>&1 | egrep surround

:
surround40 'cards.pcm.surround40'
surround41 'cards.pcm.surround41'
surround50 'cards.pcm.surround50'
surround51 'cards.pcm.surround51'
surround71 'cards.pcm.surround71'

Please help. Thanks in advance.

PS It all works with the latest kernel and alsa.

Last edited by cookevillain; 06-05-2007 at 04:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help me enable my ISA sound card Navyblue Linux - Hardware 10 11-04-2005 05:33 PM
No sound for Intel Sound Card in Suse 10.0 niztec Suse/Novell 2 11-01-2005 08:04 PM
Can't get sound to work on SuSE 9.3, hda-intel onboard card MamaWombat Linux - Newbie 3 09-16-2005 12:39 AM
Sound/Multi-channels on an HDA-Intel/C-Media CMI9880 soundcard? newbuntu Linux - Hardware 6 08-09-2005 08:05 PM
midi / synth sound with SIS7012 aka Intel i8x0 onboard sound card does not work wahwah Linux - Hardware 1 11-10-2003 05:25 PM


All times are GMT -5. The time now is 05:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration