LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-21-2008, 10:41 PM   #1
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Rep: Reputation: 34
Horizontal Sync and Vertical Refresh for 1680 x 1050 widescreen @ 60hz (not 75)


I have a widescreen lcd and I cant get it to go to 1680 x 1050 because the monitor says it goes out of range. I have no idea what the horizsync and vertrefresh should be because the documentation doesn't say.

I've tried different values I've found with google but [gnome] screen resolution always has refresh at 75hz for 1680x1050 and I know it should be 60hz because the monitor's troubleshooting says to put it there.

My monitor is a sceptre x20.
 
Old 03-21-2008, 11:11 PM   #2
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
have you tried letting DDC configure it automatically?

you could also try gtf:

gtf 1680 1050 60

which will return a mode line you could use.
 
Old 03-21-2008, 11:16 PM   #3
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
I don't have qtf?? I ran a search too I'm on debian.

edit -- btw I've tried using modelines where I've seen other people posting the result of that command but it still doesn't work -- says 75 refresh and everything even though the modeline specifically says 60.

Last edited by 1veedo; 03-21-2008 at 11:22 PM.
 
Old 03-22-2008, 04:28 AM   #4
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
A LCD max refresh rate is 60 H If I try to put it on a higher rate I get the message input not supported
The old CRT tubes has a much higher refresh rate


all thw best
 
Old 03-22-2008, 08:35 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
We need to know what video card and driver you are using.

With widescreens, I have found that the generic driver sometimes will not support the 16:10 or 16:9 formats. For example, I use "nvidia" proprietary driver from Nvidia instead of the "nv" driver.

The modeline tool is gtf, not qtf.

Here's the specs (from Sceptre website):
http://www.sceptre.com/Products/LCD/...20wg_1080p.htm
 
Old 03-22-2008, 11:03 AM   #6
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
I don't have gtf, either.

My video card is a 6200 gtx, it should support this resolution (I googled for this earlier). The driver is 1.0.8776-4.

I tried looking for their website but couldn't find it thanks, it still doesn't have it's horizontal sync and vertical refresh?
 
Old 03-22-2008, 03:34 PM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
You can get gtf using your package manager.

We need the complete description of your card, including the make (ATI? Nvidia?)

It looks like you gave a the driver version #. We need the actual name of the file. Look in /etc/X11/xorg.conf for a section like this:
Code:
Section "Device"
    Identifier "device1"
    VendorName "ATI Technologies Inc."
    BoardName "ATI Radeon"
    Driver "radeon"
    Option "DPMS"
    Option "XaaNoOffscreenPixmaps" "1"
#    Option "IgnoreEDID" "true"
EndSection
If you have Nvidia, you'll probably see "nv" or "nvidia"

Quote:
I tried looking for their website but couldn't find it thanks, it still doesn't have it's horizontal sync and vertical refresh?
Today 05:35 AM
Just click on the link I supplied and scroll down!!
 
Old 03-22-2008, 03:51 PM   #8
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
It's nvidia, nvidia proprietary drivers, friarly up to date I would assume (installed through debians repo).
 
Old 03-22-2008, 09:49 PM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
OK.....since you don't say anything else, can I assume you have now put in the correct scan rates, and maybe gotten gtf and tried a modeline?

I promise you that 1680x1050 will work with the nvidia driver.

We also still need the details on your video card.
 
Old 03-22-2008, 10:19 PM   #10
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
gtf isn't in debian's repository. I havn't been able to find it.

My video card is an nvidia 6200 gtx 256mb (posted above).
 
Old 03-23-2008, 05:32 AM   #11
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Quote:
Originally Posted by 1veedo View Post
gtf isn't in debian's repository. I havn't been able to find it.

My video card is an nvidia 6200 gtx 256mb (posted above).
OK--sorry. I misread you post and thought you were only giving the driver name.
From Google, I think you have an Nvidia GeoForce 6200.

If you have the "nvidia" driver installed, then we are almost there.

I cannot find gtf in my repository either--that makes me think it is built-in to X.

Here's a modeline to try:
Code:
 Modeline "1680x1050"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
This goes in the "Monitor" section of xorg.conf. Then in the screen section, make this the only mode specified.

Here is an example of the final product (some stuff removed for clarity):
Code:
Section "Monitor"

    Identifier "monitor1"
    VendorName "..."
    ModelName "..."
    HorizSync ...
    VertRefresh ...
    Modeline  <<insert here>>
EndSection

Section "Device"
    Identifier "device1"
    VendorName "..."
    BoardName "..."
    Driver "nvidia"
    ..
    ..
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
        Depth 24
        Modes "1680x1050"
    EndSubsection
EndSection
 
Old 03-23-2008, 04:12 PM   #12
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
Still goes out of range. That's the same modeline I've tried before but I specified the display to be only 1680 x 1050 like you said.
 
Old 03-23-2008, 04:56 PM   #13
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Please post your version of the 3 key sections of xorg.conf (Device, Monitor, and Screen)

One thing I found setting up a Dell 24" wide-screen: I had to specify the vert scan as 59.9-60.1 to force it to go at 60Hz. (I think you can also just enter one frequency---check "man xorg.conf")
 
Old 03-23-2008, 10:23 PM   #14
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
I've connected a new computer to this monitor, running Ubuntu. I have an nvidia 8800 gtx in this computer, nvidia proprietary drivers properly installed and everything. I do have gtf installed here but the modeline is the same... and doesn't work.
Code:
  # 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
  Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
Code:
Section "Device"
	Identifier	"nVidia Corporation G80 [GeForce 8800 GTX]"
	Driver		"nvidia"
	Busid		"PCI:1:0:0"
	Option		"AddARGBVisuals"	"True"
	Option		"AddARGBGLXVisuals"	"True"
	Option		"NoLogo"	"True"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Horizsync	28-84
	Vertrefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation G80 [GeForce 8800 GTX]"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes	"1440x900"	"1280x1024"	"1280x800"	"1024x768"
	EndSubSection
EndSection
I did have "1680x1050" there but in ubuntu it wont even start X like this, in debian it would fail at 1680x1050 and go to 1440x900.
 
Old 03-23-2008, 10:34 PM   #15
1veedo
Member
 
Registered: Dec 2004
Location: WV, USA
Distribution: Gentoo, Debian
Posts: 186

Original Poster
Rep: Reputation: 34
Whoa I got it working.

Use nvidia-settings under root to change your resolution!

These parts changed.
Code:
Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 84.0
    VertRefresh     43.0 - 60.0
    ModeLine       "1680x1050_60.00" 147.1 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SceptreX20WG-NagaII"
    HorizSync       30.0 - 85.0
    VertRefresh     56.0 - 76.0
EndSection

Section "Device"
    Identifier     "nVidia Corporation G80 [GeForce 8800 GTX]"
    Driver         "nvidia"
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "NoLogo" "True"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTX"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation G80 [GeForce 8800 GTX]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Modes      "1440x900" "1280x1024" "1280x800" "1024x768"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1680x1050_60 +0+0; 1280x1024 +0+0; 1280x800 +0+0; 1024x768 +0+0"
EndSection
Thanks for helping I don't know if my other computer (debian, geforce 6200 gtx) had this option but I think I would have seen it. Maybe debian has a different version of nvidia-settings.
 
  


Reply

Tags
rate, refresh


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vertical refresh rate, horizontal sync rate. NomDeGuerre Linux - Newbie 7 10-07-2005 03:36 AM
refresh rate horizontal/vertical sync TV cjae Linux - Hardware 1 04-15-2005 11:41 PM
vertical and horizontal refresh rate of presario 2568 AI melinda_sayang Linux - Laptop and Netbook 0 10-13-2004 09:40 AM
Horizontal and vertical refresh sharpie General 5 01-24-2004 08:17 PM
Horizontal and vertical refresh rate johannes Linux - Laptop and Netbook 3 10-31-2003 06:44 AM


All times are GMT -5. The time now is 03:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration