LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-23-2005, 12:03 PM   #1
mmarkvillanueva
Member
 
Registered: May 2005
Location: Philippines
Distribution: Slackware 10.0 : Linux 2.6.7
Posts: 66

Rep: Reputation: 15
Unhappy HELP! Installing Driver for ATI 3D Rage Pro on Slackware 10


HELP! Installing Driver for ATI 3D Rage Pro

SOME SPECS

Monitor: Gateway VX700
Video: ATI 3D Rage Pro
Distro: Slackware 10.0
Downloaded Driver: fglrx-4.3.0-3.12.0.i386.rpm


WHERE IT ALL STARTED...

I can't have a resolution of 1024 or higher in X. I can only have 800 x 600. I have already tried to edit /etc/X11/xorg.conf by adding additional resolutions and editing the HorizSync and VertRefresh but it didn't work. I tried to execute xorgsetup and xorgconfig many times but it fails to start X.

Here's the generated /var/log/Xorg.0.log:

=======================================================

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/navi:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.4.26 i686 [ELF]
Current Operating System: Linux navi 2.4.26 #6 Mon Jun 14 19:07:27 PDT 2004 i686
Build Date: 05 June 2004
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May 23 23:47:46 2005
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 51 of section Monitor in file /etc/X11/xorg.conf
The HorizSync keyword must be followed by a list of numbers or ranges.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


=======================================================


NEXT STEP... DRIVER INSTALLATION

One of the persons (c_olin3404)who responded to my previous thread (http://www.linuxquestions.org/questi...ware+10+atir+3)suggested to install driver for my video. I found a thread entitled Sbing's Slackware FAQ and followed the instructions. I've download the driver fglrx-4.3.0-3.12.0.i386.rpm, converted it into tgz and followed the instructions.

The first "make.sh" went ok. Here's the output:

=======================================================

initializing...
cleaning...
patching 'highmem.h'
skipping patch 'drmP.h', not needed
skipping patch 'drm_os_inux.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agppart_be.c'
compiling './agp3.c'
compiling './i7505.c'
compiling './nvidia-agp.c'
compiling './firegl_public.c'
linking of fglrx kernel module...
duplicating results into driver repository...
done.

=======================================================

After that I executed make_install and it gives me the following output... failed!

=======================================================

-creating symlink
-recreating module dependency list
-trying a sample load of kernel module
Warning: loading /lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (c) 2002 - ATI Techologies, Starnberg, GERMANY
See http://tux.org/lkml/#export-tainted for information about tainted module
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: init_module: No such device.
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output of dmesg
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.

=======================================================

Also here is the output of dmesg: (i don't know how to view syslog)

=======================================================

Linux version 2.4.26 (root@tree) (gcc version 3.3.4) #6 Mon Jun 14 19:07:27 PDT 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000005ffe000 (usable)
BIOS-e820: 0000000005ffe000 - 0000000006000000 (reserved)
BIOS-e820: 00000000ffe00000 - 0000000100000000 (reserved)
95MB LOWMEM available.
On node 0 totalpages: 24574
zone(0): 4096 pages.
zone(1): 20478 pages.
zone(2): 0 pages.
Kernel command line: BOOT_IMAGE=Linux ro root=341
Initializing CPU#0
Detected 264.891 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 527.56 BogoMIPS
Memory: 93988k/98296k available (1844k kernel code, 3924k reserved, 618k data, 120k init, 0k highmem)
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After generic, caps: 0080f9ff 00000000 00000000 00000000
CPU: Common caps: 0080f9ff 00000000 00000000 00000000
CPU: Intel Pentium II (Klamath) stepping 04
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfcaae, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router PIIX/ICH [8086/7110] at 00:07.0
Limiting direct PCI/PCI transfers.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
Journalled Block Device driver loaded
pty: 512 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10f
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
RAMDISK driver initialized: 16 RAM disks of 7777K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 00:07.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdcMA, hddio
hda: ST34312A, ATA DISK drive
hdb: Maxtor 90432D2, ATA DISK drive
blk: queue c03b3360, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03b349c, I/O limit 4095Mb (mask 0xffffffff)
hdc: GCR-8523B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: 8420832 sectors (4311 MB) w/512KiB Cache, CHS=524/255/63, UDMA(33)
hdb: attached ide-disk driver.
hdb: host protected area => 1
hdb: 8438879 sectors (4321 MB) w/512KiB Cache, CHS=525/255/63, UDMA(33)
hdc: attached ide-cdrom driver.
hdc: ATAPI 52X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
Partition check:
hda: hda1
hdb: hdb1 hdb2
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
8regs : 438.400 MB/sec
32regs : 252.400 MB/sec
pII_mmx : 600.000 MB/sec
p5_mmx : 616.400 MB/sec
raid5: using function: p5_mmx (616.400 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.8(17/11/2003)
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 120k freed
Adding Swap: 377516k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,65), internal journal
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 60M
agpgart: Detected Intel 440LX chipset
agpgart: AGP aperture is 64M @ 0xf4000000
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
isapnp: Scanning for PnP cards...
isapnp: Card 'CS4236B'
isapnp: 1 Plug & Play card detected total
Intel ISA PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
ds: no socket drivers loaded!
PCI: Found IRQ 11 for device 00:11.0
PCI: Sharing IRQ 11 with 00:07.2
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
See Documentation/networking/vortex.txt
00:11.0: 3Com PCI 3c905 Boomerang 100baseTx at 0xdc80. Vers LK1.1.18-ac
***INVALID CHECKSUM 003e*** 00:c0:4f:91:e0:a2, IRQ 11
product code 0000 rev 00.0 date 07-03-97
Internal config register is 16302d8, transceivers 0xe040.
8K word-wide RAM 3:5 Rx:Tx split, autoselect/MII interface.
MII transceiver found at address 24, status 7849.
Enabling bus-master transmits and whole-frame receives.
00:11.0: scatter/gather enabled. h/w checksums disabled
eth0: Dropping NETIF_F_SG since no checksum feature.
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:07.2
PCI: Sharing IRQ 11 with 00:11.0
uhci.c: USB UHCI at I/O 0xdce0, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
isapnp: Scanning for PnP cards...
isapnp: Card 'CS4236B'
isapnp: 1 Plug & Play card detected total
[fglrx] Maximum main memory to use for locked dma buffers: 56 MBytes.
[fglrx:firegl_init] *ERROR* Device not found!

=======================================================

SUMMARY

So there! What is the next step that I should do? How do I fix the problem? According to a person () who responded to my question (and suggested to create my own thread that I have obtained the correct driver if I am using Slackware 10 and didn't do any upgrade on the kernel or whatsoever. My question is did I get the correct driver for my video card (i.e.,ATI 3D Rage Pro)
I just visited HCL and look for my driver (http://www.linuxquestions.org/hcl/sh...cat=182&page=1). What is Utah driver? maybe it would work...

Hoping that someone out there my respond to my query... Thanks in advance
 
Old 05-23-2005, 06:16 PM   #2
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
xorg.conf
Quote:
Parse error on line 51 of section Monitor in file /etc/X11/xorg.conf
The HorizSync keyword must be followed by a list of numbers or ranges.
(EE) Problem parsing the config file
(EE) Error parsing the config file
This just boils down to you didn't edit line 51 of your /etc/X11/xorg.conf properly.

Driver:

Looking over this again - no, this is not the correct driver *for your card*. (If your card were supported by ATi's proprietary driver, then this would be correct.) But your card isn't supported by ATi. Good news is that it's supported under X.Org by the 'mach64' driver.

On the bad side - what I've looked up so far can't make it's mind up on what else you need to do. For X.Org 6.7, I think you need to download the latest Mach64 DRI driver, then build and install that.
 
Old 05-24-2005, 01:15 PM   #3
mmarkvillanueva
Member
 
Registered: May 2005
Location: Philippines
Distribution: Slackware 10.0 : Linux 2.6.7
Posts: 66

Original Poster
Rep: Reputation: 15
i ran xorgsetup again and then edited xorg.conf using pico
the reason why i get errors is that the HorzSync and VertRefresh there is incorrect and the user must edit it first. in addition to that there are no screen resolutions indicated so i edited that to. i placed 1152x864 1024x768 800x600 640x440.

when i startx there was no error and fluxbox was launch but how come, the screen is not centered and i have to readjust the monitor. i can't change the resolution too it's still 800x600. when i launch KDE and look for the Display setting, the highest resolution available is 800x600!

i tried using knoppix 3.8.1
i was surprised that it automagically detected my ATI 3D Rage PRO and when KDE was launch i got a 1154x864 resolution!

btw here is my new xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "dri"
Load "glx"
Load "xtrap"
Load "freetype"
Load "type1"
Load "freetype"
Load "speedo"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
#DisplaySize 310 230 # mm
Identifier "Monitor0"
VendorName "GWY"
ModelName "VX700"
HorizSync 30.0 - 86.0
#HorizSync 50.0 - 0.0
VertRefresh 50.0 - 130.0
Option "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "accel" # [<bool>]
#Option "crt_display" # [<bool>]
#Option "composite_sync" # [<bool>]
#Option "hw_cursor" # [<bool>]
#Option "linear" # [<bool>]
#Option "mmio_cache" # [<bool>]
#Option "test_mmio_cache" # [<bool>]
#Option "panel_display" # [<bool>]
#Option "probe_clocks" # [<bool>]
#Option "reference_clock" # <freq>
#Option "shadow_fb" # [<bool>]
#Option "sw_cursor" # [<bool>]
Identifier "Card0"
Driver "ati"
VendorName "ATI"
BoardName "3D Rage Pro AGP 1X"
ChipSet "ati"
ChipId 0x4744
ChipRev 0x5c
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
SubSection "Display"
Depth 32
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
EndSection
 
Old 05-24-2005, 06:40 PM   #4
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
Code:
Screen 0 "Screen0" 0 0
' Screen "Screen0" ' will suffice.

Have you tried looking at the xorg.conf that Knoppix produces and using that instead?
 
Old 05-25-2005, 06:23 AM   #5
mmarkvillanueva
Member
 
Registered: May 2005
Location: Philippines
Distribution: Slackware 10.0 : Linux 2.6.7
Posts: 66

Original Poster
Rep: Reputation: 15
here is the config of knoppix which is XF86Config...

======================================================================

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/navi:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.4.26 i686 [ELF]
Current Operating System: Linux navi 2.4.26 #6 Mon Jun 14 19:07:27 PDT 2004 i686
Build DSection "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/share/fonts/latex-ttf-fonts"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "ServerFlags"
EndSection

Section "Keyboard"
Protocol "Standard"
AutoRepeat 500 5
LeftAlt Meta
RightAlt Meta
ScrollLock Compose
RightCtl Control
# This is just the default keymap for X.
# May be changed with the KDE international keyboard tool.
XkbModel "pc105"
XkbLayout "us"

# XkbOptions "ctrl:swapcaps"
# XkbKeycodes "xfree86"
# XkbTypes "default"
# XkbCompat "default"
# XkbSymbols "us(pc101)"
# XkbGeometry "pc"
# XkbRules "xfree86"
# XkbModel "pc101"
# XkbLayout "us"
EndSection

Section "Pointer"
Protocol "PS/2"
Device "/dev/mouse"
Emulate3Buttons
Emulate3Timeout 70
EndSection

# Auto-generated by mkxf86config

Section "Monitor"
Identifier "Monitor0"
VendorName "GWY"
ModelName "GWY044d"
HorizSync 30 - 86 # DDC-probed
VertRefresh 50 - 130 # DDC-probed
# These are the DDC-probed settings reported by your monitor.
# 1600x1200, 65.0Hz; hfreq=81.25, vfreq=65.00
ModeLine "1600x1200" 175.50 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1280x1024, 75.0Hz; hfreq=79.98, vfreq=75.03
ModeLine "1280x1024" 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 1024x768, 70.0Hz; hfreq=56.48, vfreq=70.07
ModeLine "1024x768" 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 72.0Hz; hfreq=48.08, vfreq=72.19
ModeLine "800x600" 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
# 800x600, 60.0Hz; hfreq=37.88, vfreq=60.32
ModeLine "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
# 640x480, 75.0Hz; hfreq=37.50, vfreq=75.00
ModeLine "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
# 640x480, 60.0Hz; hfreq=31.47, vfreq=59.94
ModeLine "640x480" 25.17 640 648 744 784 480 482 484 509 -hsync -vsync
# Extended modelines with GTF timings
# 640x480 @ 100.00 Hz (GTF) hsync: 50.90 kHz; pclk: 43.16 MHz
ModeLine "640x480" 43.16 640 680 744 848 480 481 484 509 -HSync +Vsync
# 768x576 @ 60.00 Hz (GTF) hsync: 35.82 kHz; pclk: 34.96 MHz
ModeLine "768x576" 34.96 768 792 872 976 576 577 580 597 -HSync +Vsync
# 768x576 @ 72.00 Hz (GTF) hsync: 43.27 kHz; pclk: 42.93 MHz
ModeLine "768x576" 42.93 768 800 880 992 576 577 580 601 -HSync +Vsync
# 768x576 @ 75.00 Hz (GTF) hsync: 45.15 kHz; pclk: 45.51 MHz
ModeLine "768x576" 45.51 768 808 888 1008 576 577 580 602 -HSync +Vsync
# 768x576 @ 85.00 Hz (GTF) hsync: 51.42 kHz; pclk: 51.84 MHz
ModeLine "768x576" 51.84 768 808 888 1008 576 577 580 605 -HSync +Vsync
# 768x576 @ 100.00 Hz (GTF) hsync: 61.10 kHz; pclk: 62.57 MHz
ModeLine "768x576" 62.57 768 816 896 1024 576 577 580 611 -HSync +Vsync
# 800x600 @ 100.00 Hz (GTF) hsync: 63.60 kHz; pclk: 68.18 MHz
ModeLine "800x600" 68.18 800 848 936 1072 600 601 604 636 -HSync +Vsync
# 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
ModeLine "1024x768" 113.31 1024 1096 1208 1392 768 769 772 814 -HSync +Vsync
# 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
ModeLine "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895 -HSync +Vsync
# 1152x864 @ 85.00 Hz (GTF) hsync: 77.10 kHz; pclk: 119.65 MHz
ModeLine "1152x864" 119.65 1152 1224 1352 1552 864 865 868 907 -HSync +Vsync
# 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
ModeLine "1152x864" 143.47 1152 1232 1360 1568 864 865 868 915 -HSync +Vsync
# 1280x960 @ 72.00 Hz (GTF) hsync: 72.07 kHz; pclk: 124.54 MHz
ModeLine "1280x960" 124.54 1280 1368 1504 1728 960 961 964 1001 -HSync +Vsync
# 1280x960 @ 75.00 Hz (GTF) hsync: 75.15 kHz; pclk: 129.86 MHz
ModeLine "1280x960" 129.86 1280 1368 1504 1728 960 961 964 1002 -HSync +Vsync
# 1280x960 @ 100.00 Hz (GTF) hsync: 101.70 kHz; pclk: 178.99 MHz
ModeLine "1280x960" 178.99 1280 1376 1520 1760 960 961 964 1017 -HSync +Vsync
# 1280x1024 @ 100.00 Hz (GTF) hsync: 108.50 kHz; pclk: 190.96 MHz
ModeLine "1280x1024" 190.96 1280 1376 1520 1760 1024 1025 1028 1085 -HSync +Vsync
# 1400x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 122.61 MHz
ModeLine "1400x1050" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -HSync +Vsync
# 1400x1050 @ 72.00 Hz (GTF) hsync: 78.77 kHz; pclk: 149.34 MHz
ModeLine "1400x1050" 149.34 1400 1496 1648 1896 1050 1051 1054 1094 -HSync +Vsync
# 1400x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 155.85 MHz
ModeLine "1400x1050" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -HSync +Vsync
# 1400x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 179.26 MHz
ModeLine "1400x1050" 179.26 1400 1504 1656 1912 1050 1051 1054 1103 -HSync +Vsync
# 1400x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 214.39 MHz
ModeLine "1400x1050" 214.39 1400 1512 1664 1928 1050 1051 1054 1112 -HSync +Vsync
# 1600x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 280.64 MHz
ModeLine "1600x1200" 280.64 1600 1728 1904 2208 1200 1201 1204 1271 -HSync +Vsync
# 1920x1200 @ 60.00 Hz (GTF) hsync: 74.52; pclk: 193.16 MHz
Modeline "1920x1200" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -HSync +HSync
EndSection

Section "Device"
Identifier "My Video Card"
VendorName "Unknown"
BoardName "Unknown"
# TextClockFreq 22.175
EndSection

Section "Device"
Identifier "fbdev"
VendorName "Unknown"
BoardName "Unknown"
EndSection


# Standard Server
Section "Screen"
Driver "svga"
Device "My Video Card"
Monitor "Monitor0"
Subsection "Display"
Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

# Accel. Server(s)
Section "Screen"
Driver "accel"
Device "My Video Card"
Monitor "Monitor0"
Subsection "Display"
Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

# Fallback
Section "Screen"
Driver "vga16"
Device "My Video Card"
Monitor "Monitor0"
Subsection "Display"
Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "Screen"
Driver "fbdev"
Device "fbdev"
Monitor "Monitor0"
SubSection "Display"
Depth 32
Modes "default"
EndSubSection
SubSection "Display"
Depth 24
Modes "default"
EndSubSection
SubSection "Display"
Depth 16
Modes "default"
EndSubSection
SubSection "Display"
Depth 15
Modes "default"
EndSubSection
SubSection "Display"
Depth 8
Modes "default"
EndSubSection
EndSection

======================================================================

when i used the config of knoppix which is XF86Config to replace xorg.conf i got the following error messages...

Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed May 25 18:52:56 2005
(==) Using config file: "/etc/X11/xorg.conf"
Parse warning on line 33 of section Keyboard in file /etc/X11/xorg.conf
Ignoring obsolete keyword "LeftAlt".
Parse error on line 33 of section Keyboard in file /etc/X11/xorg.conf
"Meta" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

==========================================================================

and i tried to fix the error, by deleting line 33, and then when i startx there was an error so i deleted the following line etc....
eventually xorg.conf became:

==========================================================================

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/share/fonts/latex-ttf-fonts"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "ServerFlags"
EndSection

Section "Keyboard"
Protocol "Standard"
AutoRepeat 500 5

# This is just the default keymap for X.
# May be changed with the KDE international keyboard tool.
XkbModel "pc105"
XkbLayout "us"

# XkbOptions "ctrl:swapcaps"
# XkbKeycodes "xfree86"
# XkbTypes "default"
# XkbCompat "default"
# XkbSymbols "us(pc101)"
# XkbGeometry "pc"
# XkbRules "xfree86"
# XkbModel "pc101"
# XkbLayout "us"
EndSection

Section "Pointer"
Protocol "PS/2"
Device "/dev/mouse"
Emulate3Buttons
Emulate3Timeout 70
EndSection

# Auto-generated by mkxf86config

Section "Monitor"
Identifier "Monitor0"
VendorName "GWY"
ModelName "GWY044d"
HorizSync 30 - 86 # DDC-probed
VertRefresh 50 - 130 # DDC-probed
# These are the DDC-probed settings reported by your monitor.
# 1600x1200, 65.0Hz; hfreq=81.25, vfreq=65.00
ModeLine "1600x1200" 175.50 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# 1280x1024, 75.0Hz; hfreq=79.98, vfreq=75.03
ModeLine "1280x1024" 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 1024x768, 70.0Hz; hfreq=56.48, vfreq=70.07
ModeLine "1024x768" 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 72.0Hz; hfreq=48.08, vfreq=72.19
ModeLine "800x600" 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
# 800x600, 60.0Hz; hfreq=37.88, vfreq=60.32
ModeLine "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
# 640x480, 75.0Hz; hfreq=37.50, vfreq=75.00
ModeLine "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
# 640x480, 60.0Hz; hfreq=31.47, vfreq=59.94
ModeLine "640x480" 25.17 640 648 744 784 480 482 484 509 -hsync -vsync
# Extended modelines with GTF timings
# 640x480 @ 100.00 Hz (GTF) hsync: 50.90 kHz; pclk: 43.16 MHz
ModeLine "640x480" 43.16 640 680 744 848 480 481 484 509 -HSync +Vsync
# 768x576 @ 60.00 Hz (GTF) hsync: 35.82 kHz; pclk: 34.96 MHz
ModeLine "768x576" 34.96 768 792 872 976 576 577 580 597 -HSync +Vsync
# 768x576 @ 72.00 Hz (GTF) hsync: 43.27 kHz; pclk: 42.93 MHz
ModeLine "768x576" 42.93 768 800 880 992 576 577 580 601 -HSync +Vsync
# 768x576 @ 75.00 Hz (GTF) hsync: 45.15 kHz; pclk: 45.51 MHz
ModeLine "768x576" 45.51 768 808 888 1008 576 577 580 602 -HSync +Vsync
# 768x576 @ 85.00 Hz (GTF) hsync: 51.42 kHz; pclk: 51.84 MHz
ModeLine "768x576" 51.84 768 808 888 1008 576 577 580 605 -HSync +Vsync
# 768x576 @ 100.00 Hz (GTF) hsync: 61.10 kHz; pclk: 62.57 MHz
ModeLine "768x576" 62.57 768 816 896 1024 576 577 580 611 -HSync +Vsync
# 800x600 @ 100.00 Hz (GTF) hsync: 63.60 kHz; pclk: 68.18 MHz
ModeLine "800x600" 68.18 800 848 936 1072 600 601 604 636 -HSync +Vsync
# 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
ModeLine "1024x768" 113.31 1024 1096 1208 1392 768 769 772 814 -HSync +Vsync
# 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
ModeLine "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895 -HSync +Vsync
# 1152x864 @ 85.00 Hz (GTF) hsync: 77.10 kHz; pclk: 119.65 MHz
ModeLine "1152x864" 119.65 1152 1224 1352 1552 864 865 868 907 -HSync +Vsync
# 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
ModeLine "1152x864" 143.47 1152 1232 1360 1568 864 865 868 915 -HSync +Vsync
# 1280x960 @ 72.00 Hz (GTF) hsync: 72.07 kHz; pclk: 124.54 MHz
ModeLine "1280x960" 124.54 1280 1368 1504 1728 960 961 964 1001 -HSync +Vsync
# 1280x960 @ 75.00 Hz (GTF) hsync: 75.15 kHz; pclk: 129.86 MHz
ModeLine "1280x960" 129.86 1280 1368 1504 1728 960 961 964 1002 -HSync +Vsync
# 1280x960 @ 100.00 Hz (GTF) hsync: 101.70 kHz; pclk: 178.99 MHz
ModeLine "1280x960" 178.99 1280 1376 1520 1760 960 961 964 1017 -HSync +Vsync
# 1280x1024 @ 100.00 Hz (GTF) hsync: 108.50 kHz; pclk: 190.96 MHz
ModeLine "1280x1024" 190.96 1280 1376 1520 1760 1024 1025 1028 1085 -HSync +Vsync
# 1400x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 122.61 MHz
ModeLine "1400x1050" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -HSync +Vsync
# 1400x1050 @ 72.00 Hz (GTF) hsync: 78.77 kHz; pclk: 149.34 MHz
ModeLine "1400x1050" 149.34 1400 1496 1648 1896 1050 1051 1054 1094 -HSync +Vsync
# 1400x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 155.85 MHz
ModeLine "1400x1050" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -HSync +Vsync
# 1400x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 179.26 MHz
ModeLine "1400x1050" 179.26 1400 1504 1656 1912 1050 1051 1054 1103 -HSync +Vsync
# 1400x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 214.39 MHz
ModeLine "1400x1050" 214.39 1400 1512 1664 1928 1050 1051 1054 1112 -HSync +Vsync
# 1600x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 280.64 MHz
ModeLine "1600x1200" 280.64 1600 1728 1904 2208 1200 1201 1204 1271 -HSync +Vsync
# 1920x1200 @ 60.00 Hz (GTF) hsync: 74.52; pclk: 193.16 MHz
Modeline "1920x1200" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -HSync +HSync
EndSection

Section "Device"
Identifier "Card0"
Driver "ati"
VendorName "ATI"
BoardName "3D Rage Pro AGP 1X"
ChipSet "ati"
ChipId 0x4744
ChipRev 0x5c
BusID "PCI:1:0:0"
# TextClockFreq 22.175
EndSection

#Section "Device"
# Identifier "fbdev"
# VendorName "Unknown"
# BoardName "Unknown"
#EndSection


# Standard Server
Section "Screen"
Driver "svga"
Device "Card0"
Monitor "Monitor0"
Subsection "Display"
Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

# Accel. Server(s)
Section "Screen"
Driver "accel"
Device "Card0"
Monitor "Monitor0"
Subsection "Display"
Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

# Fallback
Section "Screen"
Driver "vga16"
Device "Card0"
Monitor "Monitor0"
Subsection "Display"
Modes "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "Screen"
Driver "fbdev"
Device "fbdev"
Monitor "Monitor0"
SubSection "Display"
Depth 32
Modes "default"
EndSubSection
SubSection "Display"
Depth 24
Modes "default"
EndSubSection
SubSection "Display"
Depth 16
Modes "default"
EndSubSection
SubSection "Display"
Depth 15
Modes "default"
EndSubSection
SubSection "Display"
Depth 8
Modes "default"
EndSubSection
EndSection


==========================================================================

there are still errors like it cannot recognize fbdev and eventually i copied the Screen section of my original xorg.conf...

==========================================================================

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
SubSection "Display"
Depth 32
Modes "1152x864" "1024x768" "800x600" "640x440"
Viewport 0 0
EndSubSection
EndSection

==========================================================================

when i startx there is no more error but the resolution is still 800x600. and also the screen is not centered (just like in knoppix on intial run) so i have to adjust the monitor....

btw knoppix uses XF86Config while in slackware xorg.conf
i guess XF86Config is not compatible in xorg

btw regarding the mach64 DRI, where can i download it...
is there any instruction on how to compile and build the source?? i'm confuse and i don't know where to start. there are so many things that a newbie like me do not understand

anyway thanks for your response !


btw i also tried changing

Screen 0 "Screen0" 0 0

into

Screen "Screen0"

before doing all of these but nothing has changed
 
Old 05-25-2005, 02:48 PM   #6
mmarkvillanueva
Member
 
Registered: May 2005
Location: Philippines
Distribution: Slackware 10.0 : Linux 2.6.7
Posts: 66

Original Poster
Rep: Reputation: 15
By the way, a friends gave me this URL:
http://gentoo-wiki.com/HOWTO_DRI_wit...Source_Drivers
the page (i think) is not for noobs like me

could anyone please explain what should i do (in case i hv to compile this open source drivers)... what and where will i download the driver and some step by step procedures...

tnx
 
Old 06-08-2005, 05:43 AM   #7
mmarkvillanueva
Member
 
Registered: May 2005
Location: Philippines
Distribution: Slackware 10.0 : Linux 2.6.7
Posts: 66

Original Poster
Rep: Reputation: 15
yeepee!!!! I've fixed the resolution problem by changing the default depth from 24 into 16.

however, i cannot play videos on that resolution! i have to change the default depth into 16 whenever i want to watch movies (of course this gives me a very low resolution)!!!

and also, whenever i play games (Final Burn and Snes), the animation (the movements) is not that smooth compared to this programs when used in windows...

well although, i've fixed the resolution problem, still i need to install the video drivers.
please... could anyone give me instructions on how to install drivers for my video? i'm really confused on which driver should be downloaded. actually i really don't know where to start

please bear with me. i'm a noob. hoping that someone would respond to my question
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: installing new driver for ATI Rage Pro xiongnu Mandriva 2 10-16-2004 12:34 AM
ATI Driver for RAGE Pro Error1312 Linux - Software 10 07-24-2004 10:56 AM
ati rage pro tvout Angotull Linux - Software 0 06-15-2004 06:11 AM
ATI Rage Pro Turbo AGP Lok3 Linux - Hardware 1 12-13-2002 04:36 AM
ATI Rage Pro Support punt Linux - General 2 08-08-2001 01:57 PM


All times are GMT -5. The time now is 09:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration