LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 03-20-2005, 07:47 AM   #1
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Rep: Reputation: 15
HELP! -> Computer won't shut down! --> SOLVED <--


Greetings

Why is it that when I shut down my system, it won't turn off automatically? It comes to a point it annouces "power down" but it remains on...

I'm using Vector Linux 5.0.1 SOHO (kernel 2.4.29) dual booted with Win XP. The boot loader is Lilo.

My config is as follows:

P4 2.4
Intel motherboard with chipset 850e
512mb Rimm
hd 60gb primary master
hd 80gb primary slave
cd writer secondary master
dvd writer secondary slave
ati 8500
sb audigy

Here's Lilo.conf:

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/hda
default = linux
prompt
timeout = 100
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
bitmap = /boot/bitmap/boot.bmp
# VESA framebuffer console @ 1024x768x64k
vga = 791
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769


# End LILO global section
# Partition 1 : DOS/Windows
other = /dev/hda1
label = windows
table = /dev/hda
# Partition 2: Linux GUI mode
image = /boot/vmlinuz
root = /dev/hda7
label = linux
append = ""
read-only
My boot/config apm/acpi section:

Code:
# CONFIG_OOM_KILLER is not set
CONFIG_PM=y
CONFIG_APM=m
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
# CONFIG_APM_DO_ENABLE is not set
# CONFIG_APM_CPU_IDLE is not set
# CONFIG_APM_DISPLAY_BLANK is not set
# CONFIG_APM_RTC_IS_GMT is not set
# CONFIG_APM_ALLOW_INTS is not set
# CONFIG_APM_REAL_MODE_POWER_OFF is not set

#
# ACPI Support
#
# CONFIG_ACPI is not set
I saw in VL forums that VL normally defaults with acpi and apm, and despite this no one else is having my problem.

As for the inittab shutdown section I have:

Code:
# What to do at the "Three Finger Salute".
#ca::ctrlaltdel:/sbin/ctrlaltdel
ca::ctrlaltdel:/sbin/shutdown -a -t3 -r now
(also already tryed using "-t1 -h now")

I have my bios fully acpi enabled, despite VL not having acpi neither apm enabled, but I need it for Win XP.

Finnaly, I'm a heavy KDE user, so I really wanted to keep it having auto started and also to always shutdown from it.

Any help really apreciated

Thanks

Last edited by chocobanana; 03-24-2005 at 09:40 AM.
 
Old 03-20-2005, 08:11 AM   #2
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 30
A common reason for the computer not shutting down after showing "Power down." is that the apm module isn't loaded. Check this with lsmod - the resulting listing will show the loaded modules. If it isn't loaded, load it with the command modprobe apm . Then see if it powers off properly.

Since you use Vectorlinux, which is Slackware based, there might be an out-commented line in /etc/rc.d/rc.modules, which reads #/sbin/modprobe apm . Remove the "#" and the APM module will be loaded in future boots.

I'm unsure how ACPI and APM work together, or even if they should work together. I mean, I believe that if you use ACPI, it should take care of this by itself, end hence APM should be unnecessary. But, as I said, I'm not sure about this.
 
Old 03-20-2005, 08:42 AM   #3
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Original Poster
Rep: Reputation: 15
Hi and thanks for your reply

My rc.modules didn't have "sbin/modprobe apm", so I descided to had it myself.

But I still have the same problem.

I think the VL kernel doesn't have the apm and acpi modules compiled by deafault.

But even so, how do other VL users manage to have shutdown working properly?

BTW, I'm posting here because in VL forums I didn't manage to get a solution...

Thanks
 
Old 03-21-2005, 09:20 AM   #4
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Original Poster
Rep: Reputation: 15
Hello

Does someone know anything about this problem?

Thanks
 
Old 03-21-2005, 11:57 AM   #5
zaicheke
Member
 
Registered: Apr 2004
Distribution: Slackware 10, Open BSD 3.6, Mac OS 10.3.7, Splack 10 beta
Posts: 393

Rep: Reputation: 30
If you have an ATX motherboard (AT doesn't's support shutting down completely (i think)) you will need either acpi or apm installed
 
Old 03-21-2005, 02:43 PM   #6
twsnnva
Member
 
Registered: Oct 2003
Location: Newport News, Va
Distribution: Debian
Posts: 246

Rep: Reputation: 30
Considering you're running a P4, I would say you probably need to use ACPI, not APM. ACPI support can either be built into the kernel or not at all. There is no option to compile it as a module, only the ACPI features, button, thermal, etc... can be built as modules. To simply shut the system down you don't need any of those features, only ACPI. dmesg should show you if ACPI is enabled in the kernel.
Code:
lightning:/$ dmesg|grep ACPI
 BIOS-e820: 000000000fff0000 - 000000000fff8000 (ACPI data)
 BIOS-e820: 000000000fff8000 - 0000000010000000 (ACPI NVS)
ACPI: RSDP (v000 AMI                                       ) @ 0x000fa340
ACPI: RSDT (v001 AMIINT SiS735XX 0x00001000 MSFT 0x0100000b) @ 0x0fff0000
ACPI: FADT (v001 AMIINT SiS735XX 0x00001000 MSFT 0x0100000b) @ 0x0fff0030
ACPI: DSDT (v001    SiS      735 0x00000100 MSFT 0x0100000d) @ 0x00000000
ACPI: Subsystem revision 20040326
ACPI: IRQ9 SCI: Edge set to Level Trigger.
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [URP2] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 10 11 *12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 10 *11 12 14 15)
PCI: Using ACPI for IRQ routing
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 12
ACPI: PCI interrupt 0000:00:02.1[B] -> GSI 12 (level, low) -> IRQ 12
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:02.2[D] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:02.3[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:02.7[C] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
ACPI: PCI interrupt 0000:00:09.0[A] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI interrupt 0000:00:0b.0[A] -> GSI 12 (level, low) -> IRQ 12
ACPI: PCI interrupt 0000:00:11.0[A] -> GSI 12 (level, low) -> IRQ 12
ACPI: PCI interrupt 0000:00:11.0[A] -> GSI 12 (level, low) -> IRQ 12
ACPI: PCI interrupt 0000:00:02.2[D] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI interrupt 0000:00:02.3[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI interrupt 0000:00:0b.0[A] -> GSI 12 (level, low) -> IRQ 12
If you don't have ACPI support you shouldn't get any of this. It it's not enabled the only option is to compile a kernel with ACPI support.
 
Old 03-22-2005, 02:21 AM   #7
finnjimm
LQ Newbie
 
Registered: Mar 2005
Location: Finland
Distribution: SUSE 9.2
Posts: 19

Rep: Reputation: 0
Make sure that you don't use SMP-kernel if you have only one CPU. Your P4 might have ht-flag even though it doesn't have HyperThreading enabled. SMP+1 CPU does not shutdown properly.
 
Old 03-23-2005, 12:53 PM   #8
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Original Poster
Rep: Reputation: 15
Hi and thanks for your replies

Here's the only output of dmesg:
Code:
BIOS-e820 000000001ffc0000 - 000000001fff8000 (ACPI data)
BIOS-e820 000000001fff8000 - 0000000020000000 (ACPI NVS)
As for the SMP kernel, I think it is disabled, but I'm not sure. Vector installation had no reference to a SMP kernel. How can I check that?

thanks
 
Old 03-23-2005, 06:07 PM   #9
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You dmesg output says you don't have ACPI compiled in your kernel.

Two ways I've got it to actually turn off the box:

APM:

In the kernel
Code:
# Power management options (ACPI, APM)
#
CONFIG_PM=y
# CONFIG_SOFTWARE_SUSPEND is not set
# CONFIG_PM_DISK is not set

#
# ACPI (Advanced Configuration and Power Interface) Support
#
# CONFIG_ACPI is not set
CONFIG_ACPI_BOOT=y

#
# APM (Advanced Power Management) BIOS Support
#
CONFIG_APM=m
and in /etc/rc.d/rc.modules
Code:
#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
/sbin/modprobe apm   <- uncommented 
and in /etc/lilo.conf
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="apm=power-off"
then issue # poweroff
to shut it down.


And recently, thanks to Tinkster, it works with

ACPI

In the kernel
Code:
# Power management options (ACPI, APM)
#
CONFIG_PM=y
# CONFIG_PM_DEBUG is not set
# CONFIG_SOFTWARE_SUSPEND is not set

#
# ACPI (Advanced Configuration and Power Interface) Support
#
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_INTERPRETER=y
# CONFIG_ACPI_SLEEP is not set
# CONFIG_ACPI_AC is not set
# CONFIG_ACPI_BATTERY is not set
CONFIG_ACPI_BUTTON=y
# CONFIG_ACPI_VIDEO is not set
CONFIG_ACPI_FAN=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
CONFIG_ACPI_DEBUG=y
CONFIG_ACPI_BUS=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SYSTEM=y
# CONFIG_X86_PM_TIMER is not set
# CONFIG_ACPI_CONTAINER is not set

#
# APM (Advanced Power Management) BIOS Support
#
# CONFIG_APM is not set
Nothing in /etc/rc.d/rc.modules or /etc/lilo.conf like with APM.

And just issue # halt to shut it down.

NB: The APM option is with a 2.4.29 kernel; ACPI is 2.6.11.5
but Tink says ACPI is what he uses and on both 2.4.x and
2.6.x kernels
 
Old 03-23-2005, 08:12 PM   #10
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Original Poster
Rep: Reputation: 15
Hi

I didn't get very well the last post, I guess it's just because I'm a newbie.

Anyway, I downloaded the standard acpi enabled vector linux kernel (2.4.29), here's my new boot/config:

Code:
# ACPI Support
#
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_BUS=y
CONFIG_ACPI_INTERPRETER=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_MMCONFIG=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SYSTEM=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_ASUS=y
CONFIG_ACPI_TOSHIBA=y
# CONFIG_ACPI_DEBUG is not set
But I still can't shut it down correctly. Is there anything that can be done with this, or could you please explain the last post?

Thanks
 
Old 03-24-2005, 06:14 AM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
If you want me to check your system, post the output of the following
commands and I'll just give her a look see. And while you're at it, what
distribution is Vector Linux based on -- save me a Google search cause
I don't remember. ;-)

$ cat /etc/rc.d/rc.modules

$ cat /etc/lilo.conf

$ ls -alc /boot

$ dmesg | grep ACPI

How are you issuing the command to shut your computer down?
 
Old 03-24-2005, 07:46 AM   #12
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Original Poster
Rep: Reputation: 15
Hi

Vector Linux 5.01 SOHO is based on Slackware 10.0 or 10.1, I'm not sure which one.

Here's my rc.modules:
Code:
### Update module dependencies ###
RELEASE=`uname -r`
VERSION=`kernelversion`
# If /usr is mounted and we have 'find', we can try to take a shortcut:
if [ -x /usr/bin/find -a -e /lib/modules/$RELEASE/modules.dep \
     -a /lib/modules/$RELEASE/modules.dep -nt /etc/modules.conf ]; then
  NEWMODS="`/usr/bin/find /lib/modules/$RELEASE -type f -newer /lib/modules/$RELEASE/modules.dep`"
  # Only rebuild dependencies if new module(s) are found:
  if [ ! "" = "$NEWMODS" ]; then
    echo "Updating module dependencies for Linux $RELEASE:"
    /sbin/depmod -a
  else
    echo "Module dependencies up to date (no new kernel modules found)."
  fi
else # we don't have find, or there is no existing modules.dep, or it is out of date.
  echo "Updating module dependencies for Linux $RELEASE:"
  /sbin/depmod -A
fi

### AGP (Accelerated Graphics Port) GART support 
/sbin/modprobe agpgart

### Network device support 
if [ -x /etc/rc.d/rc.netdevice ]; then
  . /etc/rc.d/rc.netdevice
fi

## Kernel 2.4 base modules
if [ "$VERSION" = "2.4" ]; then
 
### load ide-scsi if specified on boot parameter
if grep -q "=ide-scsi " /proc/cmdline ; then
    /sbin/modprobe ide-scsi
fi

# exit immediatelly, cut further processing
exit 0

### Kernel 2.6 based modules
elif [ "$VERSION" = "2.6" ]; then

# PS/2 mouse support 
if grep -qe "MOUSETYPE.*=.*ps2" /etc/sysconfig/vector; then
    modprobe psmouse proto=imps
fi

# exit immediatelly, cut further processing
exit 0

fi # end VERSION check
Here's my lilo.conf:
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/hda
default = vector_linux
prompt
timeout = 100
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
bitmap = /boot/bitmap/boot.bmp
# VESA framebuffer console @ 1024x768x64k
vga = 791
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769


# End LILO global section
# Partition 1 : DOS/Windows
other = /dev/hda1
label = windows
table = /dev/hda
# Partition 2: Vector_Linux
image = /boot/vmlinuz
root = /dev/hda7
label = vector_linux
append = ""
read-only
# Partition 3: Vida_Linux
image = /boot/vmlinuz
root = /dev/hda8
label = vida_linux
append = ""
read-only
Here's my /boot listing:
Code:
total 6124
drwxr-xr-x   4 root       root     4096 2005-03-23 21:38 ./
drwxr-xr-x  19 root       root     4096 2005-03-24 12:32 ../
lrwxrwxrwx   1 root       root       37 2005-03-15 23:35 README.initrd -> /usr/doc/mkinitrd-1.0.1/README.initrd
lrwxrwxrwx   1 root       root       22 2005-03-23 21:13 System.map -> System.map-acpi-2.4.29
-rw-r--r--   1 mrdesigner users  653861 2005-03-23 21:13 System.map-acpi-2.4.29
-rw-r--r--   1 root       root   633830 2005-03-23 21:38 System.map-high-2.4.29
-rw-rw-r--   1 root       users  619938 2005-03-15 23:30 System.map-sata-2.4.29
drwxr-xr-x   2 root       root     4096 2005-03-15 23:30 bitmap/
-rw-r--r--   1 root       root      512 2005-03-17 21:00 boot.0300
-rw-r--r--   1 root       root      193 2005-03-15 23:30 boot.label
-rw-r--r--   1 mrdesigner users   42096 2005-03-23 21:13 config-acpi-2.4.29
-rw-r--r--   1 root       root    38517 2005-03-23 21:38 config-high-2.4.29
-rw-r--r--   1 root       root    41742 2005-03-15 23:30 config-sata-2.4.29
-rw-r--r--   1 root       root     5032 2005-03-15 23:30 diag1.img
-rw-------   1 root       root   199680 2005-03-23 20:32 map
drwxr-xr-x   2 root       root     4096 2005-03-16 00:30 tamu/
lrwxrwxrwx   1 root       root       19 2005-03-23 21:13 vmlinuz -> vmlinuz-acpi-2.4.29
-rw-r--r--   1 mrdesigner users 1346782 2005-03-23 21:13 vmlinuz-acpi-2.4.29
-rw-r--r--   1 root       root  1335160 2005-03-23 21:38 vmlinuz-high-2.4.29
-rw-rw-r--   1 root       users 1278255 2005-03-15 23:30 vmlinuz-sata-2.4.29
Here's the output of dmesg:
Code:
BIOS-e820: 000000001ffc0000 - 000000001fff8000 (ACPI data)
 BIOS-e820: 000000001fff8000 - 0000000020000000 (ACPI NVS)
I'm issuing the shutdown from KDE. I'd really like to continue doing it because I work mainly with programs with UI, so I admit I'm looking for a certain comodity. But I already tryed issuing from the command line "shutdown -t 1 -h now" both as a user and also as root, but without results.

Thanks
 
Old 03-24-2005, 08:14 AM   #13
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Something is wrong with your ACPI configuration in the kernel,
perhaps, or maybe you don't have an ACPI motherboard? You
should have more than those 2 lines for ACPI.

Since it's really long, could you post your entire contents of
/boot/config-acpi-2.4.29 at http://pastebin.com/ and then
provide the link? Perhaps it's okay to post it in here, but I'd
really like to get a look at the entire power management
section, as well as how they might have structured their
kernel different from the sources at kernel.org -- if they did.
Specifically, is there no APM enabled in your config?

Could you also post the output of "lsmod" here?

And for shutdown you only need issue "halt" if it's working
correctly for ACPI to shut the computer down.

If you have the time, you might also search Google <Linux>
for "shutdown from KDE"
 
Old 03-24-2005, 08:43 AM   #14
chocobanana
Member
 
Registered: Jun 2004
Location: Vice City
Distribution: Suse 10.1
Posts: 30

Original Poster
Rep: Reputation: 15
Hi

Here's config-acpi-2.4.29: http://pastebin.com/262089

Here's the output of lsmod:
Code:
Module                  Size  Used by    Not tainted
snd-mixer-oss          12152   0 (autoclean)
usb-storage            62336   0
radeon                104576   1
scanner                10720   0 (unused)
i810_rng                2528   0 (unused)
uhci                   24284   0 (unused)
ipt_state                536  45 (autoclean)
ipt_REJECT              3128   4 (autoclean)
ipt_limit                888   6 (autoclean)
ipt_LOG                 3448   6 (autoclean)
usb-ohci               19368   0 (unused)
ip_conntrack_ftp        3632   0 (unused)
ip_conntrack_irc        2768   0 (unused)
ip_conntrack           18440   2 [ipt_state ip_conntrack_ftp ip_conntrack_irc]
iptable_filter          1676   1 (autoclean)
ehci-hcd               17516   0 (unused)
ip_tables              12000   5 [ipt_state ipt_REJECT ipt_limit ipt_LOG iptable_filter]
usbcore                58860   1 [usb-storage scanner uhci usb-ohci ehci-hcd]
emu10k1-gp              1192   0 (unused)
gameport                1420   0 [emu10k1-gp]
ohci1394               23888   0 (unused)
ieee1394               41636   0 [ohci1394]
e100                   47636   1 (autoclean)
snd-seq-midi            3296   0 (unused)
snd-emu10k1-synth       3868   0 (unused)
snd-emux-synth         26204   0 [snd-emu10k1-synth]
snd-seq-midi-emul       4464   0 [snd-emux-synth]
snd-seq-virmidi         2712   0 [snd-emux-synth]
snd-seq-midi-event      3264   0 [snd-seq-midi snd-seq-virmidi]
snd-seq                35024   0 [snd-seq-midi snd-emux-synth snd-seq-midi-emulsnd-seq-virmidi snd-seq-midi-event]
snd-emu10k1            65860   2 [snd-emu10k1-synth]
snd-hwdep               4352   0 [snd-emux-synth snd-emu10k1]
snd-util-mem            1136   0 [snd-emux-synth snd-emu10k1]
snd-ac97-codec         52472   0 [snd-emu10k1]
snd-pcm                54504   0 [snd-emu10k1 snd-ac97-codec]
snd-timer              13412   0 [snd-seq snd-emu10k1 snd-pcm]
snd-rawmidi            12320   0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-seq-device          3812   0 [snd-seq-midi snd-emu10k1-synth snd-emux-synthsnd-seq snd-emu10k1 snd-rawmidi]
snd                    31268   2 [snd-mixer-oss snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-midi-event snd-seq snd-emu10k1 snd-hwdep snd-util-mem snd-ac97-codec snd-pcm snd-timer snd-rawmidi snd-seq-device]
soundcore               3396   5 [snd]
snd-page-alloc          4712   0 [snd-mixer-oss snd-seq-midi snd-seq snd-emu10k1 snd-hwdep snd-pcm snd-timer snd-rawmidi snd-seq-device snd]
lp                      6404   0
parport_pc             15044   1
parport                22824   1 [lp parport_pc]
agpgart                45092   3
I already tried booting with and without the apm service enabled...

Thanks
 
Old 03-24-2005, 09:10 AM   #15
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You've got APM as a module in the kernel, but it's not loading.
CONFIG_APM=m

Try to uncomment it in /etc/rc.d/rc.M if Vector has that, and see
what happens. That file should look like this:
Code:
# Start APM or ACPI daemon.
# If APM is enabled in the kernel, start apmd:
#if [ -e /proc/apm ]; then
#  if [ -x /usr/sbin/apmd ]; then
#    echo "Starting APM daemon:  /usr/sbin/apmd"
#    /usr/sbin/apmd
#  fi
elif [ -x /etc/rc.d/rc.acpid ]; then # otherwise, start acpid:
  . /etc/rc.d/rc.acpid start
fi
You can first look to see if apmd is running by issuing "ps -aux"
and if it is, then comment (put a # before) it out of that file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer doesn't turn off after shut down... figfighter Mandriva 3 07-22-2005 03:04 AM
Can't get the computer to shut off automatically KezzerDrix Mandriva 12 03-30-2005 09:07 AM
can't shut down computer - now I'm localhost? muzza Linux - Newbie 3 03-28-2005 08:15 AM
Computer Won't Shut Down djabbot Linux - General 3 01-11-2005 02:07 AM
power off the computer after shut down gary.chan Linux - Software 1 01-05-2003 11:35 AM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration