LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Headphone plugged in, sound still comes out of speakers (http://www.linuxquestions.org/questions/linux-hardware-18/headphone-plugged-in-sound-still-comes-out-of-speakers-278654/)

tbraun 01-16-2005 09:27 PM

Headphone plugged in, sound still comes out of speakers
 
Hello!

I recently installed Novell Desktop Linux (basically SuSE) on my HP/Compaq nc6000 laptop. There are only a few things which cause problems.

One of which is the fact that even though I plug in a headphone, the sound still comes out of the main speakers of the laptop. This is a dual-boot machine, and under Windows the speakers will mute if a headphone is plugged in. Under Linux, however, sound now comes out of BOTH: The headphone AND the speakers.

What can / should I configure to solve this problem?

For what it's worth, YaST tells me that I have a sound-card model:

82801DB (ICH4) AC'97 Audio Controller


Thank you very much!

Tom

fibbi 01-16-2005 10:50 PM

you need to turn headphone detection on.

Though there may be some cute YaST way to do it, assuming you're using alsa, just do the following (in a terminal of course):

be root
type "alsamixer"

it should bring up a nice mixer that you can change the levels on. Some of them are levels that you can set, others are just simple off/on switches, which you toggle by pressing "m".

Move over to "headphone detection" (it should have MM at the top, meaning it's off)
Hit "m" (should make the MM go away)
hit escape
type "alsactl store"

should work.

uphu 01-16-2005 10:59 PM

When I put speakers in it overrides my headphones for whatever reason, so what I do is just unplug my speakers. Easy as that, and it works!

tbraun 01-18-2005 04:36 PM

Hello!

Thank you for the reply, fibbi.

However, when I start the alsamixer, I don't see any 'headphone detection' option anywhere. Where could it hide? And what else could I do?

Thank you very much,

Tom


All times are GMT -5. The time now is 06:51 AM.