LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   HDMI Audio doesn't work - Debian Squeeze (Intel HDMI) (http://www.linuxquestions.org/questions/linux-hardware-18/hdmi-audio-doesnt-work-debian-squeeze-intel-hdmi-903870/)

felipefv 09-19-2011 12:25 PM

HDMI Audio doesn't work - Debian Squeeze (Intel HDMI)
 
Hi,

I'm trying to plug my computer to the TV through the HDMI output but there's no audio coming from it. The image is ok.

Reading some other posts here, I've tried to create the file "asound.conf" in /etc with the following information (two attempts):

1 - pcm.!default hdmi:Intel

2 - pcm.!default {
type plug
{
slave.pcm
type hw
card 0
device 3
}
}

I checked the card and device numbers and they are correct.

The applications used to test (aplay and speaker-test) with the parameters "-d plughw: 0.3" and "-D hw: 0.3" did not work as well.

Now, to make it worse, when Totem starts it pauses for one second (mouse too).

Well .. anyone know any solution to this problem of HDMI audio?

Infos:
Debian Squeeze (updated)
Motherboard: ASUS P7H55-M/BR
Video: Intel HDMI (onboard)

Thank you!

jayfree 09-19-2011 02:03 PM

One thing you should check, cause it happened to me. I connected pc to my tv, then switched to hdmi input on tv, then switched to hdmi output on pc, then switched to hdmi sound output(in pulse audio)on pc, the picture was ok, but no sound. Tinkered with it for hours before I realized that the tv had reset the audio input to analog because there was no sound detected from hdmi connection when it was enabled. After resetting sound input on tv to hdmi it was there. So to sum it up, make sure hdmi audio and video output are enabled before switching input on tv. Hope this helps.

felipefv 09-19-2011 02:29 PM

Quote:

Originally Posted by jayfree (Post 4476336)
One thing you should check, cause it happened to me. I connected pc to my tv, then switched to hdmi input on tv, then switched to hdmi output on pc, then switched to hdmi sound output(in pulse audio)on pc, the picture was ok, but no sound. Tinkered with it for hours before I realized that the tv had reset the audio input to analog because there was no sound detected from hdmi connection when it was enabled. After resetting sound input on tv to hdmi it was there. So to sum it up, make sure hdmi audio and video output are enabled before switching input on tv. Hope this helps.

Thanks for the reply, jayfree.

But where can I find this options? The TV doesn't have anything like that. I don't remember anything like that in Debian Squeeze (but I didn't search for "pulse audio").

jayfree 09-19-2011 02:54 PM

The tv audio settings are a little deeper in the menu than the common settings, you would have to check the manual to locate it, and they are on a per input basis, like my tv has 3 hdmi ports with individual settings for each one. I use fedora with kde, so my pulse audio settings are in the mixer for kde, Debian is foreign to me, so I'm sorry I can't be of more assistance.

felipefv 09-19-2011 02:57 PM

Quote:

Originally Posted by jayfree (Post 4476378)
The tv audio settings are a little deeper in the menu than the common settings, you would have to check the manual to locate it, and they are on a per input basis, like my tv has 3 hdmi ports with individual settings for each one. I use fedora with kde, so my pulse audio settings are in the mixer for kde, Debian is foreign to me, so I'm sorry I can't be of more assistance.

I understand. But thanks for the help. I'll try to find something at the TV menu and keep looking here for some solution.

felipefv 09-20-2011 07:12 AM

Well... to make it work, I had to run the commands:

m-a update
m-a prepare
m-a a-i -t alsa-source

I already did something like that when installing some nVidia card. But can anyone tell me what's going on when I run those commands/apps?

jayfree 09-21-2011 06:54 AM

http://wiki.debian.org/ModuleAssistant

H_TeXMeX_H 09-21-2011 08:46 AM

Can you post the output of 'lspci -k'.

This may or may not help:
http://www.linuxquestions.org/questi...2/#post4032980

dreamviewer 02-06-2012 09:47 AM

Hi All,

I just discovered this great forum when trying to find a solution to this HDMI audio on Debian problem. A great forum. Keep up the good work! :)

Now, I have an HP Pavilion Slimline s5780uk running Debian GNU/Linux 6.0.4 (squeeze) and I cannot get HDMI audio to work. The sound card is detected because the audio works well through the analogue outputs, but silence on HDMI, although the picture is fantastic. I have checked the Alsa Mixer and all options are enabled and volume controls are at the maximum.

Here is what my '/etc/modprobe.d/alsa-base.conf' looks like.

---

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

---

Can anyone shed any light on what the problem is?


Thanks for any help,



dreamviewer


All times are GMT -5. The time now is 03:33 AM.