LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   hda-intel SigmaTel STAC9200 no-sound (medion-laptop) (http://www.linuxquestions.org/questions/linux-hardware-18/hda-intel-sigmatel-stac9200-no-sound-medion-laptop-597506/)

peterrus 11-06-2007 08:23 AM

hda-intel SigmaTel STAC9200 no-sound (medion-laptop)
 
Hello, my soundcard does not seem to function properly on kubuntu, fedora, and knoppix (and maybe other distro's which I have not tried)

I found this (famous?) information script and here is the output:

link for external viewing: http://pastebin.ca/763474

Code:

!!################################
!!ALSA Information Script v 0.4.34
!!################################

!!Script ran on: Tue Nov  6 15:20:39 CET 2007


!!Linux Distribution
!!------------------

Ubuntu 7.10 \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 7.10"


!!Kernel Information
!!------------------

Kernel release:    2.6.22-14-generic
Operating System:  GNU/Linux
Architecture:      i686
Processor:        unknown
SMP Enabled:      Yes


!!ALSA Version
!!------------

Driver version:    1.0.15
Library version:    1.0.15
Utilities version:  1.0.15


!!Loaded ALSA modules
!!-------------------

snd_hda_intel


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [NVidia        ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xb0000000 irq 19


!!PCI Soundcards installed in the system
!!--------------------------------------

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)


!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:10.1 0403: 10de:026c (rev a2)
        Subsystem: 161f:205e


!!Modprobe options (Sound related)
!!--------------------------------

snd-hda-intel: model=3stack


!!Loaded sound module options
!!--------------------------

!!Module: snd_hda_intel
enable : N
id : <NULL>
index : -1
model : ref
position_fix : 0
power_save : 0
power_save_controller : Y
probe_mask : -1
single_cmd : N


!!HDA-Intel Codec information
!!---------------------------

Codec: SigmaTel STAC9200
Address: 0
Vendor Id: 0x83847690
Subsystem Id: 0x161f205e
Revision Id: 0x102201
No Modem Function Group found
Default PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
Node 0x02 [Audio Output] wcaps 0xd0401: Stereo
  Power: 0x0
Node 0x03 [Audio Input] wcaps 0x1d0541: Stereo
  Power: 0x0
  Connection: 1
    0x0a
Node 0x04 [Audio Input] wcaps 0x140311: Stereo Digital
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
  Connection: 1
    0x08
Node 0x05 [Audio Output] wcaps 0x40211: Stereo Digital
  PCM:
    rates [0x1e0]: 44100 48000 88200 96000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
Node 0x06 [Vendor Defined Widget] wcaps 0xf30201: Stereo Digital
Node 0x07 [Audio Selector] wcaps 0x300901: Stereo
  Connection: 3
    0x02* 0x08 0x0a
Node 0x08 [Pin Complex] wcaps 0x430681: Stereo Digital
  Pincap 0x0810024: IN EAPD Detect
  Pin Default 0x01c47010: [Jack] SPDIF In at Ext Rear
    Conn = RCA, Color = Yellow
  Pin-ctls: 0x20: IN
  Power: 0x0
Node 0x09 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x0810: OUT
  Pin Default 0x01447010: [Jack] SPDIF Out at Ext Rear
    Conn = RCA, Color = Yellow
  Pin-ctls: 0x40: OUT
  Connection: 2
    0x05* 0x0a
Node 0x0a [Audio Selector] wcaps 0x30090d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
  Amp-Out vals:  [0x00 0x00]
  Connection: 1
    0x0c
Node 0x0b [Audio Selector] wcaps 0x300105: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x1d 0x1d]
  Connection: 1
    0x07
Node 0x0c [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
  Amp-Out vals:  [0x04 0x04]
  Connection: 5
    0x10 0x0f* 0x0e 0x0d 0x12
Node 0x0d [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x083f: IN OUT HP Detect
  Pin Default 0x0221401f: [Jack] HP Out at Ext Front
    Conn = 1/8, Color = Green
  Pin-ctls: 0xc0: OUT HP
  Connection: 1
    0x0b
Node 0x0e [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x083f: IN OUT HP Detect
  Pin Default 0x01114010: [Jack] Speaker at Ext Rear
    Conn = 1/8, Color = Green
  Pin-ctls: 0x40: OUT
  Connection: 1
    0x0b
Node 0x0f [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0837: IN OUT Detect
  Pin Default 0x02a19020: [Jack] Mic at Ext Front
    Conn = 1/8, Color = Pink
  Pin-ctls: 0x20: IN
  Connection: 1
    0x0b
Node 0x10 [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x081737: IN OUT Detect
  Pin Default 0x01a19021: [Jack] Mic at Ext Rear
    Conn = 1/8, Color = Pink
  Pin-ctls: 0x24: IN
  Connection: 1
    0x0b
Node 0x11 [Pin Complex] wcaps 0x400104: Mono Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00]
  Pincap 0x0810: OUT
  Pin Default 0x90100140: [Fixed] Speaker at Int N/A
    Conn = Unknown, Color = Unknown
  Pin-ctls: 0x00:
  Connection: 1
    0x13
Node 0x12 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x0820: IN
  Pin Default 0x01813122: [Jack] Line In at Ext Rear
    Conn = 1/8, Color = Blue
  Pin-ctls: 0x20: IN
Node 0x13 [Audio Mixer] wcaps 0x200100: Mono
  Connection: 1
    0x07
Node 0x14 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
  Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=1
  Amp-Out vals:  [0x00]


!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116,  0 2007-11-06 15:06 /dev/snd/controlC0
crw-rw---- 1 root audio 116,  4 2007-11-06 15:06 /dev/snd/hwC0D0
crw-rw---- 1 root audio 116, 24 2007-11-06 15:06 /dev/snd/pcmC0D0c
crw-rw---- 1 root audio 116, 16 2007-11-06 15:06 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116, 25 2007-11-06 15:06 /dev/snd/pcmC0D1c
crw-rw---- 1 root audio 116, 17 2007-11-06 15:06 /dev/snd/pcmC0D1p
crw-rw---- 1 root audio 116, 33 2007-11-06 15:06 /dev/snd/timer


!!Aplay/Arecord output
!!------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [NVidia]

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 29 [94%] [-3.00dB] [on]
  Front Right: Playback 29 [94%] [-3.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Mono
  Mono: Playback [on] Capture [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Capture Mux',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 4 [100%] [40.00dB]
  Front Right: 4 [100%] [40.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Front Mic' 'Line'
  Item0: 'Front Mic'


!!All Loaded Modules
!!------------------

Module
ipv6
af_packet
rfcomm
l2cap
bluetooth
ppdev
powernow_k8
cpufreq_userspace
cpufreq_ondemand
cpufreq_stats
cpufreq_powersave
cpufreq_conservative
freq_table
sbs
video
ac
battery
button
container
dock
joydev
parport_pc
lp
parport
loop
r8180
psmouse
snd_hda_intel
ieee80211_rtl
agpgart
i2c_nforce2
pcspkr
serio_raw
k8temp
shpchp
pci_hotplug
snd_pcm
snd_timer
snd_page_alloc
snd_hwdep
snd
soundcore
i2c_core
evdev
ext3
jbd
mbcache
ide_disk
ide_cd
cdrom
amd74xx
ide_core
ehci_hcd
forcedeth
ata_generic
libata
scsi_mod
ohci_hcd
usbcore
thermal
processor
fan
fuse
apparmor
commoncap

The problem is that, I can play sounds, in all players they start playing, but I do not hear anything, not through the speakers nor the headphones. This kinda renders my laptop unusable for daily use.

I hope somebody can help me out.

edit: the model=ref option is added by me, though it does not make any difference.

I have followed this: https://help.ubuntu.com/community/HdaIntelSoundHowto so I have the latest version of alsa installed.

peterrus 11-06-2007 10:38 AM

and the aadebug script's output:

Code:

ALSA Audio Debug v0.1.0 - Tue Nov  6 17:36:58 CET 2007
http://alsa.opensrc.org/aadebug
http://www.gnu.org/licenses/gpl.txt

Kernel ----------------------------------------------------
Linux rustop-0 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Loaded Modules --------------------------------------------
snd_hda_intel        293792  2
snd_pcm                80644  1 snd_hda_intel
snd_timer              24580  1 snd_pcm
snd_page_alloc        11656  2 snd_hda_intel,snd_pcm
snd_hwdep              10628  1 snd_hda_intel
snd                    56708  8 snd_hda_intel,snd_pcm,snd_timer,snd_hwdep

Modprobe Conf ---------------------------------------------
Warning: module config file does not exist
This means any kernel modules will not be auto loaded
See your linux distro docs on how to create this file

Proc Asound -----------------------------------------------
cat: /proc/asound/{version,cards,devices,hwdep,pcm,seq/clients}: No such file or directory

Dev Snd ---------------------------------------------------
controlC0  hwC0D0  pcmC0D0c  pcmC0D0p  timer

CPU -------------------------------------------------------
model name      : AMD Turion(tm) 64 X2 Mobile Technology TL-50
cpu MHz        : 800.000
model name      : AMD Turion(tm) 64 X2 Mobile Technology TL-50
cpu MHz        : 800.000

RAM -------------------------------------------------------
MemTotal:      2010016 kB
SwapTotal:    3903784 kB

Hardware --------------------------------------------------
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control


alf_kraus 05-24-2008 02:18 AM

Hi,

I have the same soundcard and just got it working, you seem pretty close

you are using the HDA Intel chip, codec is SigmaTel STAC9200, same as I

trying out all possibilities for modprobe options as listed under "STAC9200" in /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz, this one worked:

options snd-hda-intel model=gateway

so add this line to:
/etc/modprobe.d/alsa-base

I did not have to add it to
/etc/modules (without "options")

found the description here (german):
http://wiki.ubuntuusers.de/Soundkarten_installieren/HDA

Emerson 05-24-2008 06:26 AM

:twocents: Turn off the power saving feature in kernel (for HDA-Intel).

Edit: Old thread, OP has it certainly working by now.


All times are GMT -5. The time now is 07:13 PM.