Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 10-11-2003, 11:43 PM   #1
LQ Newbie
Registered: Oct 2003
Location: Norway
Distribution: Slamd64 12.1 / Slackware 12.1
Posts: 11

Rep: Reputation: 0
have combo CD-RW/DVD, problem with SCSI emulation, can not play DVD

I have a litle problem with my combo CD-RW/DVD

When I enable SCSI emulation in /etc/lilo.conf with "append="hdc=ide-scsi" my CD-RW/DVD works as a CD/RW, but DVD's will not play, is there any way I can use both CD-RW and DVD at the same time without commenting/uncommenting that line in /etc/lilo.conf and rebooting?

I'm using Slackware 9.1 and mplayer.

Old 10-11-2003, 11:50 PM   #2
LQ Addict
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
I think what you need to do is to have
point to the same place (both are links). The easiest would be to do
ln -s /dev/cdrom /dev/dvd
Old 10-12-2003, 04:34 AM   #3
LQ Newbie
Registered: Oct 2003
Location: Phuket Island, Thailand
Posts: 1

Rep: Reputation: 0
Hi. I have a similar problem, I think... I bought a Linux machine at half price here in Thailand. The machine included CDRoast (for CD burning), but the CD was read only and not read write. So, after I ran the CD burner software for the first time, it didn't find a CD writer and now mt CD player has stopped working ever since. I think my grub.conf file is missing a line that allows the CD drive to be recognized. Question is: What should my grub.conf line look like to get my CDRom Drive to work again?
Old 10-12-2003, 09:23 AM   #4
LQ Newbie
Registered: Oct 2003
Location: UK
Distribution: SuSE 8.2/9.0 Pro, IPCop, looking at others as time allows
Posts: 18

Rep: Reputation: 0
Stunix: Theoretically you can get both CD-RW and DVD working by doing moving the links like the previous guy said.

One problem you may very well encounter is this. Under SCSI emulation the DVD drive does not appear to do DMA. As a result your DVD's will stutter and skip like crazy. I experienced this on a 1.2 GHz Athlon with a combi-drive. Yet my 400 MHz P-II with a SCSI DVD drive is as smooth as silk.

To get decent playback you have to turn off scsi emulation. The easiest way to do this is to have two identical entries in your lilo/grub config file, one with the hdc=ide-scsi parameter and one without. Then set whichever you're more likely to use as the default. I do more burning than DVD watching, so that tends to be my default. That removes one of your inconvenient steps.

Because this parameter is passed to the kernel at boot time, I don't think there is a way to change this on a running system. However I may be wrong. (If this is possible I would be very interested to know how.)

You then need to make sure your /dev/<links to real device> point to the correct place. e.g.:

w/scsi-emulation (CD-RW mode)
/dev/cdrom -> /dev/sr0
/dev/cdrecorder -> /dev/sr0
/dev/dvd -> /dev/sr0

wo/scsi-emulation (DVD mode)
/dev/cdrom -> /dev/hdc
/dev/dvd -> /dev/hdc
(as the recorder/rewriter can't be used in DVD mode, the link is not needed)

You could probably do some sort of boot script to create the correct links depending on which device (hdc or sr0) is available.

Finally, when using the system in DVD mode, make very sure that DMA mode is enabled, or all this switching between kernel parameters will count for nothing.

Eric: First identify what device the CD drive is on using something like
ide_info /dev/hd[a-d]
as root or whatever hardware info tools come with your distro. Then look at /etc/fstab and find the entry that is supposed to be the cd-rom. Then go to the /dev directory and make this link. On my system for eg:
CD is on /dev/hdc
in fstab it lists:
/dev/dvd             /media/dvd           auto       ro,noauto,user,exec   0 0
/dev/cdrecorder      /media/cdrecorder    auto       ro,noauto,user,exec   0 0
/dev/cdrom           /media/cdrom         auto       ro,noauto,user,exec   0 0
so in /dev I run the command:
ln -s /dev/dvd /dev/recorder /dev/cdrom /dev/hdc
which rebuilds all the the symbolic links to a non scsi emulated ide DVD drive. For you Eric, You probably just need to miss out the /dev/dvd and /dev/cdrecorder, as your drive doesn't have those capabilities.


Last edited by sboddy; 11-12-2003 at 07:54 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD Decrypter (without SCSI emulation) + DVD Shrink mrbass Linux - Software 5 10-25-2005 02:20 PM
how can I mount my dvd burner using SCSI emulation? Xavius Linux - Hardware 14 04-18-2005 12:38 AM
Play DVD on CDRW/DVD Combo Drive?? halo14 Linux - Laptop and Netbook 13 09-21-2004 10:21 AM
Help With SCSI Emulation with RW/DVD Drive deadjoebob Linux - Newbie 11 03-06-2004 03:48 PM
combo rom won't read/play dvd, no ans from dvd-howto sirpelidor Linux - Hardware 0 12-22-2003 12:20 PM

All times are GMT -5. The time now is 07:17 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration