LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-18-2010, 06:26 AM   #1
ReeRD
LQ Newbie
 
Registered: Apr 2010
Posts: 8

Rep: Reputation: 0
hald does not start randomly?


On my Debian system hald fails to start randomly. Logs do not show any errors.

When I restart it and it does start, the output looks like this:
Code:
root@LAPTOP:~# /etc/init.d/hal restart
Restarting Hardware abstraction layer: hald.
root@LAPTOP:~#
When I restart it and it does NOT start, the output looks like this:
Code:
root@LAPTOP:~# /etc/init.d/hal restart
Restarting Hardware abstraction layer: haldroot@LAPTOP:~#
As you can see in the latter case some expected output (".\n") is missing. Also, the return code is 1 instead of 0 which clearly indicates a failure.

I tried the same quite a few times and it's completely random. What could be the problem?

Last edited by ReeRD; 05-18-2010 at 06:40 AM.
 
Old 05-19-2010, 02:10 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
You could try starting hald at the command line with the --daemon=yes --verbose=yes options in the hope of finding the cause.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hald not running rlarion Linux - Newbie 1 03-16-2010 07:42 AM
what is hald-runner? invader44 Linux - Newbie 2 01-02-2009 09:11 AM
What are rc.messagebus and rc.hald for? FreeTinker Slackware 9 03-10-2008 04:53 PM
Kubuntu networking randomly doesn't start on boot, and needs restart andy-k Linux - Networking 11 09-09-2006 04:41 PM
hald underscorelinux Linux - Software 0 10-07-2005 10:12 AM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration