LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-10-2005, 03:02 AM   #1
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
Angry gnomemeeting crashed, now i got "video0: Device or resource busy" B


Hi, was trying to see people from the netmeeting world by using gnomemeeting, everything has been working fine, and suddently the program had no respond, so i had to issue a Kill command to take gnomemeeting away.


after that, everytime when i start gnomemeeting, it'll crash whenever i try to accept a call from someone, or i try to call someone else. And the root causing problem I've discover has to do with /dev/video and /dev/video0 (they are same thing, symbolic link)

root@localhost dev]# cat video
cat: video: Device or resource busy
[root@localhost dev]# cat video0
cat: video0: Device or resource busy
[root@localhost dev]#

if I had to chase and see where that leads to:

[root@localhost dev]# ls -l video
lr-xr-xr-x 1 root root 10 Jan 10 02:21 video -> v4l/video0
[root@localhost dev]# ls -l video0
lr-xr-xr-x 1 root root 10 Jan 10 02:21 video0 -> v4l/video0
[root@localhost dev]#

now i'm at:
root@localhost v4l]# pwd
/lib/dev-state/v4l
[root@localhost v4l]#

root@localhost v4l]# cat video0
cat: video0: Device or resource busy

so... problem now seems locate at /lib/dev-state/v41 and i'm thinking maybe the kill command i issued only killed the gnomemeeting, but not the access to the device itself, what should I be doing next step, to get my webcam start working again?

should i remove video0 and reinstall it? or is there way i can actually kill the resources?

p.s: i tried rebooting the computer, or issue a cammand "fuser /dev/video0" and still not helping heheheh

thank you

Last edited by sirpelidor; 01-10-2005 at 04:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
V4L: "cat /dev/video0: no such device"; to be sure not supported? jago25_98 Linux - Hardware 1 01-27-2005 04:04 PM
nvidia insmod: "Device or resource busy" w/GeForce 4 MX KeithSpook Linux - Hardware 4 03-03-2004 12:21 PM
problem installing KDE themes-"Mutex destroy failure:Devise or resource busy" kpachopoulos Linux - Newbie 2 02-28-2004 03:18 PM
problem installing KDE themes-"Mutex destroy failure:Devise or resource busy" kpachopoulos Linux - Software 0 02-28-2004 08:45 AM
"/dev/dsp: Device or resource busy" Cdzin Linux - Hardware 4 02-25-2004 06:39 AM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration