LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Getting a logitech webcam working with newest Skype Client (http://www.linuxquestions.org/questions/linux-hardware-18/getting-a-logitech-webcam-working-with-newest-skype-client-879083/)

shadogamon 05-05-2011 07:35 PM

Getting a logitech webcam working with newest Skype Client
 
My sister was gifted a logitech quickcam chat . The gspca_zc3xx driver is installed and running (tested with mplayer, vlc, google talk + various flash video sites) and it is running 100% ok.

it seems however that skype is STILL not interfacing directly with V4l resulting in some nasty feedback( or just no video feed) so I tried the old work around LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype (worked with my old logitech webcam on an older release) but it STILL isn't working.
here is the output
Code:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skypeERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libequinox.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libequinox.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libequinox.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libequinox.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libequinox.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libequinox.so: wrong ELF class: ELFCLASS64
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so


(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Loading IM context type 'ibus' failed
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so


(<unknown>:3545): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3545): Gtk-WARNING **: Loading IM context type 'ibus' failed

Any ideas?
Any programs used to fix must be available in source / 64 bit binaries :P

corp769 05-05-2011 08:15 PM

Code:

env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
You are tying to run it using the env command, correct? I didn't see that in your post, just want to verify. Also, have you tried running skype without doing the preload? Also, what distro are you running?

I also recommend trying to preload /usr/lib64/libv4l/v4l1compat.so to see if that would work also.

Cheers,

Josh

shadogamon 05-06-2011 05:26 AM

Yes I am running it with the env command.

And I'm using ubuntu at the moment


All times are GMT -5. The time now is 10:19 PM.