LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-02-2009, 03:59 PM   #1
sjampoo
Member
 
Registered: Jan 2009
Location: Oosterbeek, The Netherlands
Distribution: Desk and Lap: Slackware13.1 64
Posts: 203
Blog Entries: 4

Rep: Reputation: 27
Get 1366x786 working on older box * Slackware 12.2 - Nvidia drivers installed


Hello,

Been trying but getting a headache from the fuzzy view due to wrong resolution..

I got an older box here.

some specs;

Distro: Slackware 12.2, KDE 3.5

uname -r
Code:
2.6.27.7-smp
lspci -v
Code:
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2) (prog-if 00 [VGA controller])
	Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 10
	Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (32-bit, prefetchable) [size=128M]
	[virtual] Expansion ROM at dd000000 [disabled] [size=64K]
	Capabilities: [60] Power Management version 2
	Capabilities: [44] AGP version 2.0
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, rivafb, nvidia
Geforce2 MX/MX 400

I've got an Acer X163w (w stands for wide) which I would like to run in it's 1366x768 resolution.. ( which hardware wise this setup is capable since it works like a charm on windows).
I did manage to install the Nvidia drivers for this card, but it might be slightly older:

nVidia driver version:
Code:
96.43.11
My xorg.conf looks like this (bottom end):
Code:
Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer X163W"
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce2 MX/MX 400"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
But I want to have it running 1366x786.. I did put it in there manually, but it just doesn't work.. I did manage to get it ' virtually ' to 1366x768, but that just made the screen go panning ;(


Help?
What even I do, it just keeps booting back into 1024 x 768, and nowhere ( not in Krandr nor in Nvidia's X server settings under System in the KDE menu ) I have the option to choose 1366x786.

When I manually put 1366x768 in xorg.conf it looks like it just ignores the fact I put it there.


Is it the Nvidia driver that just doesn't have this resolution in there, or is it KDE or X11 that just doesn't know (yet) how to handle this strange widescreen mode?


My eyes hurt!
 
Old 06-02-2009, 04:28 PM   #2
sjampoo
Member
 
Registered: Jan 2009
Location: Oosterbeek, The Netherlands
Distribution: Desk and Lap: Slackware13.1 64
Posts: 203
Blog Entries: 4

Original Poster
Rep: Reputation: 27
My Xorg.0.log.old says, when I manually put 1366x768 in my xorg.conf:


Code:
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1366x768"; removing.
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): DPI set to (76, 102); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
So, mmm. thus an Nvidia problem, which cannot be overcome?

After I used the Nvidia X server settings program, things look like this in the Xorg.0.log:
Code:
(**) NVIDIA(0): Option "MetaModes" "nvidia-auto-select +0+0"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce2 MX/MX 400 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 03.11.01.37.00
(--) NVIDIA(0): Interlaced video modes are not supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce2 MX/MX 400 at
(--) NVIDIA(0):     PCI:1:0:0:
(--) NVIDIA(0):     Acer X163W (CRT-0)
(--) NVIDIA(0): Acer X163W (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): DPI set to (76, 102); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
as you can see: no where the 1366x786 is mentioned.
 
Old 06-03-2009, 01:30 AM   #3
sjampoo
Member
 
Registered: Jan 2009
Location: Oosterbeek, The Netherlands
Distribution: Desk and Lap: Slackware13.1 64
Posts: 203
Blog Entries: 4

Original Poster
Rep: Reputation: 27
I probably shouldn't bump this one, since it was only last night that I posted,. but I get the feeling i might have put it in the wrong forum categorie?
 
Old 06-09-2009, 02:01 AM   #4
sjampoo
Member
 
Registered: Jan 2009
Location: Oosterbeek, The Netherlands
Distribution: Desk and Lap: Slackware13.1 64
Posts: 203
Blog Entries: 4

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by sjampoo View Post
I probably shouldn't bump this one, since it was only last night that I posted,. but I get the feeling i might have put it in the wrong forum categorie?
Bump?

Please. anyone..?

Or atleast tell me it cannot be done..
 
Old 06-09-2009, 06:51 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
It is 1366 x 768
Even so, it is unique (in my experience) in not having an integer aspect ratio. For example 16:9 would be 1360x765 or 1376x774 ...Oh well....

Have you tried a modeline?
 
Old 06-09-2009, 12:41 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
That's a really old card, are you sure the resolution will even go up that high ? One thing you can try is with the nvidia drivers you can disable EDID detection, that may help.

Last edited by H_TeXMeX_H; 06-09-2009 at 12:42 PM.
 
Old 07-23-2009, 05:00 AM   #7
sjampoo
Member
 
Registered: Jan 2009
Location: Oosterbeek, The Netherlands
Distribution: Desk and Lap: Slackware13.1 64
Posts: 203
Blog Entries: 4

Original Poster
Rep: Reputation: 27
*edit*
@ H_TeXMeX_H -> Yes, as it works like a charm under W2K, I pressume it should also be capable to deliver a resolution ' this high ' under X.

--
Anyways:

Got things going last week.

Problem ( I guess ) is that 1366 isn't a multiple of 8 ( 1366/8 = 170,75).. which is not supported by, what 'they' say, the nVidia driver.

1360 or 1368 are a multiple of 8, so resolutions of 1360x768 and 1366x768 are supported and via a modeline I got them going.
1360x768 is a bit to small, so those 6 pixel lines missing really f*&k-ip the screen: unsharpness-galore
1368x768 is a bit to wide, so there's part of the desktop falling off at the left side of the screen. Not just 2 pixel rows, no,. just about 20 (estimated guess).
Just enough to: get an unscharpness-galore anyways, and have my XFCE buttons fall off.

What should I do next?
- Throw away the monitor ( it did cost me next to nothing, but it's brand new )
- Get another videocard to see if that will work
- Get back to MS windows (in W2K, it ran just fine with the resolution on 1366x768 @ 60Hz )

Last edited by sjampoo; 07-27-2009 at 04:35 PM.
 
Old 07-27-2009, 05:30 PM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Coming here from your new thread, but since it is new, with zero replies,
and I have no real solution, I didn't want to touch that thread...

Three suggestions ... (1) try the latest 96.43.13 driver; (2) search and/or post in Nvidia's Linux forum; (3) try the nv driver.

When Slackware 13.0 is released, if you upgrade you'll have an entirley
different X.Org server. It needs nothing in xorg.conf for nVidia except:
Code:
mingdao@jeremiah:~$ cat /etc/X11/xorg.conf
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection
 
Old 08-23-2009, 10:39 AM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I think you should contact nvidia and tell them about it, if it works with their Window$ drivers then I would consider this a bug in the Linux drivers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installed nvidia drivers Rita G. Debian 2 02-07-2008 07:08 AM
Installed nVidia drivers ok but.... thoffland Linux - Newbie 1 07-07-2005 12:11 PM
Installed Mandrake 10.1 but Nvidia 6800 Drivers not working? lachesis Linux - Newbie 2 02-08-2005 04:25 PM
I've installed my NVIDIA drivers but my 3D acceleration is not working? Moses420ca Linux - Newbie 7 09-02-2003 12:14 PM
Slackware problems - nVidia drivers and LAN card not working Epimetreus Slackware 2 05-31-2003 02:16 AM


All times are GMT -5. The time now is 01:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration