LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 12-19-2009, 10:07 AM   #1
h2sammo
LQ Newbie
 
Registered: Jun 2009
Posts: 6

Rep: Reputation: 0
Question gentoo on appletv no sound (hdmi or composite)


ok according to this post: http://www.nvnews.net/vbulletin/show...=124536&page=2 sound over hdmi is elusive with nvidia-drivers.

i am trying to use the composite cable but i still have no sound. can you help me troubleshoot this?
here is an ompoad of the alsamixer settings: http://omploader.org/vMzBxeQ/window.png

Code:
 localhost appletv # lsmod 
Module                  Size  Used by 
snd_seq                36860  0 
snd_seq_device          5432  1 snd_seq 
wl                   1258988  0 
snd_pcm_oss            29704  0 
snd_mixer_oss          11908  1 snd_pcm_oss 
snd_hda_codec_atihdmi     2852  1 
nvidia               9571868  28 
snd_hda_codec_realtek   182676  1 
snd_hda_intel          21312  3 
hid_logitech            5220  0 
hid_apple               5372  0 
snd_hda_codec          47240  3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel 
usbhid                 15020  0 
snd_pcm                49076  4 snd_pcm_oss,snd_hda_intel,snd_hda_codec 
snd_timer              15152  3 snd_seq,snd_pcm 
ndiswrapper           133108  0 
snd                    40552  13 snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer 
soundcore               4844  1 snd 
snd_page_alloc          7060  2 snd_hda_intel,snd_pcm
Code:
localhost appletv # lspci -k 
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Contr 
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express R 
        Kernel driver in use: pcieport-driver 
00:07.0 Performance counters: Intel Corporation Device 27a3 (rev 03) 
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02 
        Kernel driver in use: HDA Intel 
        Kernel modules: snd-hda-intel 
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02) 
        Kernel driver in use: pcieport-driver 
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02) 
        Kernel driver in use: uhci_hcd 
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02) 
        Kernel driver in use: ehci_hcd 
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2) 
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02) 
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02) 
        Kernel driver in use: PIIX_IDE 
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02) 
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1) 
        Kernel driver in use: nvidia 
        Kernel modules: nvidia 
02:00.0 Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 05) 
        Kernel driver in use: wl 
        Kernel modules: wl 
03:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10) 
        Kernel driver in use: 8139too
Code:
localhost ~ # ls -l /dev/snd 
total 0 
drwxr-xr-x 2 root root       60 Dec 18 07:32 by-path 
crw-rw---- 1 root audio 116,  0 Dec 18 07:32 controlC0 
crw-rw---- 1 root audio 116, 24 Dec 18 07:32 pcmC0D0c 
crw-rw---- 1 root audio 116, 16 Dec 18 07:41 pcmC0D0p 
crw-rw---- 1 root audio 116, 25 Dec 18 07:32 pcmC0D1c 
crw-rw---- 1 root audio 116, 17 Dec 18 07:32 pcmC0D1p 
crw-rw---- 1 root audio 116, 26 Dec 18 07:32 pcmC0D2c 
crw-rw---- 1 root audio 116, 19 Dec 18 07:32 pcmC0D3p 
crw-rw---- 1 root audio 116,  1 Dec 18 07:32 seq 
crw-rw---- 1 root audio 116, 33 Dec 18 07:32 timer
according to these guys: http://code.google.com/p/atv-bootloa...ki/atvhardware
the sound card for the composite is: Realtek ALC885 7.1+2 Channel High Definition Audio Codec but i dont see it in lspci

my menconfig settings inside hda_intel: http://omploader.org/vMzByZg I dont see a Silicon Image SI 1390 (hdmi component). But i do see the realtek codec suport.

no sound...
help?!

another thread i opened on this: http://forums.gentoo.org/viewtopic-t...ighlight-.html
 
Old 02-10-2010, 03:06 PM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 661

Rep: Reputation: 71
Hi
I really think that I didn't understand your problem, but I'll still give it a shot - just delete this if it doesn't have anything to do with your problem.

Are you trying to use the composite cable with its audio connectors because audio over hdmi for nvidia does not work or because you really want to use composite?

In any case, my audio over HDMI is working perfectly - the audio part of the graphics card is recognized as a normal audio card...
Code:
00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 SATA controller: nVidia Corporation MCP78S [GeForce 8200] AHCI Controller (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:13.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:14.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:08.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
01:0a.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 70)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8200 (rev a2)
04:00.0 PCI bridge: NEC Corporation uPD720400 PCI Express - PCI/PCI-X Bridge (rev 06)
04:00.1 PCI bridge: NEC Corporation uPD720400 PCI Express - PCI/PCI-X Bridge (rev 06)
07:00.0 PCI bridge: Integrated Device Technology, Inc. PES4T4 PCI Express Switch (rev 0e)
08:02.0 PCI bridge: Integrated Device Technology, Inc. PES4T4 PCI Express Switch (rev 0e)
08:03.0 PCI bridge: Integrated Device Technology, Inc. PES4T4 PCI Express Switch (rev 0e)
08:04.0 PCI bridge: Integrated Device Technology, Inc. PES4T4 PCI Express Switch (rev 0e)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
...and I just selected in the kernel config the entry "Build NVIDIA HDMI HD-audio codec support".

Cannot be this simple, or?
 
Old 12-25-2010, 12:43 PM   #3
h2sammo
LQ Newbie
 
Registered: Jun 2009
Posts: 6

Original Poster
Rep: Reputation: 0
you are able to get sound on appletv through HDMI with gentoo installed?

how did you do it?

I still cannot get it done (i get video over hdmi and sound over component now). I have the kernel setting you mentioned enabled for hdmi enabled for nvidia.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP dv9850es, CX20561 and HDMI sound Zup Linux - Hardware 12 02-08-2010 07:44 AM
HD ATI HDMI interfering with default sound card setting CA0106 RichardT Ubuntu 2 01-06-2010 07:21 AM
BCM4328 chipset nic (appletv) cant get onto my wireless network h2sammo Linux - Wireless Networking 1 12-16-2009 06:16 AM
Sound HDMI 780G MythTV Mplayer Xine forum1793 Linux - Hardware 13 04-26-2009 08:35 AM
No sound over HDMI Video Card with GeForce 9500GT jpacooper Linux - Hardware 2 02-03-2009 05:07 PM


All times are GMT -5. The time now is 02:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration