LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-20-2007, 06:32 AM   #1
lizard_king825
Member
 
Registered: May 2006
Posts: 47

Rep: Reputation: 15
GeForce 6100 xorg.conf Composite help please


Hi all I am running a biostar tforce 6100
fedora 6: x86_64
I have installed my driver from livna:
1.0-9746
When the box boots the splash screen is their on the computer mointor "Dell", I am trying to get the composite out to the tv working here.
I think I might be close but nothing on my tv yet?
if some one could give me a hand or give me ideas please?
thanks

below is my xorg.conf:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "off"
Option "Clone" "on"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "type1"
Load "freetype"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL P780"
HorizSync 30.0 - 85.0
VertRefresh 48.0 - 120.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Crappy Television"
HorizSync 30.0 - 50.0
VertRefresh 60.0 - 60.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6100"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6100"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "True"
BusID "PCI:0:5:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "TVStandard" "NTSC-M"
# Option "ConnectedMonitor" "TV"
Option "TVOutFormat" "COMPOSITE"
Option "TVOverScan" "0.5"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600"
EndSubSection
EndSection
 
Old 01-20-2007, 11:15 PM   #2
mayhemt
Member
 
Registered: Sep 2005
Location: irving TX
Distribution: SuSe, Kubuntu, Win$ucks
Posts: 50

Rep: Reputation: 15
Get drivers from nvidia.com & install the driver package. With it you get nvidia-settings to tweak most of the aspects. Give it a try.
 
Old 01-20-2007, 11:20 PM   #3
lizard_king825
Member
 
Registered: May 2006
Posts: 47

Original Poster
Rep: Reputation: 15
reply

Hi i have already have nvidia-settings
with the driver from livna

the nvidia-settings
doesnt show my tv

still have no composite out to the tv

thanks
 
Old 01-20-2007, 11:35 PM   #4
runnerfrog
Member
 
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
Your config looks pretty close, but at my first glimpse it lacks of an extensions section:
Code:
Section "Extensions"
Option "Composite" "Enable"
EndSection
It is possible that your card doesn't need it? _I_ never knew of any yet, so try it, unless you are sure it doesn't.
Anyway I think this is a good walkthrough and has an example xorg.conf.
Cheers.
 
Old 01-21-2007, 12:16 AM   #5
lizard_king825
Member
 
Registered: May 2006
Posts: 47

Original Poster
Rep: Reputation: 15
reply

thanks for the link
I have added them lines to my xorg.conf and restarted the box.
I am still fighting this composite out to the tv here
now when the box boots I still have the nivida splash screen on the pc,
but the tv is pure black, before it was fuzzy/static.
maybe getting closer

thank you
 
Old 01-25-2007, 11:57 AM   #6
runnerfrog
Member
 
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
I leave you here a quote with my working config for a 6600LE. Spanish lang oriented, watch out with the little details, and backup. Cheers.

Quote:

# USAGE:
# startx -- :1 -layout LAYOUT
# LAYOUT:
# - Monitor : Output to default monitor
# - TwinView : TwinView output to Monitor & TV
#
#--------------------------------------------------------------------

Section "ServerFlags"
Option "DefaultServerLayout" "Monitor"
Option "AllowMouseOpenFail" "true"
EndSection

#--------------------------------------------------------------------
# Fonts, Modules, Input devices
#--------------------------------------------------------------------

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/Type1"

EndSection

Section "Module"
Load "ddc" # ddc
Load "extmod"
Load "dbe"
Load "glx"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "USB Keyboard"
Driver "kbd"

Option "XkbModel" "logiitc"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"

Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

#--------------------------------------------------------------------
# Monitors
#--------------------------------------------------------------------

Section "Monitor"
Identifier "LCD"

VendorName "Samsung"
ModelName "SyncMaster 713bm"

Option "DPMS" "true"
HorizSync 28.0 - 96.0
VertRefresh 50.0 - 75.0
EndSection

Section "Monitor"
Identifier "TV"

Option "DPMS"
HorizSync 30-50
VertRefresh 60
EndSection

#--------------------------------------------------------------------
# Layout "Monitor" (default)
#--------------------------------------------------------------------

Section "Device"
Identifier "nVidia 6600LE"

Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "nVidia 6600LE 256MB"

Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "NoDDC" "false"
Option "NoLogo" "true"
Option "Coolbits" "true"
Option "UseEdidDPI" "true"
Option "UseEdidFreqs" "true"
Option "NvAGP" "true"
EndSection

#---------

Section "Screen"
Identifier "nVidia 6600LE LCD"
Device "nVidia 6600LE"
Monitor "LCD"
DefaultColorDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "800x600"
EndSubSection
EndSection

#---------

Section "ServerLayout"
Identifier "Monitor"
Screen 0 "nVidia 6600LE LCD" 0 0
InputDevice "USB Keyboard" "CoreKeyboard"
InputDevice "USB Mouse" "CorePointer"
EndSection

#--------------------------------------------------------------------
# Layout "TwinView"
#--------------------------------------------------------------------

Section "Device"
Identifier "nVidia 6600LE-0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "nVidia 6600LE 256MB"

Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "NoDDC" "false"
Option "NoLogo" "true"
Option "Coolbits" "true"
Option "UseEdidDPI" "true"
Option "UseEdidFreqs" "true"
Option "NvAGP" "true"

Option "TwinView" "true"
Option "TwinViewOrientation" "Clone"
Option "ConnectedMonitor" "DFP, TV"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1280x1024, 800x600"
Option "TVOutFormat" "COMPOSITE"
Option "TVStandard" "PAL-B"

BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "nVidia 6600LE-1"
Driver "nvidia"
VendorName "nVIDIA Corporation"
BoardName "nVidia 6600LE 256MB"

Option "RenderAccel" "true"
Option "NoDDC" "false"
Option "NoLogo" "false
Option "NvAGP" "true"
Option "IgnoreEDID" "true"
Option "UseEdidFreqs" "false"
Option "HWCursor" "false"

BusID "PCI:1:0:0"
Screen 1
EndSection

#----------

Section "Screen"
Identifier "nVidia 6600LE-0 LCD"
Device "nVidia 6600LE-0"
Monitor "LCD"

DefaultColorDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "800x600"
EndSubSection
EndSection

Section "Screen"
Identifier "nVidia 6600LE-1 TV"
Device "nVidia 6600LE-1"
Monitor "TV"

DefaultColorDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600"
EndSubSection
EndSection

#----------

Section "ServerLayout"
Identifier "TwinView"
Screen 0 "nVidia 6600LE-0 LCD" 0 0
Screen 1 "nVidia 6600LE-1 TV" #Rightof "Vidia 6600LE-0 LCD"
InputDevice "USB Keyboard" "CoreKeyboard"
InputDevice "USB Mouse" "CorePointer"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install nvidia drivers Geforce 6100 netscaper Linux - Hardware 4 07-24-2006 05:47 AM
geforce 6100 ololad8 Linux - Hardware 1 07-14-2006 07:10 PM
Mainboard on GeForce 6100 with 3D acceleration webdevel Linux - Hardware 3 12-21-2005 07:03 PM
post xorg.conf files: if you have a geforce fx 5700 VE come HERE! mrchaos Linux - Hardware 6 05-24-2005 11:28 PM
xorg.conf fro geforce 5200 synapse Slackware 4 01-19-2005 12:18 PM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration